14921 matches found
kernel: hv_netvsc: NULL pointer dereference in netvsc_get_ethtool_stats()
An issue was discovered in the Linux kernel through 5.16-rc6. netvscgetethtoolstats in drivers/net/hyperv/netvscdrv.c lacks check of the return value of kvmallocarray and will cause the null pointer dereference...
kernel: ASoC: cs35l41: Fix an out-of-bounds access in otp_packed_element_t
A vulnerability was found in the Linux kernel's CS35L41 driver. The constant CS35L41NUMOTPELEM is defined as 100 but is used by the arrays otpmap1 and otpmap2, which are both expected to contain only 99 elements. This mismatch causes the code to access memory past the array boundaries when...
kernel: drm/virtio: Ensure that objs is not NULL in virtio_gpu_array_put_free()
A flaw was found in the virtio-gpu module in the Linux kernel. If the initialization fails, for example, due to a fault injection, a missing check in the virtiogpuarrayputfree function can cause a NULL pointer dereference, resulting in a denial of service...
kernel: dm ioctl: prevent potential spectre v1 gadget
A vulnerability was found in the Linux kernel's dm-ioctl interface in the lookupioctl function, which accepts a user-provided cmd value that is used to index the ioctls array directly. This issue could lead to an out-of-bounds access if the CPU speculatively executes the array access before cmd i...
kernel: hv_netvsc: NULL pointer dereference in netvsc_get_ethtool_stats()
An issue was discovered in the Linux kernel through 5.16-rc6. netvscgetethtoolstats in drivers/net/hyperv/netvscdrv.c lacks check of the return value of kvmallocarray and will cause the null pointer dereference...
php: Uninitialized array in pg_query_params() leading to RCE
A vulnerability was found in PHP due to an uninitialized array in pgqueryparams function. When using the Postgres database extension, supplying invalid parameters to the parameterized query may lead to PHP attempting to free memory, using uninitialized data as pointers. This flaw allows a remote...
GSD-2022-1007002 ext2: Use kvmalloc() for group descriptor array
ext2: Use kvmalloc for group descriptor array This is an automated ID intended to aid in discovery of potential security vulnerabilities. The actual impact and attack plausibility have not yet been proven. This ID is fixed in Linux Kernel version v5.15.75 by commit...
GSD-2022-1006717 ext2: Use kvmalloc() for group descriptor array
ext2: Use kvmalloc for group descriptor array This is an automated ID intended to aid in discovery of potential security vulnerabilities. The actual impact and attack plausibility have not yet been proven. This ID is fixed in Linux Kernel version v6.0.3 by commit...
PT-2022-35555 · Linux · Linux Kernel
Name of the Vulnerable Software and Affected Versions: Linux Kernel versions prior to v5.10.150 Description: The issue concerns the use of char for section boundaries in the machvec component. It was introduced in version v2.6.23 and fixed in version v5.10.150. The actual impact and attack...
PT-2022-34972
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v6.0.3 Description The issue is related to the use of kvmalloc for the group descriptor array in ext2. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux Kernel versions...
Huawei EulerOS: Security Advisory for sqlite (EulerOS-SA-2022-2779)
The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2022 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
EulerOS 2.0 SP9 : sqlite (EulerOS-SA-2022-2779)
According to the versions of the sqlite package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : An issue was found in fts5UnicodeTokenize in ext/fts5/fts5tokenize.c in Sqlite. A unicode61 tokenizer configured to treat unicode...
EulerOS 2.0 SP9 : sqlite (EulerOS-SA-2022-2744)
According to the versions of the sqlite package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : An issue was found in fts5UnicodeTokenize in ext/fts5/fts5tokenize.c in Sqlite. A unicode61 tokenizer configured to treat unicode...
PT-2024-11889
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description The issue is related to an out-of-bounds read in the afe4404 read|write raw function. A KASAN report indicates a global-out-of-bounds read in afe4404 read raw+0x2ce/0x380. The bug is...
OESA-2022-2051 dbus security update
Security Fixes: An issue was discovered in D-Bus before 1.12.24, 1.13.x and 1.14.x before 1.14.4, and 1.15.x before 1.15.2. An authenticated attacker can cause dbus-daemon and other programs that use libdbus to crash when receiving a message with certain invalid type signatures.CVE-2022-42010 An...
CLSA-2022-1668118023 Fix CVE(s): CVE-2022-35737
SECURITY UPDATE: array-bounds overflow if billions of bytes are used in a string argument to a C API - debian/patches/CVE-2022-35737.patch: increase the size of loop variables in the printf implementation to avoid overflow. - CVE-2022-35737...
Unlimited length of LineOfCredit.ids: storage collisions
Lines of code Vulnerability details Impact There are no restrictions for ids length So malicious borrower may create many credits and replace storage slot data at some position Proof of Concept 1. LineOfCredit.ids saves array size in slot Oracle data feed is insufficiently validated in Oracle.sol...
Sudo 1.8.0 through 1.9.12 with the crypt() password backend contains a plugins/sudoers/auth/passwd.c array-out-of-bounds error that can result in a heap-based buffer over-read. This can be triggered by arbitrary local users with access to Sudo by entering a password of seven characters or fewer. The impact could vary depending on the system libraries compiler and processor architecture.
...
CVE-2022-41259
SAP SQL Anywhere - version 17.0, allows an authenticated attacker to prevent legitimate users from accessing a SQL Anywhere database server by crashing the server with some queries that use an ARRAY constructor...
CVE-2022-41259
SAP SQL Anywhere - version 17.0, allows an authenticated attacker to prevent legitimate users from accessing a SQL Anywhere database server by crashing the server with some queries that use an ARRAY constructor...