14917 matches found
CVE-2022-38072: Incorrect Access of Indexable Resource
An improper array index validation vulnerability exists in the stlfixnormaldirections functionality of ADMesh Master Commit 767a105 and v0.98.4. A specially-crafted stl file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability...
PT-2023-36075 · Admesh · Admesh
Name of the Vulnerable Software and Affected Versions: ADMesh versions prior to the fixed version Description: The issue is related to improper array index validation in the stl fix normal directions functionality. This can be exploited by providing a specially-crafted stl file, leading to a heap...
ADMesh stl_fix_normal_directions improper array index validation vulnerability
Talos Vulnerability Report TALOS-2022-1594 ADMesh stlfixnormaldirections improper array index validation vulnerability April 3, 2023 CVE Number CVE-2022-38072 SUMMARY An improper array index validation vulnerability exists in the stlfixnormaldirections functionality of ADMesh Master Commit 767a10...
PT-2023-13581 · Admesh · Admesh
Name of the Vulnerable Software and Affected Versions: ADMesh versions 0.98.4 and Master Commit 767a105 Description: An improper array index validation issue exists in the stl fix normal directions functionality, which can lead to a heap buffer overflow when a specially-crafted stl file is...
dMute.sol: Attacker can push lock items to victim's array such that redemptions are forever blocked
Lines of code Vulnerability details Impact This report deals with how an attacker can abuse the fact that he can lock MUTE tokens for any other user and thereby push items to the array of UserLockInfo structs of the user. There are two functions in the dMute contract that iterate over all items i...
CVE-2022-37376
This vulnerability allows remote attackers to disclose sensitive information on affected installations of Foxit PDF Editor 11.1.1.53537. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists...
CVE-2022-37376
CVE-2022-37376 affects Foxit PDF Editor 11.1.1.53537. The flaw lies in the handling of arrays, where actions in JavaScript can trigger a read past the end of an allocated object, enabling sensitive information disclosure. User interaction is required (target must visit a malicious page or open a ...
DOS attack to RedeemTo() and GetUnderlyingTokens(), leading to loss of funds.
Lines of code Vulnerability details Impact Detailed description of the impact of this finding. An attacker can launch a DOS attack to RedeemTo and GetUnderlyingTokens so that it will always fail for a particular account, say Bob. In this way, Bob will not be able to redeem the MuteToken locked...
AZL-35320 CVE-2023-25675 affecting package tensorflow for versions less than 2.11.1-1
TensorFlow is an open source machine learning platform. When running versions prior to 2.12.0 and 2.11.1 with XLA, tf.rawops.Bincount segfaults when given a parameter weights that is neither the same shape as parameter arr nor a length-0 tensor. A fix is included in TensorFlow 2.12.0 and 2.11.1...
EulerOS 2.0 SP11 : ppp (EulerOS-SA-2023-1576)
According to the versions of the ppp package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : - A vulnerability classified as problematic has been found in ppp. Affected is the function dumpppp of the file pppdump/pppdump.c of the component...
Deno buffer error vulnerability
Deno is open source a simple , modern and secure JavaScript and TypeScript runtime environment . It uses V8 and is built with Rust. A security vulnerability exists in Deno versions prior to 1.32.1, which stems from a resizable array passed to an asynchronous function being shrunk during an...
UBUNTU-CVE-2023-1436
An infinite recursion is triggered in Jettison when constructing a JSONArray from a Collection that contains a self-reference in one of its elements. This leads to a StackOverflowError exception being thrown...
Important: sqlite
Issue Overview: SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to a C API. CVE-2022-35737 Affected Packages: sqlite Issue Correction: Run dnf update sqlite --releasever 2023.0.20230322 or dnf update --advisor...
Amazon Linux 2023 : apr, apr-devel (ALAS2023-2023-016)
It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2023-016 advisory. An out-of-bounds array read in the aprtimeexp functions was fixed in the Apache Portable Runtime 1.6.3 release CVE-2017-12613. The fix for this issue was not carried forward to the APR 1.7.x...
CLSA-2023-1679350071 php: Fix of 3 CVEs
CVE-2023-0567: crypt: Fix validation of malformed BCrypt hashes - CVE-2023-0568: Fix array overrun when appending slash to paths - CVE-2023-0662: Fix DoS vulnerability when parsing multipart request body...
CBL Mariner 2.0 Security Update: tensorflow (CVE-2022-41884)
The version of tensorflow installed on the remote CBL Mariner 2.0 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the CVE-2022-41884 advisory. - TensorFlow is an open source platform for machine learning. If a numpy array is created with a shape suc...
CBL Mariner 2.0 Security Update: kernel (CVE-2021-43389)
The version of kernel installed on the remote CBL Mariner 2.0 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the CVE-2021-43389 advisory. - An issue was discovered in the Linux kernel before 5.14.15. There is an array-index-out-of-bounds flaw in th...
EulerOS 2.0 SP10 : ppp (EulerOS-SA-2023-1560)
According to the versions of the ppp package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : - A vulnerability classified as problematic has been found in ppp. Affected is the function dumpppp of the file pppdump/pppdump.c of the component...
OESA-2023-1174 kernel security update
The Linux Kernel, the operating system core itself. Security Fixes: In bindertransactionbufferrelease of binder.c, there is a possible use after free due to improper input validation. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction...
Ghost Foundation node-sqlite3 code execution vulnerability
Talos Vulnerability Report TALOS-2022-1645 Ghost Foundation node-sqlite3 code execution vulnerability March 16, 2023 CVE Number CVE-2022-43441 SUMMARY A code execution vulnerability exists in the Statement Bindings functionality of Ghost Foundation node-sqlite3 5.1.1. A specially-crafted Javascri...