55 matches found
EUVD-2026-116709
A vulnerability has been identified in armeria-saml versions prior to 1.41.1, where attacker-controlled RelayState is reflected into the HTTP Location header after successful authentication, allowing an unvalidated redirect to an attacker-controlled URL...
CVE-2026-11753
A vulnerability exists in armeria-saml versions prior to 1.41.1 where an attacker-controlled RelayState is reflected into the HTTP Location header following successful authentication. This flaw allows for an unvalidated redirect to an attacker-controlled URL. No specific exploit information or re...
CVE-2026-11749
A vulnerability exists in armeria-saml prior to version 1.41.1 because bearer assertions are not enforced for one-time use. This flaw allows an attacker to replay previously consumed assertion IDs while they remain within their validity period. The impact includes unauthorized access or session r...
EUVD-2026-116708
A vulnerability has been identified in armeria-saml prior to 1.41.1, where bearer assertions are not enforced for one-time use, allowing replay of previously consumed assertion IDs within their validity period...
EUVD-2024-0511
Malicious code in bioql PyPI...
CVE-2024-1735
A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later...
com.linecorp.centraldogma:centraldogma-server-auth-saml (>=0.45.0, <=0.64.2) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (>=1.0.0, <=1.27.1)
com.linecorp.armeria:armeria-saml MAVEN version =1.0.0, =0.45.0, =0.64.2 Source cves: CVE-2024-1735 Source advisory: OSV:GHSA-4M6J-23P2-8C54...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.39.0) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.84.0)
com.linecorp.armeria:armeria-saml MAVEN version 0.84.0 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.39.0 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.44.8) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.99.2)
com.linecorp.armeria:armeria-saml MAVEN version 0.99.2 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.44.8 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.40.0) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.87.0)
com.linecorp.armeria:armeria-saml MAVEN version 0.87.0 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.40.0 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.33.0) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.76.2)
com.linecorp.armeria:armeria-saml MAVEN version 0.76.2 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.33.0 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.41.2) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.90.2)
com.linecorp.armeria:armeria-saml MAVEN version 0.90.2 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.41.2 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.43.4) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.97.0)
com.linecorp.armeria:armeria-saml MAVEN version 0.97.0 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.43.4 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.44.9) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.99.4)
com.linecorp.armeria:armeria-saml MAVEN version 0.99.4 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.44.9 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.44.2) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.98.2)
com.linecorp.armeria:armeria-saml MAVEN version 0.98.2 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.44.2 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.43.3) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.96.0)
com.linecorp.armeria:armeria-saml MAVEN version 0.96.0 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.43.3 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.44.3) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.98.3)
com.linecorp.armeria:armeria-saml MAVEN version 0.98.3 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.44.3 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.44.12) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.99.7)
com.linecorp.armeria:armeria-saml MAVEN version 0.99.7 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.44.12 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.43.0) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.93.0)
com.linecorp.armeria:armeria-saml MAVEN version 0.93.0 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.43.0 Source cves: CVE-2024-1735...
com.linecorp.centraldogma:centraldogma-server-auth-saml (0.41.4) potentially affected by CVE-2024-1735 via com.linecorp.armeria:armeria-saml (0.91.0)
com.linecorp.armeria:armeria-saml MAVEN version 0.91.0 is affected by a known vulnerability. The following packages have a transitive dependency on com.linecorp.armeria:armeria-saml and may be impacted: - com.linecorp.centraldogma:centraldogma-server-auth-saml 0.41.4 Source cves: CVE-2024-1735...