25 matches found
Linux Distros Unpatched Vulnerability : CVE-2026-102829
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of...
ROOT-APP-NPM-AIKIDO-2026-455143 AIKIDO-2026-455143 in @simple-git/argv-parser - Patched by Root
Root has patched AIKIDO-2026-455143 in the @simple-git/argv-parser package for Root:npm. Multiple fixed versions available...
ROOT-APP-NPM-CVE-2026-102829 CVE-2026-102829 in @simple-git/argv-parser - Patched by Root
Root has patched CVE-2026-102829 in the @simple-git/argv-parser package for Root:npm. Multiple fixed versions available...
simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection
Security control bypass in @simple-git/argv-parser: Git's VISUAL editor fallback is not classified as allowUnsafeEditor Report metadata | Field | Value | | --- | --- | | Package | @simple-git/argv-parser npm, pkg:npm/%40simple-git/argv-parser | | Repository | https://github.com/steveukx/git-js | ...
@strapi/upgrade (>=0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, <=0.0.0-next.5613eaed044dde893bdffc7c01a9e38754f363eb), ag-toolkit (0.7.0) +2 more potentially affected by CVE-2026-102829 via @simple-git/argv-parser (2.0.0)
@simple-git/argv-parser NPM version 2.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on @simple-git/argv-parser and may be impacted: - @strapi/upgrade =0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, =4.0.0, =4.0.1 Source cves:...
@strapi/upgrade (>=0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, <=0.0.0-next.5613eaed044dde893bdffc7c01a9e38754f363eb), ag-toolkit (0.7.0) +2 more potentially affected by CVE-2026-102829 via @simple-git/argv-parser (2.0.0)
@simple-git/argv-parser NPM version 2.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on @simple-git/argv-parser and may be impacted: - @strapi/upgrade =0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, =4.0.0, =4.0.1 Source cves:...
EUVD-2026-89336
simple-git: VISUAL editor environment variable is omitted from unsafe editor detection...
GHSA-V5RQ-49VH-5V5C simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection
Security control bypass in @simple-git/argv-parser: Git's VISUAL editor fallback is not classified as allowUnsafeEditor Report metadata | Field | Value | | --- | --- | | Package | @simple-git/argv-parser npm, pkg:npm/%40simple-git/argv-parser | | Repository | https://github.com/steveukx/git-js | ...
Arbitrary Command Injection
Overview simple-git is a light weight interface for running git commands in any node.js application. Affected versions of this package are vulnerable to Arbitrary Command Injection via the detect-vulnerable-config-writes path in the argv-parser package, where unsanitised arguments passed to git...
Command Injection
Overview Affected versions of this package are vulnerable to Command Injection via the prepareEnv function in parse-env.ts, which fails to recognize the VISUAL environment variable as a tracked unsafe editor key. Because VISUAL is not included in the GitEnvKeys map, it is silently discarded befor...
@strapi/upgrade (>=0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, <=0.0.0-next.5613eaed044dde893bdffc7c01a9e38754f363eb), ag-toolkit (0.7.0) +2 more potentially affected by CVE-2026-102829 via @simple-git/argv-parser (2.0.0)
@simple-git/argv-parser NPM version 2.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on @simple-git/argv-parser and may be impacted: - @strapi/upgrade =0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, =4.0.0, =4.0.1 Source cves:...
CVE-2026-102829
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of the argv-parser package, parseEnv omits VISUAL from GitEnvKeys, so prepareEnv drops the value before vulnerabilityCheck can classify it a...
CVE-2026-102829 simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of the argv-parser package, parseEnv omits VISUAL from GitEnvKeys, so prepareEnv drops the value before vulnerabilityCheck can classify it a...
CVE-2026-102829 simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of the argv-parser package, parseEnv omits VISUAL from GitEnvKeys, so prepareEnv drops the value before vulnerabilityCheck can classify it a...
CVE-2026-102829
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of the argv-parser package, parseEnv omits VISUAL from GitEnvKeys, so prepareEnv drops the value before vulnerabilityCheck can classify it a...
CVE-2026-102829
The simple-git library, which allows Node.js applications to execute Git operations, is vulnerable due to a flaw in the argv-parser package prior to version 2.0.1 . The parseEnv function omits VISUAL from GitEnvKeys, causing prepareEnv to drop the value before vulnerabilityCheck can identify it a...
2context (>=0.1.0, <=0.2.0), 5etools-utils (>=0.16.0, <=0.17.24) +8145 more potentially affected by CVE-2026-102829 via @simple-git/argv-parser (>=1.1.1, <=2.0.0)
@simple-git/argv-parser NPM version =1.1.1, =0.1.0, =0.16.0, =0.0.112-rc1, =1.0.0-beta.1, =1.0.0, =0.0.2, =1.0.0, =1.0.0, =1.25.0, =2.0.0, =1.0.3, =1.1.0, =0.1.0, =0.1.0, =0.1.0, =0.2.0 and more Source cves: CVE-2026-102829 Source advisory: MEND:CVE-2026-102829...
CVE-2026-102829 simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of the argv-parser package, parseEnv omits VISUAL from GitEnvKeys, so prepareEnv drops the value before vulnerabilityCheck can classify it a...
2context (>=0.1.0, <=0.2.0), 5etools-utils (>=0.16.0, <=0.17.24) +8145 more potentially affected by CVE-2026-102828 via @simple-git/argv-parser (1.1.1)
@simple-git/argv-parser NPM version 1.1.1 is affected by a known vulnerability. The following packages have a transitive dependency on @simple-git/argv-parser and may be impacted: - 2context =0.1.0, =0.16.0, =0.0.112-rc1, =1.0.0-beta.1, =1.0.0, =0.0.2, =1.0.0, =1.0.0, =1.25.0, =2.0.0, =1.0.3,...
2context (>=0.1.0, <=0.2.0), 5etools-utils (>=0.16.0, <=0.17.24) +8145 more potentially affected by CVE-2026-102826 via @simple-git/argv-parser (1.1.1)
@simple-git/argv-parser NPM version 1.1.1 is affected by a known vulnerability. The following packages have a transitive dependency on @simple-git/argv-parser and may be impacted: - 2context =0.1.0, =0.16.0, =0.0.112-rc1, =1.0.0-beta.1, =1.0.0, =0.0.2, =1.0.0, =1.0.0, =1.25.0, =2.0.0, =1.0.3,...