251 matches found
CVE-2021-38297
Exploiting CVE-2021-38297: Vulnerability in GO Wasm Buffer Overflow Overview of the Vulnerability WebAssembly WASM serves as a binary instruction format executable in most modern web browsers. It acts as a compilation target for various high-level languages like C, C++, Rust, and GO, allowing cod...
codeql-sample-polkit
-- coding: utf-8 - - The polkit pkexec bug Overview This repository examines the polkit pkexec bug using CodeQL. It has instructions for building the databases the resultant databases a sequence of queries illustrating an approach to find this bug These are done: the polkit source / database buil...
CVE-2021-38297-Go-wasm-Replication
🚨 Exploiting CVE-2021-38297: A Journey into GO Wasm Buffer Overflow 🚨 🌐 Overview of the Vulnerability 🌐 WebAssembly WASM 🌍, a cutting-edge binary instruction format, enables the seamless execution of high-level languages like C, C++, Rust, and GO in modern web browsers. However, the discovery of...
CVE-2021-4034
CVE-2021-4034 Local privilege escalation via pkexec YouTube video Watch the ✨ YouTube Video Run locally make all && ./pwnkit && make clean Run in docker Build the docker image docker build -t pwnkit . Run the exploit docker run -it pwnkit bash make all && ./pwnkit && make clean Detect using...
CVE-2024-52301
CVE-2024-52301 POC This vulnerability is based on the CVE-2024-50340 vulnerability Requirements The registerargcargv option must be enabled in the PHP configuration file php.ini. This setting loads command-line arguments and query params into $SERVER'argv'...
CVE-2026-46529
RCE via PDF argv injection CVE-2026-46529 atril/xreader/evince Working proof-of-concept for the argv injection in evspawn shell/ev-application.c. A single click anywhere on the rendered page of a crafted PDF triggers arbitrary code execution as the user running the viewer. This release uses the...
CLSA-2026-1792758525 TuxCare security update for @simple-git/argv-parser (3 CVEs)
TuxCare rebuilt @simple-git/argv-parser to address 3 CVEs. Fixed in 1.1.1-tuxcare.2...
CLSA-2026-1792595414 TuxCare security update for @simple-git/argv-parser (1 CVE)
TuxCare rebuilt @simple-git/argv-parser to address 1 CVE. Fixed in 1.1.1-tuxcare.1...
Linux Distros Unpatched Vulnerability : CVE-2026-102829
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of...
Astra Linux – Vulnerability in Linux 5.15
In the Linux kernel, the following vulnerabilities have been resolved: ksmbd: fixed a possible memory leak in smb2lock. argv needs to be freed when setupasyncwork fails, or when the current process is awakened...
Astra Linux – Vulnerability in Composer
Composer is a dependency manager for PHP. Users who publish a composer.phar file to a publicly accessible web server where the file can be executed as a PHP file may be subject to a remote code execution vulnerability if PHP also has registerargcargv enabled in php.ini. Versions 2.6.4, 2.2.22, an...
ROOT-APP-NPM-AIKIDO-2026-455143 AIKIDO-2026-455143 in @simple-git/argv-parser - Patched by Root
Root has patched AIKIDO-2026-455143 in the @simple-git/argv-parser package for Root:npm. Multiple fixed versions available...
ROOT-APP-NPM-CVE-2026-102829 CVE-2026-102829 in @simple-git/argv-parser - Patched by Root
Root has patched CVE-2026-102829 in the @simple-git/argv-parser package for Root:npm. Multiple fixed versions available...
PT-2026-122658
Root has patched AIKIDO-2026-455143 in the @simple-git/argv-parser package for Root:npm. Multiple fixed versions available...
@strapi/upgrade (>=0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, <=0.0.0-next.5613eaed044dde893bdffc7c01a9e38754f363eb), ag-toolkit (0.7.0) +2 more potentially affected by CVE-2026-102829 via @simple-git/argv-parser (2.0.0)
@simple-git/argv-parser NPM version 2.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on @simple-git/argv-parser and may be impacted: - @strapi/upgrade =0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, =4.0.0, =4.0.1 Source cves:...
@strapi/upgrade (>=0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, <=0.0.0-next.5613eaed044dde893bdffc7c01a9e38754f363eb), ag-toolkit (0.7.0) +2 more potentially affected by CVE-2026-102829 via @simple-git/argv-parser (2.0.0)
@simple-git/argv-parser NPM version 2.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on @simple-git/argv-parser and may be impacted: - @strapi/upgrade =0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, =4.0.0, =4.0.1 Source cves:...
simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection
Security control bypass in @simple-git/argv-parser: Git's VISUAL editor fallback is not classified as allowUnsafeEditor Report metadata | Field | Value | | --- | --- | | Package | @simple-git/argv-parser npm, pkg:npm/%40simple-git/argv-parser | | Repository | https://github.com/steveukx/git-js | ...
EUVD-2026-89336
simple-git: VISUAL editor environment variable is omitted from unsafe editor detection...
GHSA-V5RQ-49VH-5V5C simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection
Security control bypass in @simple-git/argv-parser: Git's VISUAL editor fallback is not classified as allowUnsafeEditor Report metadata | Field | Value | | --- | --- | | Package | @simple-git/argv-parser npm, pkg:npm/%40simple-git/argv-parser | | Repository | https://github.com/steveukx/git-js | ...
CVE-2026-103431
colmux in collectl before 4.3.20.2 does not sanitize ANSI/VT100 terminal escape sequences in data received from remote collectl instances before displaying it, allowing a local user on a monitored host to inject escape sequences into the terminal of an operator running colmux, via a crafted proce...