13198 matches found
ant: excessive memory allocation when reading a specially crafted TAR archive
When reading a specially crafted TAR archive an Apache Ant build can be made to allocate large amounts of memory that finally leads to an out of memory error, even for small inputs. This can be used to disrupt builds using Apache Ant. Apache Ant prior to 1.9.16 and 1.10.11 were affected...
CVE-2022-25168: Improper Neutralization of Special Elements used in an OS Command
Apache Hadoop's FileUtil.unTarFile, File API does not escape the input file name before being passed to the shell. An attacker can inject arbitrary commands. This is only used in Hadoop 3.3 InMemoryAliasMap.completeBootstrapTransfer, which is only ever run by a local user. It has been used in...
PT-2022-3981
Name of the Vulnerable Software and Affected Versions Apache Hadoop versions prior to 2.10.2 Apache Hadoop versions prior to 3.2.4 Apache Hadoop versions prior to 3.3.3 Description The issue is related to the FileUtil.unTarFile, File API in Apache Hadoop, which does not escape the input file name...
CVE-2022-31195 Path traversal vulnerability in Simple Archive Format package import in DSpace
DSpace open source software is a repository application which provides durable access to digital resources. In affected versions the ItemImportServiceImpl is vulnerable to a path traversal vulnerability. This means a malicious SAF simple archive format package could cause a file/directory to be...
CVE-2022-31195 Path traversal vulnerability in Simple Archive Format package import in DSpace
DSpace open source software is a repository application which provides durable access to digital resources. In affected versions the ItemImportServiceImpl is vulnerable to a path traversal vulnerability. This means a malicious SAF simple archive format package could cause a file/directory to be...
golang: compress/gzip: stack exhaustion in Reader.Read
A flaw was found in golang. Calling the Reader, Read method on an archive that contains a large number of concatenated 0-length compressed files can cause a panic issue due to stack exhaustion...
DSpace path traversal vulnerability
DSpace is an open source turnkey repository application from the DuraSpace community. A path traversal vulnerability exists in DSpace versions 4.0 through 6.3, which stems from the intention that the SAF Simple Archive Format package could lead to the creation of files/directories in any location...
[SECURITY] Fedora 36 Update: golang-github-vbatts-tar-split-0.11.1-11.fc36
Pristinely disassembling a tar archive, and stashing needed raw bytes and offsets to reassemble a validating original archive...
Untangling KNOTWEED: European private-sector offensive actor using 0-day exploits
The Microsoft Threat Intelligence Center MSTIC and the Microsoft Security Response Center MSRC found a private-sector offensive actor PSOA using multiple Windows and Adobe 0-day exploits, including one for the recently patched CVE-2022-22047, in limited and targeted attacks against European and...
Arbitrary file write vulnerability in clif-performance-testing
clif-performance-testing 64.vc0d66de1dfbf and earlier allows users to extract files from an archive without validating file paths of files contained within the archive. This allows attackers with Overall/Read permission to create or replace arbitrary files on the Jenkins controller file system wi...
Command Injection
git-archive is vulnerable to command injection. A local authenticated attacker is able to inject and execute malicious commands through the exports function in index.js...
lambda_pattern (>=0.0.15, <=0.0.31), push2cloud-cli (>=1.0.0, <=2.0.3) +3 more potentially affected by CVE-2020-28422 via git-archive (0.1.4)
git-archive NPM version 0.1.4 is affected by a known vulnerability. The following packages have a transitive dependency on git-archive and may be impacted: - lambdapattern =0.0.15, =1.0.0, =1.0.0, =2.0.4 - push2cloud-compiler-rf 2.0.2 Source cves: CVE-2020-28422 Source advisory:...
git-archive vulnerable to Command Injection via exports function
All versions of package git-archive are vulnerable to Command Injection via the exports function...
GHSA-VQGR-MFXM-47F3 git-archive vulnerable to Command Injection via exports function
All versions of package git-archive are vulnerable to Command Injection via the exports function...
lambda_pattern (>=0.0.15, <=0.0.31), push2cloud-cli (>=1.0.0, <=2.0.3) +3 more potentially affected by CVE-2020-28422 via git-archive (0.1.4)
git-archive NPM version 0.1.4 is affected by a known vulnerability. The following packages have a transitive dependency on git-archive and may be impacted: - lambdapattern =0.0.15, =1.0.0, =1.0.0, =2.0.4 - push2cloud-compiler-rf 2.0.2 Source cves: CVE-2020-28422 Source advisory: GHSA-VQGR-MFXM-47...
CVE-2020-28422
All versions of package git-archive are vulnerable to Command Injection via the exports function...
Command injection
All versions of package git-archive are vulnerable to Command Injection via the exports function...
CVE-2020-28422
All versions of package git-archive are vulnerable to Command Injection via the exports function...
CVE-2020-28422 Command Injection
All versions of package git-archive are vulnerable to Command Injection via the exports function...
CVE-2020-28422
CVE-2020-28422 affects the git-archive module, where the vulnerability is a command injection via the exports function . All versions are reported vulnerable, enabling a local attacker to execute arbitrary commands through the exports function. The issue has been consistently described across mul...