166670 matches found
CVE-2026-92125: Improper Control of Generation of Code
Jenkins Script Security Plugin 1415.v9af9b3ac253d and earlier does not reject the @GroovyASTTransformationClass annotation, allowing attackers with permission to define and run sandboxed scripts, including Pipelines, to run an arbitrary AST transformation at compile time, bypassing the sandbox...
PT-2026-93422
Name of the Vulnerable Software and Affected Versions Apache Airflow Apache Kafka provider versions 1.15.0 through 1.9.9 Description The software resolves dotted-path strings found in a Kafka connection's extra field into Python callables using the import string function without an allowlist. The...
CVE-2026-86792: Use of Externally-Controlled Input to Select Classes or Code
Apache Airflow Apache Kafka provider versions 1.15.0 before 2.0.0 resolve dotted-path strings found in a Kafka connection's extra field into Python callables via importstring, with no allowlist, and hand them to the confluent-kafka client which invokes them. Deployments that have enabled the Kafk...
CVE-2026-51990
An issue in Sogou Sogou Input Method 16.3.0.3498 fixed in 16.3.0.3498 allows a remote attacker to execute arbitrary code via the bizhelper.exe component...
PT-2026-94089
Name of the Vulnerable Software and Affected Versions kedro-datasets versions 5.0.0 through 9.4.9 Description The kedro datasets experimental.pytorch.PyTorchDataset component loads .pt model files using the torch.load function without enforcing the weights only=True parameter, and it silently dro...
ALSA-2026:67910 Important: libevent security update
The libevent packages provide an abstract asynchronous event notification library. Security Fixes: libevent: Libevent: Denial of Service via malformed RPC data CVE-2026-63383 libevent: Libevent: Off-by-one stack buffer overflow leading to denial of service or data corruption CVE-2026-63387...
Debian dsa-6501 : firefox-esr - security update
The remote Debian 13 host has packages installed that are affected by multiple vulnerabilities as referenced in the dsa-6501 advisory. - ------------------------------------------------------------------------- Debian Security Advisory DSA-6501-1 [email protected] https://www.debian.org/securit...
SUSE SLED15 / SLES15 Security Update : python-GitPython (SUSE-SU-2026:4191-1)
The remote SUSE Linux SLED15 / SLEDSAP15 / SLES15 / SLESSAP15 host has a package installed that is affected by multiple vulnerabilities as referenced in the SUSE-SU-2026:4191-1 advisory. - CVE-2026-87817: failure to properly validade the git directory location allows attackers to impersonate the...
Ubuntu 22.04 LTS / 24.04 LTS / 26.04 LTS / Pro Realtime 22.04 LTS / Pro Realtime 24.04 LTS : polkit vulnerability (USN-8762-1)
The remote Ubuntu 22.04 LTS / 24.04 LTS / 26.04 LTS / Pro Realtime 22.04 LTS / Pro Realtime 24.04 LTS host has packages installed that are affected by a vulnerability as referenced in the USN-8762-1 advisory. It was discovered that polkit incorrectly handled cookie input. A local attacker could...
Oracle Linux 8 : ELSA-2026-67278-0: / perl:5.32 (ELSA-2026-672780)
The remote Oracle Linux 8 host has packages installed that are affected by a vulnerability as referenced in the ELSA-2026-672780 advisory. - Fixes: CVE-2026-13221 - Don't create a trie that would overflow - Fix CVE-2025-40909 - Clone dirhandles without fchdir - Fix CVE-2023-47038 - Fix...
Important: postgresql:18 security update
PostgreSQL is an advanced object-relational database management system DBMS. Security Fixes: postgresql: PostgreSQL: SQL injection in pgcreatesubscriber allows arbitrary SQL execution as superuser CVE-2026-6476 postgresql: PostgreSQL: Arbitrary code execution via integer wraparound in tsvector an...
Debian dsa-6503 : thunderbird - security update
The remote Debian 13 host has packages installed that are affected by multiple vulnerabilities as referenced in the dsa-6503 advisory. - ------------------------------------------------------------------------- Debian Security Advisory DSA-6503-1 [email protected] https://www.debian.org/securit...
D-Link DIR-645 Router Code Execution
The vulnerability of the hedwigcgimain function in D-Link DIR-645 router microprogramming software is related to buffer overflow in the stack. Exploiting this vulnerability allows an attacker operating remotely to execute arbitrary code...
D-Link DI-8100 router CGI Endpoint Heap Buffer Overflow DoS
The vulnerability of the tgfilehtm function in the CGI Endpoint of the D-Link DI-8100 router’s microprogramming system is related to the issue of writing operations outside of the buffer in memory when processing the fn parameter. Exploiting this vulnerability allows an attacker to execute...
SUSE CVE-2026-90947
A flaw was found in GIMP. When processing a specially crafted lighting preset file, the Lighting Effects filter does not properly validate the number of light sources. This can lead to an out-of-bounds write, corrupting memory. An attacker could exploit this by convincing a user to open a malicio...
SUSE CVE-2026-90948
A flaw was found in GIMP's ICO file loader. When processing an ICO file containing an embedded PNG image, an integer overflow can occur during the calculation of the required buffer size. This leads to an undersized buffer being allocated, causing a heap-based buffer overflow when the decoded pix...
Deserialization of Untrusted Data
Overview Affected versions of this package are vulnerable to Deserialization of Untrusted Data via the ci parameter in the GET request, which is passed to the unserialize function without restricting allowed classes. An attacker can execute arbitrary code or manipulate the database by supplying a...
CVE-2026-92248
A flaw was found in the file-psd plugin in GIMP. When generating a thumbnail preview for a specially crafted PSD Photoshop Document image file, an integer overflow occurs during the multiplication of values from an embedded JPEG header. This leads to an undersized heap allocation, resulting in a...
CVE-2026-76861
Netcore NR255-V version 1.5.130703 contains a stack-based buffer overflow in ntoolstcpdumpstartset.cgi caused by an unsized sprintf call when processing form values. An attacker can submit crafted input to this cgi endpoint to overflow the stack buffer and potentially execute arbitrary code...
CVE-2026-92248
A flaw was found in the file-psd plugin in GIMP. When generating a thumbnail preview for a specially crafted PSD Photoshop Document image file, an integer overflow occurs during the multiplication of values from an embedded JPEG header. This leads to an undersized heap allocation, resulting in a...