166657 matches found
postgresql: PostgreSQL: Arbitrary code execution via integer wraparound in tsvector and tsquery functions
A flaw was found in PostgreSQL. An unprivileged database user can exploit an integer wraparound vulnerability in the tsvector and tsquery data type functions. By providing crafted large inputs, the server can be forced to undersize an allocation, leading to an out-of-bounds write. This could...
postgresql: PostgreSQL: Arbitrary code execution via plperl tied hash heap buffer overflow
A flaw was found in PostgreSQL. A heap buffer overflow vulnerability exists in the plperl component when returning a tied hash. This allows a function owner to execute arbitrary code as the operating system user running the database by providing a specially crafted function body. This could lead ...
postgresql: PostgreSQL: Arbitrary code execution via type confusion in cursor lifecycle
A flaw was found in PostgreSQL. This vulnerability, caused by type confusion in the 'portal'/cursor lifecycle, allows a user to execute arbitrary code as the operating system user running the database. This can occur by re-creating a cursor or other portal with different types. Successful...
postgresql: PostgreSQL: Arbitrary code execution via long POSIX timezone abbreviation
A heap buffer overflow flaw was found in the PostgreSQL tochartimestamptz function. An attacker can exploit this by supplying an overly long POSIX timezone abbreviation to execute arbitrary code as the database's operating system user, potentially resulting in complete system compromise...
postgresql: pltcl: plperl: PostgreSQL: Arbitrary code execution in 32-bit pltcl and plperl
A flaw was found in PostgreSQL. An integer wraparound vulnerability in 32-bit builds of pltcl and plperl allows an object creator to cause the server to undersize an allocation and write out-of-bounds via crafted function bodies. This can lead to arbitrary code execution as the operating system...
postgresql: PostgreSQL: Arbitrary code execution via type confusion with "internal" arguments
A type confusion vulnerability in PostgreSQL allows any user to execute arbitrary code as the database's operating system user by calling functions with mishandled "internal" data type arguments...
postgresql-fuzzystrmatch: PostgreSQL fuzzystrmatch: Arbitrary code execution via integer wraparound
A flaw was found in PostgreSQL fuzzystrmatch. A low-privileged database user can exploit an integer wraparound vulnerability by providing extreme inputs to the levenshtein or levenshteinlessequal SQL functions. This allows the user to execute arbitrary code as the operating system user running th...
postgresql: PostgreSQL: Arbitrary code execution via type confusion in 'refint' module
A flaw was found in PostgreSQL. A type confusion vulnerability in the 'refint' module allows an object creator to execute arbitrary code as the operating system user running the database. This could lead to a complete compromise of the database server...
EUVD-2026-88074
In Google fuse-archive versions prior to 1.24, an attacker who can prepend a directory to PATH or write a malicious binary to an attacker-controlled or writable directory appearing in PATH can hijack the execution pathway. This allows the attacker to execute arbitrary local code under the securit...
CVE-2026-87723
Google fuse-archive versions prior to 1.24 are vulnerable to an Untrusted Search Path (PATH Hijacking) . An attacker capable of prepending a directory to the PATH or writing a malicious binary to a writable directory within the PATH can hijack the execution pathway. This vulnerability allows for ...
CVE-2026-100888
A flaw was found in OpenDKIM. A remote attacker can exploit this flaw to cause a Denial of Service DoS or potentially arbitrary code execution by submitting a specially crafted DomainKeys Identified Mail DKIM signature header. In the dkimcanonselecthdrs function, improper processing of the 'h'...
USN-8825-1 requests vulnerability
It was discovered that Requests did not correctly handle generating random temporary file paths. An attacker could possibly use this issue to execute arbitrary code...
USN-8825-1: Requests vulnerability
It was discovered that Requests did not correctly handle generating random temporary file paths. An attacker could possibly use this issue to execute arbitrary code...
PT-2026-116261
Уязвимость функции system компонента HNAP CGI Handler микропрограммного обеспечения маршрутизатора D-Link DIR-868L связана с непринятием мер по очистке данных на управляющем уровне. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, выполнить произвольный код от имени root...
ROS-20260928-73-0078
The vulnerability of the tipcmonreinitself function in the Linux operating system’s kernel relates to the possibility of using memory after it is freed. Exploiting this vulnerability could allow an attacker to execute arbitrary code or cause a service failure...
ROS-20260928-73-0033
The vulnerability of the ext4xattr inodeupdateref function in the Linux operating system is related to a countable loss of significance. Exploiting this vulnerability could allow an attacker to execute arbitrary code...
macOS 26.x < 26.7.1 (149228)
The remote host is running a version of macOS / Mac OS X that is 26.x prior to 26.7.1. It is, therefore, affected by a vulnerability: - An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 26.7.1 and iPadOS 26.7.1, macOS Sequoia 15.8.1, macOS Tahoe...
macOS 15.x < 15.8.1 (149229)
The remote host is running a version of macOS / Mac OS X that is 15.x prior to 15.8.1. It is, therefore, affected by a vulnerability: - An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 26.7.1 and iPadOS 26.7.1, macOS Sequoia 15.8.1, macOS Tahoe...
Important: emacs
Issue Overview: GNU Emacs before 31.0.91 contains an integer overflow in the PBM/PPM/PGM image loader that allows an attacker to leak heap memory contents by supplying a crafted image with large dimensions and an elevated max color index. The image loader multiplies image dimensions and channel...
PT-2026-99867
Name of the Vulnerable Software and Affected Versions mH-DEVELOPER versions prior to 3.0.30 Description The smart home module uses an end-of-life and unsupported Debian 8 operating system and Node.js runtime v17.0.1 in its production firmware. This reliance on obsolete components exposes the devi...