93861 matches found
CVE-2026-58415: Files or Directories Accessible to External Parties
Internal state files accessible to external parties in moddavfs in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows a remote client to read WebDAV dead properties of resources it cannot author via a GET request for the .DAV state directory This issue affects...
CVE-2026-56449: Out-of-bounds Write
Out-of-bounds Write vulnerability in Apache HTTP Server's modproxyhtml with crafted HTTP response bodies. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68...
CVE-2026-47360: Exposure of Sensitive Information to an Unauthorized Actor
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache HTTP Server's modsessioncookie module. When SessionCookieRemove changes across internal redirects, the session cookie may still be passed to a backend server. This issue affects Apache HTTP Server: from 2.4.0...
PT-2026-103828
Name of the Vulnerable Software and Affected Versions Apache APISIX version 3.17.0 Description An issue exists where sensitive information can be inserted into log files. Under specific response structures, unmasked header values may be written to the log sink. Recommendations Upgrade to version...
PT-2026-103830
Name of the Vulnerable Software and Affected Versions Apache Camel Quarkus versions 3.2.0 through 3.33.2 Apache Camel Quarkus versions 3.34.0 through 3.39.9 Description Improper restriction of XML External Entity XXE references in the XSLT support extension camel-quarkus-support-xalan allows an...
PT-2026-103829
Name of the Vulnerable Software and Affected Versions Apache APISIX versions 2.3.0 through 3.6.x Description An issue exists where a request's authorization scope could persist into subsequent requests on the same route when using a supported authz-keycloak configuration. This leads to unintended...
PT-2026-103832
Name of the Vulnerable Software and Affected Versions Apache APISIX versions 3.17.0 through 3.18.0 Description Cross-Site Request Forgery CSRF exists in the feishu-auth and dingtalk-auth plugins. An attacker can trick a user into clicking a crafted link, causing the user's browser session on a...
PT-2026-103831
Name of the Vulnerable Software and Affected Versions Apache APISIX versions 3.17.0 through 3.18.0 Description An improper verification of cryptographic signatures occurs within the saml-auth plugin under default configuration. This allows an unauthenticated attacker to impersonate any user on...
PT-2026-103834
Name of the Vulnerable Software and Affected Versions Apache APISIX versions 2.14.1 through 3.18.0 Description An issue exists where the use of non-canonical URL paths for authorization decisions allows a crafted encoded path to reach an upstream endpoint. In configurations where a permissive rou...
PT-2026-103835
Name of the Vulnerable Software and Affected Versions Apache APISIX versions 3.12.0 through 3.18.0 Description Improper Authentication occurs when using the openid-connect plugin with remote introspection against an authorization server that serves multiple issuers. In this scenario, a token that...
CVE-2026-79768: Path Equivalence: '/./' (Single Dot Directory)
Path equivalence: '/./' single dot directory vulnerability in Apache HTTP Server's moduserdir module when configured with absolute non-wildcard UserDir directive the 2nd form in https://httpd.apache.org/docs/2.4/mod/moduserdir.htmluserdir This issue affects Apache HTTP Server: from 2.4.0 through...
CVE-2026-59797: Improper Privilege Management
Improper Privilege Management vulnerability in Apache HTTP Server's modssl via SSLRequire and file-related expressions. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68...
CVE-2026-58415: Files or Directories Accessible to External Parties
Internal state files accessible to external parties in moddavfs in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows a remote client to read WebDAV dead properties of resources it cannot author via a GET request for the .DAV state directory This issue affects...
CVE-2026-47360: Exposure of Sensitive Information to an Unauthorized Actor
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache HTTP Server's modsessioncookie module. When SessionCookieRemove changes across internal redirects, the session cookie may still be passed to a backend server. This issue affects Apache HTTP Server: from 2.4.0...
CVE-2026-42528: Memory Allocation with Excessive Size Value
A memory calculation bug in moddav in Apache httpd 2.4.67 and earlier allows an attacker with permission to create WebDAV locks to crash server child processes. Users are recommended to upgrade to version 2.4.69, which fixes this issue...
CVE-2026-94269: Use of Non-Canonical URL Paths for Authorization Decisions
Use of Non-Canonical URL paths for authorization decisions vulnerability in Apache APISIX. In some configurations where a permissive route overlaps a protected one, a crafted encoded path can reach an upstream endpoint that the matched route's policies were never meant to cover. A request that...
CVE-2026-82806: Exposure of Data Element to Wrong Session
Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended...
CVE-2026-78242: Insertion of Sensitive Information into Log File
Insertion of sensitive information into log file vulnerability in Apache APISIX. This vulnerability can cause the unmasked header value to be written to the log sink under a certain response structure. This issue affects Apache APISIX: 3.17.0. Users are recommended to upgrade to version 3.18.0,...
PT-2026-103931
Name of the Vulnerable Software and Affected Versions Apache HTTP Server versions 2.4.0 through 2.4.68 Description Internal state files in the mod dav fs module are accessible to external parties. This allows a remote client to read WebDAV dead properties of resources they are not authorized to...
PT-2026-103942
Name of the Vulnerable Software and Affected Versions Apache HTTP Server versions 2.4.0 through 2.4.68 Description A path equivalence issue exists in the mod userdir module when configured with an absolute non-wildcard UserDir directive. This flaw involves the use of the /./ single dot directory...