3514 matches found
Low: protobuf-c
Issue Overview: Protobuf-c v1.4.0 was discovered to contain an invalid arithmetic shift via the function parsetagandwiretype in protobuf-c/protobuf-c.c. This vulnerability allows attackers to cause a Denial of Service DoS via unspecified vectors. CVE-2022-33070 Affected Packages: protobuf-c Note:...
Important: gtk2
Issue Overview: gtk3: gtk2: Library injection from CWD CVE-2024-6655 Affected Packages: gtk2 Note: This advisory is applicable to Amazon Linux 2 AL2 Core repository. Visit this FAQ section for the difference between AL2 Core and AL2 Extras advisories. Issue Correction: Run yum update gtk2 to upda...
Low: ca-certificates
Issue Overview: Certifi is a curated collection of Root Certificates for validating the trustworthiness of SSL certificates while verifying the identity of TLS hosts. Certifi starting in 2021.05.30 and prior to 2024.07.4 recognized root certificates from GLOBALTRUST. Certifi 2024.07.04 removes ro...
Medium: thunderbird
Issue Overview: A heap overflow vulnerability exists in libvpx - Encoding a frame that has larger dimensions than the originally configured size with VP9 may result in a heap overflow in libvpx. We recommend upgrading to version 1.13.1 or above CVE-2023-6349 Affected Packages: thunderbird Note:...
Amazon Linux 2 : docker (ALASDOCKER-2024-040)
The version of docker installed on the remote host is prior to 25.0.6-1. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2DOCKER-2024-040 advisory. 2025-01-04: CVE-2024-36620 was added to this advisory. 2025-01-04: CVE-2024-36623 was added to this advisory...
Amazon Linux 2 : docker (ALASNITRO-ENCLAVES-2024-041)
The version of docker installed on the remote host is prior to 25.0.6-1. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2NITRO-ENCLAVES-2024-041 advisory. 2025-01-04: CVE-2024-36620 was added to this advisory. 2025-01-04: CVE-2024-36623 was added to this advisory...
Amazon Linux 2 : kernel (ALASKERNEL-5.10-2024-064)
The version of kernel installed on the remote host is prior to 5.10.220-209.867. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2KERNEL-5.10-2024-064 advisory. 2024-12-05: CVE-2022-48827 was added to this advisory. 2024-12-05: CVE-2022-48828 was added to this...
Amazon Linux 2 : kernel (ALASKERNEL-5.15-2024-045)
The version of kernel installed on the remote host is prior to 5.15.161-106.159. It is, therefore, affected by a vulnerability as referenced in the ALAS2KERNEL-5.15-2024-045 advisory. In the Linux kernel, the following vulnerability has been resolved: net: fix dstnegativeadvice race CVE-2024-3697...
Amazon Linux 2 : ecs-service-connect-agent (ALASECS-2024-038)
The version of ecs-service-connect-agent installed on the remote host is prior to v1.29.6.0-1. It is, therefore, affected by a vulnerability as referenced in the ALAS2ECS-2024-038 advisory. dd-trace-cpp is the Datadog distributed tracing for C++. When the library fails to extract trace context du...
Amazon Linux 2 : edk2 (ALAS-2024-2591)
It is, therefore, affected by a vulnerability as referenced in the ALAS2-2024-2591 advisory. Issue summary: Calling the OpenSSL API function SSLselectnextproto with anempty supported client protocols buffer may cause a crash or memory contents tobe sent to the peer. Impact summary: A buffer...
Amazon Linux 2 : java-17-amazon-corretto (ALAS-2024-2600)
The version of java-17-amazon-corretto installed on the remote host is prior to 17.0.12+7-1. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2-2024-2600 advisory. Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product...
Amazon Linux 2 : java-11-amazon-corretto (ALAS-2024-2599)
The version of java-11-amazon-corretto installed on the remote host is prior to 11.0.24+8-1. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2-2024-2599 advisory. Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product...
Amazon Linux 2 : ecs-init, --advisory ALAS2ECS-2024-039 (ALASECS-2024-039)
The version of ecs-init installed on the remote host is prior to 1.84.0-1. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2ECS-2024-039 advisory. An attacker may cause an HTTP/2 endpoint to read arbitrary amounts of header data by sending an excessive number of...
Amazon Linux 2 : golang (ALAS-2024-2598)
The version of golang installed on the remote host is prior to 1.22.5-1. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2024-2598 advisory. The net/http HTTP/1.1 client mishandled the case where a server responds to a request with an Expect: 100-continue header with a...
Amazon Linux 2 : mariadb (ALASMARIADB10.5-2024-006)
The version of mariadb installed on the remote host is prior to 10.5.25-1. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2MARIADB10.5-2024-006 advisory. MariaDB Server 10.4 before 10.4.33, 10.5 before 10.5.24, 10.6 before 10.6.17, 10.7 through 10.11 before 10.11....
Amazon Linux 2 : kernel (ALASKERNEL-5.15-2024-046)
The version of kernel installed on the remote host is prior to 5.15.162-107.160. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2KERNEL-5.15-2024-046 advisory. 2024-08-27: CVE-2024-42096 was added to this advisory. 2024-08-27: CVE-2024-42070 was added to this...
Amazon Linux 2 : gstreamer1-plugins-base (ALAS-2024-2592)
The version of gstreamer1-plugins-base installed on the remote host is prior to 1.18.4-5. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2024-2592 advisory. GStreamer EXIF Metadata Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows...
Amazon Linux 2 : nano (ALAS-2024-2590)
The version of nano installed on the remote host is prior to 2.9.8-2. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2024-2590 advisory. nano: running chmod and chown on the filename allows malicious user to replace the emergency file with a malicious symlink to a...
Amazon Linux 2 : libreswan (ALAS-2024-2596)
The version of libreswan installed on the remote host is prior to 3.25-4.8. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2024-2596 advisory. The Libreswan Project was notified of an issue causing libreswan to restart when using IKEv1 without specifying an esp= line. Wh...
Amazon Linux 2 : gstreamer-plugins-base (ALAS-2024-2593)
The version of gstreamer-plugins-base installed on the remote host is prior to 0.10.36-18. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2024-2593 advisory. GStreamer EXIF Metadata Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows...