8229 matches found
goblin (1.0.0b1) potentially affected by CVE-2021-21330 via aiohttp (0.22.1)
aiohttp PYPI version 0.22.1 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - goblin 1.0.0b1 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
aiogremlin (3.2.6rc1), aiopogo (>=2.0.2, <=2.0.4) +22 more potentially affected by CVE-2021-21330 via aiohttp (2.2.5)
aiohttp PYPI version 2.2.5 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - aiogremlin 3.2.6rc1 - aiopogo =2.0.2, =0.1.1, =1.0.1, =1.0.0, =1.0.0, =2.1.0rc1, =2.0.0, =0.51.0, =0.2.0, =0.0.0, =0.1.1, =1.6.2, =1.6.6 and more...
hassmart-homeassistant (0.60.0), homeassistant (>=0.60.0, <=0.60.1) +2 more potentially affected by CVE-2021-21330 via aiohttp (2.3.6)
aiohttp PYPI version 2.3.6 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - hassmart-homeassistant 0.60.0 - homeassistant =0.60.0, =0.60.1 - pyplanet 0.5.4 - reliz 0.1.0.dev0 Source cves: CVE-2021-21330 Source advisory:...
duniterpy (0.40.8), jenkins-epo (>=1.159.0, <=1.160.0) potentially affected by CVE-2021-21330 via aiohttp (2.0.0rc1)
aiohttp PYPI version 2.0.0rc1 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - duniterpy 0.40.8 - jenkins-epo =1.159.0, =1.160.0 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
botstory (0.0.63) potentially affected by CVE-2021-21330 via aiohttp (2.0.1)
aiohttp PYPI version 2.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - botstory 0.0.63 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
muffin (0.5.1) potentially affected by CVE-2021-21330 via aiohttp (0.20.1)
aiohttp PYPI version 0.20.1 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin 0.5.1 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
muffin (>=0.3.3, <=0.3.7) potentially affected by CVE-2021-21330 via aiohttp (0.18.4)
aiohttp PYPI version 0.18.4 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.3.3, =0.3.7 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
aio-tinder (>=0.1.7, <=0.1.8) potentially affected by CVE-2021-21330 via aiohttp (1.0.1)
aiohttp PYPI version 1.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - aio-tinder =0.1.7, =0.1.8 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
homeassistant (>=0.36.0, <=0.37.1), hypr (0.8.2) +3 more potentially affected by CVE-2021-21330 via aiohttp (1.2.0)
aiohttp PYPI version 1.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - homeassistant =0.36.0, =0.1.0, =0.1.0, =1.5.9, =1.5.12 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
polyswarm-api (>=0.1.0, <=0.2.2), polyswarm-client (>=1.0.0rc0, <=1.0.2) +1 more potentially affected by CVE-2021-21330 via aiohttp (2.3.1)
aiohttp PYPI version 2.3.1 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - polyswarm-api =0.1.0, =1.0.0rc0, =0.2.0a7, =0.2.0a10 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
echod (0.1.0), muffin (>=0.0.94, <=0.0.97) potentially affected by CVE-2021-21330 via aiohttp (0.16.5)
aiohttp PYPI version 0.16.5 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - echod 0.1.0 - muffin =0.0.94, =0.0.97 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
muffin (>=0.1.5, <=0.1.6) potentially affected by CVE-2021-21330 via aiohttp (0.17.3)
aiohttp PYPI version 0.17.3 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.1.5, =0.1.6 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
muffin (>=0.0.2, <=0.0.22) potentially affected by CVE-2021-21330 via aiohttp (0.14.1)
aiohttp PYPI version 0.14.1 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.0.2, =0.0.22 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
geoffrey (>=0.1.0, <=0.1.2) potentially affected by CVE-2021-21330 via aiohttp (0.6.4)
aiohttp PYPI version 0.6.4 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - geoffrey =0.1.0, =0.1.2 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
pushpull (0.0.2) potentially affected by CVE-2021-21330 via aiohttp (0.22.0)
aiohttp PYPI version 0.22.0 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - pushpull 0.0.2 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
muffin (>=0.7.1, <=0.8.6) potentially affected by CVE-2021-21330 via aiohttp (0.21.6)
aiohttp PYPI version 0.21.6 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.7.1, =0.8.6 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
scriptworker (0.2.1) potentially affected by CVE-2021-21330 via aiohttp (0.22.0a0)
aiohttp PYPI version 0.22.0a0 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - scriptworker 0.2.1 Source cves: CVE-2021-21330 Source advisory: OSV:GHSA-V6WP-4M6F-GCJG...
GHSA-V6WP-4M6F-GCJG `aiohttp` Open Redirect vulnerability (`normalize_path_middleware` middleware)
Impact Open redirect vulnerability — a maliciously crafted link to an aiohttp-based web-server could redirect the browser to a different website. It is caused by a bug in the aiohttp.webmiddlewares.normalizepathmiddleware middleware. Patches This security problem has been fixed in v3.7.4. Upgrade...
CVE-2021-21330: URL Redirection to Untrusted Site
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. In aiohttp before version 3.7.4 there is an open redirect vulnerability. A maliciously crafted link to an aiohttp-based web-server could redirect the browser to a different website. It is caused by a bug in the...
aiohttp Input Validation Error Vulnerability
aiohttp is an open source asynchronous HTTP client/server framework for asyncio and Python. An input validation error vulnerability exists in aiohttp versions prior to 3.7.4, which stems from an open redirection vulnerability. Maliciously crafted pointers can redirect the browser to another websi...