7785 matches found
0x20bf (0.0.1), 2keys (0.5.1) +2199 more potentially affected by CVE-2024-27306 via aiohttp (>=0.6.4, <=3.9.4rc0)
aiohttp PYPI version =0.6.4, =0.0.1a0, =0.1.0, =0.5.0a0, =1.0.0, =1.0.0, =0.0.1, =1.0.2, =0.2.1, =0.1.2, =0.3.3, =0.1.0, =0.1.15 and more Source cves: CVE-2024-27306 Source advisory: MEND:CVE-2024-27306...
CVE-2024-27306
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. A XSS vulnerability exists on index pages for static file handling. This vulnerability is fixed in 3.9.4. We have always recommended using a reverse proxy server e.g. nginx for serving static files. Users following th...
CVE-2024-27306 aiohttp vulnerable to XSS on index pages for static file handling
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. A XSS vulnerability exists on index pages for static file handling. This vulnerability is fixed in 3.9.4. We have always recommended using a reverse proxy server e.g. nginx for serving static files. Users following th...
CVE-2024-27306
CVE-2024-27306 : An XSS vulnerability exists in aiohttp’s index pages for static file handling. Root cause: improper validation of input on index/static file pages. The issue is fixed in aiohttp 3.9.4. Public advisories recommend upgrading to the patched version; for those unable to upgrade, a wo...
CVE-2024-27306
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. A XSS vulnerability exists on index pages for static file handling. This vulnerability is fixed in 3.9.4. We have always recommended using a reverse proxy server e.g. nginx for serving static files. Users following th...
0x20bf (0.0.1), 2keys (0.5.1) +2090 more potentially affected by CVE-2024-27306 via aiohttp (>=3.0.0b0, <=3.9.4rc0)
aiohttp PYPI version =3.0.0b0, =0.0.1a0, =0.1.0, =0.5.0a0, =1.0.0, =1.0.0, =0.0.1, =1.0.2, =0.2.1, =0.1.2, =0.3.3, =0.1.0, =0.1.15 and more Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
muffin (>=0.3.0, <=0.3.2) potentially affected by CVE-2024-27306 via aiohttp (0.18.3)
aiohttp PYPI version 0.18.3 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.3.0, =0.3.2 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
muffin (>=0.2.0, <=0.2.1) potentially affected by CVE-2024-27306 via aiohttp (0.17.4)
aiohttp PYPI version 0.17.4 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.2.0, =0.2.1 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
muffin (>=0.1.5, <=0.1.6) potentially affected by CVE-2024-27306 via aiohttp (0.17.3)
aiohttp PYPI version 0.17.3 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.1.5, =0.1.6 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
muffin (>=0.1.1, <=0.1.4) potentially affected by CVE-2024-27306 via aiohttp (0.17.2)
aiohttp PYPI version 0.17.2 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.1.1, =0.1.4 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
muffin (>=0.0.107, <=0.1.0) potentially affected by CVE-2024-27306 via aiohttp (0.17.1)
aiohttp PYPI version 0.17.1 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.0.107, =0.1.0 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
muffin (>=0.0.105, <=0.0.106) potentially affected by CVE-2024-27306 via aiohttp (0.17.0)
aiohttp PYPI version 0.17.0 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.0.105, =0.0.106 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
muffin (>=0.0.98, <=0.0.104) potentially affected by CVE-2024-27306 via aiohttp (0.16.6)
aiohttp PYPI version 0.16.6 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.0.98, =0.0.104 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
echod (0.1.0), muffin (>=0.0.94, <=0.0.97) potentially affected by CVE-2024-27306 via aiohttp (0.16.5)
aiohttp PYPI version 0.16.5 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - echod 0.1.0 - muffin =0.0.94, =0.0.97 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
muffin (>=0.0.46, <=0.0.52) potentially affected by CVE-2024-27306 via aiohttp (0.15.0)
aiohttp PYPI version 0.15.0 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.0.46, =0.0.52 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
muffin (>=0.0.23, <=0.0.45) potentially affected by CVE-2024-27306 via aiohttp (0.14.4)
aiohttp PYPI version 0.14.4 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.0.23, =0.0.45 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
muffin (>=0.0.2, <=0.0.22) potentially affected by CVE-2024-27306 via aiohttp (0.14.1)
aiohttp PYPI version 0.14.1 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - muffin =0.0.2, =0.0.22 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
interest (0.0.1) potentially affected by CVE-2024-27306 via aiohttp (0.14.0)
aiohttp PYPI version 0.14.0 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - interest 0.0.1 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
iamine (>=0.1.5, <=0.1.6) potentially affected by CVE-2024-27306 via aiohttp (0.13.1)
aiohttp PYPI version 0.13.1 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - iamine =0.1.5, =0.1.6 Source cves: CVE-2024-27306 Source advisory: OSV:GHSA-7GPW-8WMC-PM8G...
aioauth-client (>=0.9.2, <=0.9.3), aiohttp-validate (>=0.1.0, <=1.0.0) +10 more potentially affected by CVE-2024-27306 via aiohttp (1.0.5)
aiohttp PYPI version 1.0.5 is affected by a known vulnerability. The following packages have a transitive dependency on aiohttp and may be impacted: - aioauth-client =0.9.2, =0.1.0, =0.0.7, =0.17.0b1, =0.32.0, =1.2.0, =0.10.3, =0.1.8a1, =1.0.0a2, =1.0.0a3 Source cves: CVE-2024-27306 Source...