Lucene search
+L

3031 matches found

IBM Security Bulletins
IBM Security Bulletins
•added 2026/07/20 5:52 p.m.•15 views

Security Bulletin: IBM Tivoli Monitoring is included with IBM Tivoli Composite Application Manager for Applications WebSphere MQ Monitoring Agent, is affected by a security vulnerability in Perl

Summary IBM Tivoli Monitoring is included with IBM Tivoli Composite Application Manager for Applications WebSphere MQ Monitoring Agent and has remediated a vulnerability in the Zlib library. Vulnerability Details CVEID:CVE-2026-4176 DESCRIPTION: Perl versions from 5.9.4 before 5.40.4-RC1, from...

9.8CVSS7.3AI score0.00811EPSS
SaveExploits0Affected Software1
OSV
OSV
•added 2026/07/19 12:16 p.m.•14 views

AZL-92516 CVE-2026-63825 affecting package kernel 6.6.157.1-1

In the Linux kernel, the following vulnerability has been resolved: gcov: use atomic counter updates to fix concurrent access crashes GCC's GCOV instrumentation can merge global branch counters with loop induction variables as an optimization. In inflatefast, the inner copy loops get transformed ...

9.8CVSS6AI score0.00437EPSS
SaveExploits0References1
Snyk
Snyk
•added 2026/07/14 6:48 p.m.•12 views

Allocation of Resources Without Limits or Throttling

Overview Affected versions of this package are vulnerable to Allocation of Resources Without Limits or Throttling in the decode function of PdfStream in PdfParser, where zlib decompression is performed without limiting the output size. An attacker can cause excessive memory consumption by...

8.7CVSS7.2AI score0.00385EPSS
SaveExploits1References2
SUSE Linux
SUSE Linux
•added 2026/07/14 11:23 a.m.•19 views

Security update for wireshark

This update for wireshark fixes the following issues CVE-2026-5401: AFP dissector crash bsc1263756. CVE-2026-5403: SBC audio codec crash bsc1263765. CVE-2026-5404: K12 RF5 file parser crash bsc1263766. CVE-2026-5406: FC-SWILS dissector crash bsc1263754. CVE-2026-5407: SMB2 dissector infinite loop...

5.5CVSS6.2AI score0.00345EPSS
SaveExploits15References60
Tenable Nessus
Tenable Nessus
•added 2026/07/14 12:00 a.m.•18 views

EulerOS 2.0 SP10 : zlib (EulerOS-SA-2026-2679)

According to the versions of the zlib packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : zlib before 1.3.2 allows CPU consumption via crc32combine64 and crc32combinegen64 because x2nmodp can do right shifts within a loop that has no...

5.5CVSS6.4AI score0.00191EPSS
SaveExploits1References2
Redos
Redos
•added 2026/07/14 12:00 a.m.•13 views

ROS-20260714-73-0010

The vulnerability of the zlib compression library, the traffic analyzer for computer networks like Wireshark, is related to the execution of a loop with improper memory management, leading to sequential memory allocation issues. Exploiting this vulnerability can allow attackers to cause service...

5.5CVSS6.4AI score0.00157EPSS
SaveExploits1
Tenable Nessus
Tenable Nessus
•added 2026/07/14 12:00 a.m.•23 views

EulerOS 2.0 SP10 : zlib (EulerOS-SA-2026-2720)

According to the versions of the zlib packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : zlib before 1.3.2 allows CPU consumption via crc32combine64 and crc32combinegen64 because x2nmodp can do right shifts within a loop that has no...

5.5CVSS6.4AI score0.00191EPSS
SaveExploits1References2
Redos
Redos
•added 2026/07/13 12:00 a.m.•19 views

ROS-20260713-73-0028

The vulnerability of the crc32combine64 and crc32combinegen64 functions in the open-source data compression library zlib relates to the fact that the x2nmodp function may perform right shifts within a loop without a termination condition. Exploiting this vulnerability could allow an attacker to...

5.5CVSS6.6AI score0.00191EPSS
SaveExploits1
Redos
Redos
•added 2026/07/13 12:00 a.m.•16 views

ROS-20260713-73-0022

The vulnerability of the Perl module from the zlib library is related to incorrect input of configuration data. Exploiting this vulnerability allows an attacker to compromise the confidentiality, integrity, and accessibility of the protected information...

9.8CVSS7.7AI score0.00793EPSS
SaveExploits0
Hacker One
Hacker One
•added 2026/07/11 1:39 p.m.•18 views

Node.js: Reachable assertion in node:zlib sync API crashes the entire process via spoofed TypedArray byteLength (all 11 *Sync functions affected)

A flaw was discovered in the synchronous Node.js zlib APIs that allowed a spoofed TypedArray byteLength to trigger a reachable assertion, causing the entire process to crash. All 11 synchronous zlib functions were affected...

6.2CVSS6.3AI score0.00167EPSS
SaveExploits0
IBM Security Bulletins
IBM Security Bulletins
•added 2026/07/08 6:38 p.m.•17 views

Security Bulletin: IBM Tivoli Monitoring's zlib library is affected by a security vulnerability.

Summary A vulnerable version of zlib library which is included as part of IBM Tivoli Monitoring ITM have been remediated. Vulnerability Details CVEID:CVE-2026-4176 DESCRIPTION: Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerabl...

9.8CVSS7.2AI score0.00811EPSS
SaveExploits0Affected Software1
Fedora
Fedora
•added 2026/07/08 1:10 a.m.•20 views

[SECURITY] Fedora 43 Update: perl-IO-Compress-2.221-1.fc43

This distribution provides a Perl interface to allow reading and writing of compressed data created with the zlib and bzip2 libraries. IO-Compress supports reading and writing of bzip2, RFC 1950, RFC 1951, RFC 1952 i.e. gzip and zip files/buffers. The following modules used to be distributed...

7.8CVSS7.2AI score0.00609EPSS
SaveExploits3
OSV
OSV
•added 2026/07/07 4:03 p.m.•18 views

PYSEC-2026-1294 Unfurl's unbounded zlib decompression allows decompression bomb DoS

Summary The compressed data parser uses zlib.decompress without a maximum output size. A small, highly compressed payload can expand to a very large output, causing memory exhaustion and denial of service. Details - unfurl/parsers/parsecompressed.py calls zlib.decompressdecoded with no size limit...

8.7CVSS6AI score0.0079EPSS
SaveExploits1References9
GithubExploit
GithubExploit
•added 2026/07/02 7:57 p.m.•110 views

inflateghost

InflateGhost — CVE-2026-40711 Critical heap overflow in zli...

8CVSS6.6AI score0.01347EPSS
SaveExploits1
IBM Security Bulletins
IBM Security Bulletins
•added 2026/07/01 9:59 p.m.•20 views

Security Bulletin: IBM MQ for HPE NonStop is vulnerable to an issue in zlib (CVE-2026-27171)

Summary IBM MQ for HPE NonStop is vulnerable to an issue in versions of zlib, due to excessive CPU consumption when inputs are not properly validated. Vulnerability Details CVEID:CVE-2026-27171 DESCRIPTION: zlib before 1.3.2 allows CPU consumption via crc32combine64 and crc32combinegen64 because...

5.5CVSS6.4AI score0.00191EPSS
SaveExploits1Affected Software1
PyPA
PyPA
•added 2026/06/29 11:50 a.m.•21 views

pyminizip affected by zlib's integer overflow/heap based buffer overflow vulnerability due to vulnerable dependency

MiniZip in zlib through 1.3 has an integer overflow and resultant heap-based buffer overflow in zipOpenNewFileInZip464 via a long filename, comment, or extra field. NOTE: MiniZip is not a supported part of the zlib product.pyminizip uses version 1.2.11 of zlib's code...

9.8CVSS7.4AI score0.03179EPSS
SaveExploits0References17Affected Software1
Positive Technologies
Positive Technologies
•added 2026/06/29 12:00 a.m.•28 views

PT-2026-53574

MiniZip in zlib through 1.3 has an integer overflow and resultant heap-based buffer overflow in zipOpenNewFileInZip4 64 via a long filename, comment, or extra field. NOTE: MiniZip is not a supported part of the zlib product. pyminizip uses version 1.2.11 of zlib's code...

9.8CVSS7.4AI score0.03179EPSS
SaveExploits0References18
Positive Technologies
Positive Technologies
•added 2026/06/28 12:00 a.m.•31 views

PT-2026-64414

Name of the Vulnerable Software and Affected Versions FFmpeg versions prior to 8.1.2 Description An information disclosure issue exists in the LCL/ZLIB video decoder. An attacker can expose uninitialized heap memory by providing a valid zlib stream that inflates to fewer bytes than the expected...

8.8CVSS7.5AI score0.00851EPSS
SaveExploits0References113
Fedora
Fedora
•added 2026/06/26 12:59 a.m.•21 views

[SECURITY] Fedora 44 Update: perl-IO-Compress-2.221-1.fc44

This distribution provides a Perl interface to allow reading and writing of compressed data created with the zlib and bzip2 libraries. IO-Compress supports reading and writing of bzip2, RFC 1950, RFC 1951, RFC 1952 i.e. gzip and zip files/buffers. The following modules used to be distributed...

7.8CVSS7.2AI score0.00609EPSS
SaveExploits3
AstraLinux
AstraLinux
•added 2026/06/24 3:11 p.m.•12 views

Astra Linux – Vulnerability in zlib

Zlib before version 1.3.2 allowed CPU consumption through crc32combine64 and crc32combinegen64, because x2nmodp could perform right shifts within a loop without a termination condition...

5.5CVSS6.7AI score0.00191EPSS
SaveExploits1References3
Rows per page
Query Builder