63 matches found
cve-2025-29927
CVE-2025-29927 CVE-2025-29927 Vulnerability All versions of Next.js from 11.1.4 through 13.5.6, 14.x before 14.2.25, and 15.x before 15.2.3 are affected by this vulnerability. The impact is particularly significant for applications that rely on middleware for implementing access controls, as...
CVE-2025-29927
CVE-2025-29927 — Next.js middleware authorization bypass Summary: vulnerability in Next.js middleware allowing authorization bypass by spoofing the x-middleware-subrequest header. Table of Contents CVE-2025-29927 — Next.js middleware authorization bypass Table of Contents Gathering vulnerable hos...
Thank-u-Next
Thank u Next – CVE-2025-29927 Exploit Tool 🧠 What is CVE-2025-29927? It’s not just a bypass — it’s a revelation. A single header, misunderstood and mishandled by middleware logic, becomes a master key to what was meant to be locked. CVE-2025-29927 exploits a misconfigured middleware authorization...
CVE-2025-29927_Scanner
CVE-2025-29927 Checker 📌 Introduction This script checks for the CVE-2025-29927 vulnerability in Next.js servers by testing multiple payloads in the x-middleware-subrequest header to detect unauthorized access. ❓ What is CVE-2025-29927? CVE-2025-29927 is a vulnerability that allows security...
nextjs-middleware-exploit
Next.js Middleware Vulnerability Research CVE-2025-29927 This repository demonstrates a critical vulnerability in Next.js middleware CVE-2025-29927, which affects versions 11.1.4 through 15.1.7. This vulnerability allows for authorization bypass , CSP bypass , and potential DoS attacks through...
next-js-auth-bypass
Hello World - Next.js 12.2 A simple proof of concept Next.js 12.2 application. 🚀 Quick Start 1. Install Dependencies npm install 2. Run the Development Server npm run dev The application will be available at http://localhost:3000 🛠️ Available Scripts npm run dev - Start development server npm...
CVE-2025-29927
CVE-2025-29927 - Next.js Middleware 15.2.2 - Authorization Bypass ⚠️ Critical Authentication Bypass in NextJS Middleware 🛠️ PoC implementation by @zs1n 💡 Overview NextJS is a popular React-based web framework, has an authentication vulnerability that affects versions prior to 12.3.5, 13.5.9,...
vulnerable-nextjs-14-CVE-2025-29927
CVE-2025-29927 Authorization Bypass reproduction This repository is a reproduction of the CVE-2025-29927 vulnerability in the next package How to reproduce 1. Follow the steps below to clone, and run the Next.js application 2. Test authorization denies access to the /api/hello endpoint $ curl...
PoC-CVE-2025-29927
PoC-CVE-2025-29927 what is the vuln? this cve reports an flaw in the header x-middleware-subrequest, responsible to takes internal requests in next.js, who allow an attacker bypass the authorization middlewares in next.js 15.0.0 and acess protected routes, for example real example in a webapp,...
vulnerable-nextjs-14-CVE-2025-29927
CVE-2025-29927 Authorization Bypass reproduction This repository is a reproduction of the CVE-2025-29927 vulnerability in the next package How to reproduce 1. Follow the steps below to clone, and run the Next.js application 2. Test authorization denies access to the /api/hello endpoint $ curl...
CVE-2025-29927-Testing
Testing script for CVE-2025-29927 Provided by CyberMaxx. CVE-2025-29927 Tester This PowerShell script is designed to help security researchers and system administrators test for CVE-2025-29927 vulnerabilities in Next.js applications. It checks whether a target application is vulnerable to the...
CVE-2025-29927_demo
CVE-2025-29937 Reproduction Steps npm i npm run dev curl -H "x-middleware-subrequest: middleware:middleware:middleware:middleware:middleware" http://localhost:3000/protected...
CVE-2025-29927
Introduction Bypass Next.js middleware authentication mechanism by forging the x-middleware-subrequest request header, allowing unauthorized access to protected routes. Environment setup Source code derived from P神, Next.js version 15.2.2 For Next.js 15.x, this issue is fixed in 15.2.3...
cve-2025-29927
cve-2025-29927 CVE-2025-29927 is a critical vulnerability in Next.js, a popular React-based web framework. The flaw exists in how the middleware feature handles certain internal headers — specifically, the x-middleware-subrequest header...
NextJS_CVE-2025-29927
Next.js Authorization Bypass Demo This application demonstrates the x-middleware-subrequest vulnerability in Next.js 13.4.19, which allows bypassing middleware protection. Setup 1. Install dependencies: npm install 2. Start the development server: npm run dev Vulnerability Demonstration The...
CVE-2025-29927
CVE-2025-29927 Introduction This document presents a study of the vulnerability CVE-2025-29927 , affecting the Middleware mechanism in the Next.js framework. Next.js is a popular open-source framework from Vercel for building React-based applications. It supports server-side rendering, static...
CVE-2025-29927
CVE-2025-29927: Next.js Middleware Bypass Vulnerability This repository demonstrates the CVE-2025-29927 vulnerability in Next.js where the internal header x-middleware-subrequest can be used to bypass middleware checks like authentication. Vulnerability Details Next.js uses an internal header...
POC-CVE-2025-29927
CVE-2025-29927: Next.js Middleware Bypass PoC Overview This PoC demonstrates CVE-2025-29927, a vulnerability in Next.js middleware that allows attackers to bypass authentication, authorization, and CSP mechanisms using the x-middleware-subrequest header. Affected Versions Next.js versions 11.1.4 ...
CVE-2025-55182
CVE-2025-55182 / CVE-2025-66478 — Next.js Middleware / RSC Bypass Analysis The author assumes no liability for misuse or damage caused by this research Provided strictly for educational and defensive purposes Description This repository contains a small laboratory and Proof-of-Concept analysis fo...
CVE-2025-29927
CVE-2025-29927 CVE-2025-29927: Next.js Middleware Bypass Vulnerability This repository demonstrates the CVE-2025-29927 vulnerability in Next.js where the internal header x-middleware-subrequest can be used to bypass middleware checks like authentication. Affected Versions Next.js 15.x 15.2.3...