Lucene search
+L

1929 matches found

Kitploit
Kitploit
•added 2026/10/04 7:05 p.m.•18 views

wolfssl

wolfSSL 嵌入式 SSL/TLS 库 wolfSSL 嵌入式 SSL 库(前身为 CyaSSL)是一个用 ANSI C 编写的轻量级 SSL/TLS 库,面向嵌入式、RTOS 和资源受限环境——主要因为其体积小、速度快且功能丰富。由于免版税定价和出色的跨平台支持,它也常用于标准操作环境。wolfSSL 支持直至当前 TLS 1.3 和 DTLS 1.3 的行业标准,体积比 OpenSSL 小多达 20 倍,并提供渐进式密码,如 ChaCha20、Curve25519、BLAKE2b/BLAKE2s 以及后量子 TLS 1.3 组。用户基准测试和反馈报告显示,使用 wolfSSL 相...

6.1AI score
SaveExploits0References1
Kitploit
Kitploit
•added 2026/10/04 4:09 p.m.•22 views

wolfCOSE

wolfCOSE wolfCOSEは、CBOR RFC 8949、COSE RFC 9052/9053、および wolfSSL を暗号バックエンドとして使用した耐量子 ML-DSA for COSE RFC 9964 を実装する軽量Cライブラリです。 主な機能 完全なRFC 9052メッセージセット : 6種類すべてのCOSEメッセージタイプ。複数署名者 COSESign や複数受信者 COSEEncrypt / COSEMac を含む 耐量子署名 : 3つのセキュリティレベルすべてにおけるML-DSA(FIPS 204)。RFC 9964...

6.2AI score
SaveExploits0References15
Kitploit
Kitploit
•added 2026/10/04 12:55 p.m.•20 views

wolfGuard

WolfGuard VPNとFIPS 140-3暗号化 WolfGuardは、wolfSSLのFIPS準拠のリファクタリングであり、Linuxカーネルベースの WireGuardを元に、Jason Donenfeldによって設計および作成されました。 使用方法は基本的に同一です。WolfGuardには2つの主要コンポーネントがあります:wolfguard.koカーネルモジュールとwg-fips設定ツールです。 wolfguard.koはlibwolfssl.koカーネルモジュールに依存し、wg-fipsはlibwolfssl.soライブラリに依存します —...

6.2AI score
SaveExploits0References1
Kitploit
Kitploit
•added 2026/10/04 9:04 a.m.•18 views

cve-2022-25640-exploit

使用 scapy 利用 CVE-2022-25640 参见 CVE-2022-25640.ipynb。 CVE-2022-25640 是 wolfSSL 5.2 之前版本中的一个漏洞。它允许客户端绕过 TLS 1.3 连接中的双向认证。...

7.5CVSS7.5AI score0.01352EPSS
SaveExploits0References1
Kitploit
Kitploit
•added 2026/10/03 12:42 p.m.•13 views

ml-kem-key-recovery

Full key recovery from a partial Fujisaki-Okamoto comparison in wolfSSL ML-KEM CVE-2026-6330 NEON and CVE-2026-10097 AVX2. Fixed in wolfSSL 5.9.2. The full technical write-up is published as Cryptology ePrint Archive, Paper 2026/1682 local copy in paper/. See Citation below. Introduction ML-KEM...

8.3CVSS6AI score0.00262EPSS
SaveExploits0References7
Tenable Nessus
Tenable Nessus
•added 2026/09/28 12:00 a.m.•11 views

Linux Distros Unpatched Vulnerability : CVE-2026-89135

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - A failed X509verifycert call permanently plants an unverified attacker CA in the shared CertManager, bypassing certificate validation in every type-blind siblin...

6.5CVSS5.8AI score0.00155EPSS
SaveExploits0References2
Tenable Nessus
Tenable Nessus
•added 2026/09/28 12:00 a.m.•13 views

Linux Distros Unpatched Vulnerability : CVE-2026-89133

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - wolfSSL versions 5.9.2 and earlier contain a flaw in the X.509 certificate validation logic where it fails to properly enforce NameConstraints extensions when...

6.3CVSS5.7AI score0.00116EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2026/09/28 12:00 a.m.•23 views

Linux Distros Unpatched Vulnerability : CVE-2026-89134

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - A certificate with no dNSName SAN but another SAN type present e.g. registeredID or iPAddress bypassed the Subject CN dNSName name-constraint check. The CN-as-D...

9.1CVSS5.8AI score0.00157EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2026/09/28 12:00 a.m.•12 views

Linux Distros Unpatched Vulnerability : CVE-2026-94417

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - When an application enables both OCSP and CRL revocation checking on one WOLFSSLCTX or certificate manager, wolfSSL skips the CRL check for any peer certificate...

5.3CVSS5.8AI score0.0015EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2026/09/28 12:00 a.m.•11 views

Linux Distros Unpatched Vulnerability : CVE-2026-89102

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - In wolfSSL versions 5.7.2 through 5.9.2 there is a client-side implementation flaw in RFC 6961, multiple OCSP response stapling, which can lead to certificate...

8.3CVSS5.9AI score0.00175EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2026/09/28 12:00 a.m.•11 views

Linux Distros Unpatched Vulnerability : CVE-2026-93304

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - A DTLS 1.2 client can accept a ChangeCipherSpec message before it has sent its ClientKeyExchange. No master secret has been derived at that point, so the client...

6.3CVSS5.8AI score0.0015EPSS
SaveExploits0References3
OSV
OSV
•added 2026/09/27 10:16 a.m.•6 views

DEBIAN-CVE-2026-94417

When an application enables both OCSP and CRL revocation checking on one WOLFSSLCTX or certificate manager, wolfSSL skips the CRL check for any peer certificate that carries no Authority Information Access OCSP URL, and accepts a certificate the loaded CRL lists as revoked. The soft-fail policy f...

5.3CVSS5.8AI score0.0015EPSS
SaveExploits0References1
NVD
NVD
•added 2026/09/27 10:16 a.m.•9 views

CVE-2026-89134

A certificate with no dNSName SAN but another SAN type present e.g. registeredID or iPAddress bypassed the Subject CN dNSName name-constraint check. The CN-as-DNS fallback was gated on cert-subjectCN != NULL && cert-altNames == NULL && !cert-isCA instead of "no dNSName SAN", so an out-of-scope CN...

9.1CVSS0.00157EPSS
SaveExploits0References1
OSV
OSV
•added 2026/09/27 10:16 a.m.•6 views

DEBIAN-CVE-2026-93304

A DTLS 1.2 client can accept a ChangeCipherSpec message before it has sent its ClientKeyExchange. No master secret has been derived at that point, so the client installs read keys derived from a known deterministic key and checks the server's Finished against that same key. An out-of-order...

3.7CVSS5.7AI score0.0015EPSS
SaveExploits0References1
NVD
NVD
•added 2026/09/27 10:16 a.m.•11 views

CVE-2026-89135

A failed X509verifycert call permanently plants an unverified attacker CA in the shared CertManager, bypassing certificate validation in every type-blind sibling consumer native TLS, OCSP, CRL, direct CM verify. This affects version 5.8.4 through 5.9.2 of wolfSSL with the macros OPENSSLEXTRA &&...

6.5CVSS0.00155EPSS
SaveExploits0References1
OSV
OSV
•added 2026/09/27 10:16 a.m.•9 views

DEBIAN-CVE-2026-93302

MatchTrustedPeer ignores the public key used, leading to forged CA clones passing verification. Affected builds are any that enable the macro WOLFSSLTRUSTPEERCERT and load CA certificates with wolfSSLCTXtrustpeercert or wolfSSLtrustpeercert. The peer must know the certificates being loaded to...

8.2CVSS5.8AI score0.00201EPSS
SaveExploits0References1
OSV
OSV
•added 2026/09/27 10:16 a.m.•7 views

DEBIAN-CVE-2026-89135

A failed X509verifycert call permanently plants an unverified attacker CA in the shared CertManager, bypassing certificate validation in every type-blind sibling consumer native TLS, OCSP, CRL, direct CM verify. This affects version 5.8.4 through 5.9.2 of wolfSSL with the macros OPENSSLEXTRA &&...

6.5CVSS5.8AI score0.00155EPSS
SaveExploits0References1
OSV
OSV
•added 2026/09/27 10:16 a.m.•5 views

AZL-105200 CVE-2026-94417 affecting package mariadb 10.11.19-1

When an application enables both OCSP and CRL revocation checking on one WOLFSSLCTX or certificate manager, wolfSSL skips the CRL check for any peer certificate that carries no Authority Information Access OCSP URL, and accepts a certificate the loaded CRL lists as revoked. The soft-fail policy f...

5.3CVSS5.8AI score0.0015EPSS
SaveExploits0References1
OSV
OSV
•added 2026/09/27 10:16 a.m.•9 views

DEBIAN-CVE-2026-89134

A certificate with no dNSName SAN but another SAN type present e.g. registeredID or iPAddress bypassed the Subject CN dNSName name-constraint check. The CN-as-DNS fallback was gated on cert-subjectCN != NULL && cert-altNames == NULL && !cert-isCA instead of "no dNSName SAN", so an out-of-scope CN...

9.1CVSS5.8AI score0.00157EPSS
SaveExploits0References1
NVD
NVD
•added 2026/09/27 10:16 a.m.•10 views

CVE-2026-94417

When an application enables both OCSP and CRL revocation checking on one WOLFSSLCTX or certificate manager, wolfSSL skips the CRL check for any peer certificate that carries no Authority Information Access OCSP URL, and accepts a certificate the loaded CRL lists as revoked. The soft-fail policy f...

5.3CVSS0.0015EPSS
SaveExploits0References1
Rows per page
Query Builder