2566 matches found
Input validation
In webpack-subresource-integrity before version 1.5.1, all dynamically loaded chunks receive an invalid integrity hash that is ignored by the browser, and therefore the browser cannot validate their integrity. This removes the additional level of protection offered by SRI for such chunks. Top-lev...
CVE-2020-15262 Invalid integrity hashes in webpack-subresource-integrity
In webpack-subresource-integrity before version 1.5.1, all dynamically loaded chunks receive an invalid integrity hash that is ignored by the browser, and therefore the browser cannot validate their integrity. This removes the additional level of protection offered by SRI for such chunks. Top-lev...
CVE-2020-15262
In webpack-subresource-integrity before version 1.5.1, all dynamically loaded chunks receive an invalid integrity hash that is ignored by the browser, and therefore the browser cannot validate their integrity. This removes the additional level of protection offered by SRI for such chunks. Top-lev...
CVE-2020-15262
Summary : CVE-2020-15262 affects webpack-subresource-integrity prior to 1.5.1. All dynamically loaded chunks receive an invalid integrity hash, which the browser ignores, removing the extra protection from SRI. Top-level chunks are unaffected. Impact (as stated) : The browser cannot validate inte...
@aldendaniels/react-scripts (0.8.3), @amc-technology/ui-library (1.0.10) +186 more potentially affected by CVE-2020-15262 via webpack-subresource-integrity (>=0.7.0, <=1.5.0)
webpack-subresource-integrity NPM version =0.7.0, =1.2.3, =9.0.0-beta.0, =0.8.8, =0.0.1-SNAPSHOT, =0.0.1-alpha.1, =1.2.2, =0.1.8, =0.0.0, =0.0.1, =0.0.1-alpha.2, =0.0.1, =0.0.1, =10.0.0 and more Source cves: CVE-2020-15262 Source advisory: MEND:CVE-2020-15262...
@amc-technology/ui-library (1.0.10), @amilabs/pink-unicorn (>=1.2.3, <=1.3.6) +174 more potentially affected by CVE-2020-15262 via webpack-subresource-integrity (>=1.0.4, <=1.5.0)
webpack-subresource-integrity NPM version =1.0.4, =1.2.3, =9.0.0-beta.0, =0.8.8, =0.0.1-SNAPSHOT, =0.0.1-alpha.1, =1.2.2, =0.1.8, =0.0.0, =0.0.1, =0.0.1-alpha.2, =0.0.1, =0.0.1, =0.6.0-next.3, =1.1.0 and more Source cves: CVE-2020-15262 Source advisory: OSV:GHSA-4FC4-CHG7-H8GH...
Unprotected dynamically loaded chunks
Impact All dynamically loaded chunks receive an invalid integrity hash that is ignored by the browser, and therefore the browser cannot validate their integrity. This removes the additional level of protection offered by SRI for such chunks. Top-level chunks are unaffected. Patches This issue is...
@amc-technology/ui-library (1.0.10), @amilabs/pink-unicorn (>=1.2.3, <=1.3.6) +174 more potentially affected by CVE-2020-15262 via webpack-subresource-integrity (>=1.0.4, <=1.5.0)
webpack-subresource-integrity NPM version =1.0.4, =1.2.3, =9.0.0-beta.0, =0.8.8, =0.0.1-SNAPSHOT, =0.0.1-alpha.1, =1.2.2, =0.1.8, =0.0.0, =0.0.1, =0.0.1-alpha.2, =0.0.1, =0.0.1, =0.6.0-next.3, =1.1.0 and more Source cves: CVE-2020-15262 Source advisory: GHSA-4FC4-CHG7-H8GH...
CVE-2020-15262: Insufficient Verification of Data Authenticity
In webpack-subresource-integrity before version 1.5.1, all dynamically loaded chunks receive an invalid integrity hash that is ignored by the browser, and therefore the browser cannot validate their integrity. This removes the additional level of protection offered by SRI for such chunks. Top-lev...
PT-2020-14322
Name of the Vulnerable Software and Affected Versions webpack-subresource-integrity versions prior to 1.5.1 Description The issue affects dynamically loaded chunks, which receive an invalid integrity hash that is ignored by the browser. This removes the additional level of protection offered by...
my-testutil (1.0.1), storm-test (0.0.1) +1 more potentially affected by unknown CVE via wepack-cli (0.0.1-security)
wepack-cli NPM version 0.0.1-security is affected by a known vulnerability. The following packages have a transitive dependency on wepack-cli and may be impacted: - my-testutil 1.0.1 - storm-test 0.0.1 - stormydb =0.1.1, =0.5.2 Source cves: unknown CVE Source advisory: GHSA-FPW3-X4XQ-6VXQ...
PT-2020-21281
Name of the Vulnerable Software and Affected Versions wepack-cli versions affected versions not specified Description The issue concerns a typosquatted package that tracked users who installed it by mistake, thinking it was a similarly named popular package. Upon installation, the package uploade...
@elastic/eui (>=0.0.1-prealpha, <=0.0.11), @pl-test/c (>=1.1.0, <=1.1.1) +5 more potentially affected by unknown CVE via serve (>=6.0.0, <=6.4.10)
serve NPM version =6.0.0, =0.0.1-prealpha, =1.1.0, =7.1.9, =4.1.8, =5.0.0 Source cves: unknown CVE Source advisory: GHSA-WM7Q-RXCH-43MX...
Command Injection
Amendment This was deemed not a vulnerability. Overview git-revision-webpack-plugin is a simple webpack plugin that generates version and commithash files during build based on a local git repository. Affected versions of this package are vulnerable to Command Injection. The function commithash...
Denial Of Service (DoS)
webpack-dev-middleware is vulnerable to denial of service. A memory leak occurs when the function writeToDisk is used, causing the compile-time to keep increasing as the duplicates write to disk keep increasing, eventually leading to a denial of service condition...
@500tech/react-scripts (>=3.0.0-alpha.8, <=5.1.0), @51npm/freedom-middleware-webpack4 (>=1.0.0, <=1.1.0) +149 more potentially affected by unknown CVE via webpack-bundle-analyzer (>=3.0.1, <=3.2.0)
webpack-bundle-analyzer NPM version =3.0.1, =3.0.0-alpha.8, =1.0.0, =0.9.0, =0.0.1-canary.49, =0.1.0, =9.0.0, =2.0.0-1, =1.12.0, =0.3.0, =1.0.0-1.0.0-beta.34.0, =0.1.0, =6.0.0-alpha.1, =0.0.1, =1.0.0, =0.0.1-alpha.151, =0.0.1-alpha.153 and more Source cves: unknown CVE Source advisory:...
Cross-Site Scripting in webpack-bundle-analyzer
Versions of webpack-bundle-analyzer prior to 3.3.2 are vulnerable to Cross-Site Scripting. The package uses JSON.stringify without properly escaping input which may lead to Cross-Site Scripting. Recommendation Upgrade to version 3.3.2 or later...
GHSA-PGR8-JG6H-8GW6 Cross-Site Scripting in webpack-bundle-analyzer
Versions of webpack-bundle-analyzer prior to 3.3.2 are vulnerable to Cross-Site Scripting. The package uses JSON.stringify without properly escaping input which may lead to Cross-Site Scripting. Recommendation Upgrade to version 3.3.2 or later...
@500tech/react-scripts (>=3.0.0-alpha.8, <=5.1.0), @51npm/freedom-middleware-webpack4 (>=1.0.0, <=1.1.0) +149 more potentially affected by unknown CVE via webpack-bundle-analyzer (>=3.0.1, <=3.2.0)
webpack-bundle-analyzer NPM version =3.0.1, =3.0.0-alpha.8, =1.0.0, =0.9.0, =0.0.1-canary.49, =0.1.0, =9.0.0, =2.0.0-1, =1.12.0, =0.3.0, =1.0.0-1.0.0-beta.34.0, =0.1.0, =6.0.0-alpha.1, =0.0.1, =1.0.0, =0.0.1-alpha.151, =0.0.1-alpha.153 and more Source cves: unknown CVE Source advisory:...
PT-2019-20063
Name of the Vulnerable Software and Affected Versions webpack-bundle-analyzer versions prior to 3.3.2 Description The issue concerns Cross-Site Scripting due to the improper use of JSON.stringify without escaping input, which may lead to security risks. Recommendations Upgrade to version 3.3.2 or...