2566 matches found
GHSA-WR3J-PWJ9-HQQ6 Path traversal in webpack-dev-middleware
Summary The webpack-dev-middleware middleware does not validate the supplied URL address sufficiently before returning the local file. It is possible to access any file on the developer's machine. Details The middleware can either work with the physical filesystem when reading the files or it can...
@moneko/core (>=3.9.17-beta.25, <=3.11.1-beta.2), @proteinjs/server (>=1.0.1, <=2.1.10) +2 more potentially affected by CVE-2024-29180 via webpack-dev-middleware (7.0.0)
webpack-dev-middleware NPM version 7.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on webpack-dev-middleware and may be impacted: - @moneko/core =3.9.17-beta.25, =1.0.1, =1.1.0, =0.0.101, =0.0.113 Source cves: CVE-2024-29180 Source advisory:...
@angular-architects/build-angular (16.2.0-next.2), @angular-devkit/build-angular (>=15.1.0-next.0, <=17.3.1) +165 more potentially affected by CVE-2024-29180 via webpack-dev-middleware (>=6.0.0, <=6.1.1)
webpack-dev-middleware NPM version =6.0.0, =15.1.0-next.0, =9.3.0, =1.12.3, =4.20.4, =0.1.0, =3.1.0-0, =3.0.0-alpha.14, =15.1.0-snapshot-1674521814202, =16.0.0-next.6, =2.6.0, =8.4.0-rc.2, =7.0.0-rc.11, =7.0.0-rc.16 and more Source cves: CVE-2024-29180 Source advisory: GHSA-WR3J-PWJ9-HQQ6...
@alex91ivanov/ngx-run-builder (1.0.0), @alfresco/adf-testing (6.0.0-A.2-8258) +137 more potentially affected by CVE-2024-29180 via webpack-dev-middleware (>=5.0.0, <=5.3.3)
webpack-dev-middleware NPM version =5.0.0, =2.0.70, =0.12.0, =13.0.0, =0.9.2, =12.0.0-beta.0, =12.1.0-next.5, =1.0.0-alpha.32, =0.0.15, =6.0.0, =1.0.0, =1.0.4 and more Source cves: CVE-2024-29180 Source advisory: GHSA-WR3J-PWJ9-HQQ6...
@moneko/core (>=3.9.17-beta.25, <=3.11.1-beta.2), @proteinjs/server (>=1.0.1, <=2.1.10) +2 more potentially affected by CVE-2024-29180 via webpack-dev-middleware (7.0.0)
webpack-dev-middleware NPM version 7.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on webpack-dev-middleware and may be impacted: - @moneko/core =3.9.17-beta.25, =1.0.1, =1.1.0, =0.0.101, =0.0.113 Source cves: CVE-2024-29180 Source advisory:...
@alex91ivanov/ngx-run-builder (1.0.0), @alfresco/adf-testing (6.0.0-A.2-8258) +137 more potentially affected by CVE-2024-29180 via webpack-dev-middleware (>=5.0.0, <=5.3.3)
webpack-dev-middleware NPM version =5.0.0, =2.0.70, =0.12.0, =13.0.0, =0.9.2, =12.0.0-beta.0, =12.1.0-next.5, =1.0.0-alpha.32, =0.0.15, =6.0.0, =1.0.0, =1.0.4 and more Source cves: CVE-2024-29180 Source advisory: OSV:GHSA-WR3J-PWJ9-HQQ6...
Path traversal in webpack-dev-middleware
Summary The webpack-dev-middleware middleware does not validate the supplied URL address sufficiently before returning the local file. It is possible to access any file on the developer's machine. Details The middleware can either work with the physical filesystem when reading the files or it can...
CVE-2024-29180
Prior to versions 7.1.0, 6.1.2, and 5.3.4, the webpack-dev-middleware development middleware for devpack does not validate the supplied URL address sufficiently before returning the local file. It is possible to access any file on the developer's machine. The middleware can either work with the...
CVE-2024-29180 webpack-dev-middleware Path Traversal vulnerability
Prior to versions 7.1.0, 6.1.2, and 5.3.4, the webpack-dev-middleware development middleware for devpack does not validate the supplied URL address sufficiently before returning the local file. It is possible to access any file on the developer's machine. The middleware can either work with the...
@moneko/core (>=3.9.17-beta.25, <=3.11.1-beta.2), @proteinjs/server (>=1.0.1, <=2.1.10) +2 more potentially affected by CVE-2024-29180 via webpack-dev-middleware (7.0.0)
webpack-dev-middleware NPM version 7.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on webpack-dev-middleware and may be impacted: - @moneko/core =3.9.17-beta.25, =1.0.1, =1.1.0, =0.0.101, =0.0.113 Source cves: CVE-2024-29180 Source advisory:...
@angular-architects/build-angular (16.2.0-next.2), @angular-devkit/build-angular (>=15.1.0-next.0, <=17.3.1) +165 more potentially affected by CVE-2024-29180 via webpack-dev-middleware (>=6.0.0, <=6.1.1)
webpack-dev-middleware NPM version =6.0.0, =15.1.0-next.0, =9.3.0, =1.12.3, =4.20.4, =0.1.0, =3.1.0-0, =3.0.0-alpha.14, =15.1.0-snapshot-1674521814202, =16.0.0-next.6, =2.6.0, =8.4.0-rc.2, =7.0.0-rc.11, =7.0.0-rc.16 and more Source cves: CVE-2024-29180 Source advisory: MEND:CVE-2024-29180...
-tompan-reacttemplate (>=1.0.1, <=1.1.0), 0726react (0.1.1) +33269 more potentially affected by CVE-2024-29180 via webpack-dev-middleware (>=0.6.2, <=5.3.3)
webpack-dev-middleware NPM version =0.6.2, =1.0.1, =1.1.0 - 0726react 0.1.1 - 0x0.icu.anima 0.1.0 - 0xgank-tea-advice-pull 1.0.0 - 0xgank-tea-balance-pencil 1.0.0 - 0xgank-tea-brick-bell 1.0.0 - 0xgank-tea-cake-victory 1.0.0 - 0xgank-tea-central-compound 1.0.0 - 0xgank-tea-characteristic 1.0.0 -...
CVE-2024-29180
Prior to versions 7.1.0, 6.1.2, and 5.3.4, the webpack-dev-middleware development middleware for devpack does not validate the supplied URL address sufficiently before returning the local file. It is possible to access any file on the developer's machine. The middleware can either work with the...
CVE-2024-29180 webpack-dev-middleware Path Traversal vulnerability
Prior to versions 7.1.0, 6.1.2, and 5.3.4, the webpack-dev-middleware development middleware for devpack does not validate the supplied URL address sufficiently before returning the local file. It is possible to access any file on the developer's machine. The middleware can either work with the...
CVE-2024-29180 webpack-dev-middleware Path Traversal vulnerability
Prior to versions 7.1.0, 6.1.2, and 5.3.4, the webpack-dev-middleware development middleware for devpack does not validate the supplied URL address sufficiently before returning the local file. It is possible to access any file on the developer's machine. The middleware can either work with the...
CVE-2024-29180
CVE-2024-29180 affects the webpack-dev-middleware development middleware used with webpack-dev-server/webpack-dev-middleware. The vulnerability arises from improper URL unescaping/normalization before parsing the requested file, allowing path traversal via sequences like %2e and %2f to access loc...
PT-2026-80854
Name of the Vulnerable Software and Affected Versions webpack-dev-middleware versions 5.3.4 through 5.x webpack-dev-middleware versions 6.1.2 through 6.x webpack-dev-middleware versions 7.1.0 through 7.x Description The software fails to sufficiently validate URL addresses before returning local...
CVE-2024-29180: Improper Limitation of a Pathname to a Restricted Directory
Prior to versions 7.1.0, 6.1.2, and 5.3.4, the webpack-dev-middleware development middleware for devpack does not validate the supplied URL address sufficiently before returning the local file. It is possible to access any file on the developer's machine. The middleware can either work with the...
webpack-dev-middleware security vulnerabilities
webpack-dev-middleware is an express style development middleware for webpack open source . Used for webpack bundles and allows to provide files emitted from webpack. A security vulnerability exists in webpack-dev-middleware versions prior to 7.1.0, 6.1.2, and 5.3.4, which stems from a path...
Fedora 38 : yarnpkg (2024-5ecc250449)
The remote Fedora 38 host has a package installed that is affected by multiple vulnerabilities as referenced in the FEDORA-2024-5ecc250449 advisory. Update to 1.22.21, add fixes for CVE-2022-37599, CVE-2023-26136, CVE-2023-46234. Tenable has extracted the preceding description block directly from...