168 matches found
CVE-2026-44578-next-js-ssrf
CVE-2026-44578 β Next.js WebSocket Upgrade SSRF Lab Self-contained lab to reproduce the CVE-2026-44578 vulnerability CWE-918, SSRF in self-hosted Next.js applications that use the built-in Node.js server. Field| Value ---|--- CVE| CVE-2026-44578 GHSA| GHSA-c4j6-fc7j-m34r CVSS 3.1| 8.6 HIGH...
cve-2026-69243-poc-aiohttp-smuggling
CVE-2026-69243 β aiohttp Request Smuggling CWE-444 Request smuggling via rejected WebSocket upgrade in aiohttp Or build the Rust version zero dependencies, std only: git clone https://github.com/JVBotelho/cve-2026-69243-poc-aiohttp-smuggling cd cve-2026-69243-poc-aiohttp-smuggling/poc cargo build...
verify-ghsa-c4j6-fc7j-m34r
verify-ghsa-c4j6-fc7j-m34r In-band verifier for GHSA-c4j6-fc7j-m34r / CVE-2026-44578 β Server-Side Request Forgery in Next.js via WebSocket upgrade requests. β οΈ For authorized security testing only. You are responsible for ensuring you have permission to test every target you pass to this script...
CVE-2026-44578-PoC
CVE-2026-44578 - Next.js WebSocket SSRF PoC Vulnerability: Server-Side Request Forgery in Next.js WebSocket upgrade handler 13.4.13 β 15.5.15, 16.0.0 β 16.1.6 Usage Detect vulnerability python3 poc.py target.com:3000 --detect Tunnel to internal Redis python3 poc.py target.com:3000 --internal...
CVE-2020-7693
CVE-2020-7693 Poc Note: I Confirm Payload for CVE-2020-7693 can running in Bug Bounty Program Description: Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20. Single Request Crashes Serve...
CVE-2026-44578
CVE-2026-44578 β Next.js WebSocket Upgrade SSRF Pre-authentication Server-Side Request Forgery in Next.js self-hosted deployments. A single crafted HTTP request extracts AWS credentials, secrets, and internal service data from localhost:80. Field| Value ---|--- CVE| CVE-2026-44578 GHSA|...
cve-2018-1002105
This was modified from https://gravitational.com/blog/kubernetes-websocket-upgrade-security-vulnerability/. All credit goes to the kind folks at Gravitational. The original PoC code was modified to go a bit beyond checking for vulnerability and to actually run a command inside the first container...
CVE-2026-44578
π¨ CVE-2026-44578 β Next.js SSRF Vulnerability π Overview CVE-2026-44578 is a high-severity Server-Side Request Forgery SSRF vulnerability affecting self-hosted Next.js applications. Attackers can exploit crafted WebSocket Upgrade Requests to force the server into making outbound requests to...
cve-2018-1002105
CVE-2018-1002105 Test utility that checks a cluster for the high severity kubernetes CVE published here. A stakeholder-level writeup of the CVE-2018-1002105 may be found at https://gravitational.com/blog/kubernetes-websocket-upgrade-security-vulnerability/ Warning Running this test through layer ...
Echo: Rejected WebSocket upgrades can bypass Echo route-level access controls
Impact Echo's Proxy middleware selected a raw tunnel when the client requested a WebSocket upgrade, before validating whether the configured upstream accepted it. If the upstream returned an ordinary HTTP response and kept the connection alive, subsequent HTTP requests on that connection were...
CVE-2026-57169 Dockhand: Unauthenticated container exec via WebSocket upgrade
Dockhand is a Docker management application. Prior to 1.0.34, the in-browser container terminal endpoint /api/containers//exec does not enforce authentication on the WebSocket upgrade request. When an unauthenticated attacker has network reach to Dockhand, knows a target container ID, and targets...
CVE-2026-57169
The Docker management application Dockhand is vulnerable to unauthenticated command execution in versions prior to 1.0.34 . The /api/containers/exec endpoint fails to enforce authentication during a WebSocket upgrade request. An unauthenticated attacker with network reach and knowledge of a targe...
nextssrf
ββββββββββββββββββββββββββββββββββββββββββββββββββββββββββββββββ β NextSSRF β CVE-2026-44578 Scanner & Exploit β β Next.js WebSocket Upgrade Handler SSRF β β Affected: 13.4.13 β 15.5.15, 16.0.0 β 16.2.4 β β @mitsec / ynsmroztas β Bug Bounty Tooling β...
PT-2026-105192
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, Neither the Web-MQTT handler deps/rabbitmq web mqtt/src/rabbit web mqtt handler.erl:104 nor the Web-STOMP handler deps/rabbitmq web stomp/src/rabbit web stomp handler.erl:102 validates the...
Socket.IO: Engine.IO Protocol Revision Mismatch DoS
Impact A denial-of-service vulnerability exists in Engine.IO / Socket.IO servers that allow transport upgrades. The Engine.IO protocol revision is negotiated during the initial handshake and stored on the session, but a newly-created transport, including a WebSocket upgrade transport, could...
CVE-2026-100558
OpenClaw versions before 2026.8.1 contain a resource exhaustion vulnerability in the Gateway listener that allows unauthenticated clients to retain response sockets by sending WebSocket upgrade requests without matching connection semantics. Attackers can repeatedly send malformed upgrade request...
CVE-2026-100527
OpenClaw before 2026.8.2 contains a denial of service vulnerability in the Browser extension relay that allows unauthenticated network sources to exhaust pending-authentication capacity. Attackers can hold every pending slot by maintaining silent WebSocket upgrades, preventing paired extensions...
CVE-2026-100558
OpenClaw versions before 2026.8.1 contain a resource exhaustion vulnerability in the Gateway listener that allows unauthenticated clients to retain response sockets by sending WebSocket upgrade requests without matching connection semantics. Attackers can repeatedly send malformed upgrade request...
EUVD-2026-87492
OpenClaw versions before 2026.8.1 contain a resource exhaustion vulnerability in the Gateway listener that allows unauthenticated clients to retain response sockets by sending WebSocket upgrade requests without matching connection semantics. Attackers can repeatedly send malformed upgrade request...
CVE-2026-100558 OpenClaw before 2026.8.1 Resource Exhaustion via WebSocket Upgrade
OpenClaw versions before 2026.8.1 contain a resource exhaustion vulnerability in the Gateway listener that allows unauthenticated clients to retain response sockets by sending WebSocket upgrade requests without matching connection semantics. Attackers can repeatedly send malformed upgrade request...