1764 matches found
CVE-2026-94419
Without NOSESSIONCACHEREF, wolfSSLgetsession does not return a session object but a ClientSession reference of the form row, index, hashsessionID into the process-global SessionCache, and ClientSessionToSession validates it against that hash alone. Because the TLS 1.2 session ID is chosen by the...
wolfssl
MQX向けビルド方法 概要 このMakefileはwolfSSLライブラリーとサンプルプログラムをMQX向けにビルドするためのものです。 以下のターゲットを含んでいます。 wolfssllib: wolfSSL静的ライブラリー test: 暗号アルゴリズムのテスト benchmark: 暗号アルゴリズムのベンチマーク client: TLS クライアントサンプルプログラム server: TLS サーバサンプルプログラム 準備 事前にGCCをインストールしておいてください。 GNU Arm Embedded Toolchain, https://developer.arm.com...
wolfCOSE
wolfCOSE wolfCOSEは、CBOR RFC 8949、COSE RFC 9052/9053、および wolfSSL を暗号バックエンドとして使用した耐量子 ML-DSA for COSE RFC 9964 を実装する軽量Cライブラリです。 主な機能 完全なRFC 9052メッセージセット : 6種類すべてのCOSEメッセージタイプ。複数署名者 COSESign や複数受信者 COSEEncrypt / COSEMac を含む 耐量子署名 : 3つのセキュリティレベルすべてにおけるML-DSA(FIPS 204)。RFC 9964...
cve-2022-25640-exploit
scapyを用いたCVE-2022-25640の悪用 参照: CVE-2022-25640.ipynb. CVE-2022-25640は、wolfSSL 5.2より前のバージョンに存在する脆弱性です。これにより、クライアントはTLS 1.3接続における相互認証を迂回できます。...
CVE-2026-82208
A flaw was found in libcurl when using the wolfSSL backend. When CA Certificate Authority caching is enabled and a CURLOPTSSLCTXFUNCTION callback is used to replace the trust store, libcurl can silently reinstall the cached store. This can lead to a scenario where a certificate that should be...
ml-kem-key-recovery
Full key recovery from a partial Fujisaki-Okamoto comparison in wolfSSL ML-KEM CVE-2026-6330 NEON and CVE-2026-10097 AVX2. Fixed in wolfSSL 5.9.2. The full technical write-up is published as Cryptology ePrint Archive, Paper 2026/1682 local copy in paper/. See Citation below. Introduction ML-KEM...
Astra Linux – Vulnerability in curl
With the wolfSSL backend, when CA caching is enabled and a CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. This results in a certificate trusted by the cached store but rejected by the callback-selected store bei...
AZL-99849 CVE-2026-82208 affecting package rust 1.90.0-10
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
AZL-99756 CVE-2026-82208 affecting package curl 8.11.1-11
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
ALPINE-CVE-2026-82208
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
CVE-2026-82208
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
AZL-99798 CVE-2026-82208 affecting package mysql 8.0.46-1
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
AZL-99840 CVE-2026-82208 affecting package rust 1.75.0-30
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
CVE-2026-82208 wolfSSL CA-cache hit overrides callback
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
CVE-2026-82208
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
CVE-2026-82208 wolfSSL CA-cache hit overrides callback
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
CVE-2026-82208
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
EUVD-2026-72152
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
CVE-2026-82208
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...
CVE-2026-82208 wolfSSL CA-cache hit overrides callback
With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...