3031 matches found
AZL-75192 CVE-2026-24049 affecting package python-virtualenv 20.26.6-2
wheel is a command line tool for manipulating Python wheel files, as defined in PEP 427. In versions 0.40.0 through 0.46.1, the unpack function is vulnerable to file permission modification through mishandling of file permissions after extraction. The logic blindly trusts the filename from the...
CVE-2026-22702
A flaw was found in virtualenv, a tool for creating isolated virtual Python environments. A local attacker can exploit a Time-of-Check-Time-of-Use TOCTOU race condition during directory creation operations. By performing symlink-based attacks, the attacker can redirect virtualenv's application da...
MiracleLinux 8 : python36:3.6 (AXSA:2024-9397:01)
The remote MiracleLinux 8 host has packages installed that are affected by a vulnerability as referenced in the AXSA:2024-9397:01 advisory. virtualenv: potential command injection via virtual environment activation scripts CVE-2024-53899 Tenable has extracted the preceding description block...
MiracleLinux 7 : python-virtualenv-15.1.0-7.el7 (AXSA:2022-3284:03)
The remote MiracleLinux 7 host has a package installed that is affected by a vulnerability as referenced in the AXSA:2022-3284:03 advisory. python-pip: directory traversal in downloadhttpurl function in src/pip/internal/download.py CVE-2019-20916 Tenable has extracted the preceding description...
MiracleLinux 7 : python-virtualenv-15.1.0-4.el7 (AXSA:2020-4513:01)
The remote MiracleLinux 7 host has a package installed that is affected by multiple vulnerabilities as referenced in the AXSA:2020-4513:01 advisory. python-urllib3: Cross-host redirect does not remove Authorization header allow for credential exposure CVE-2018-20060 python-urllib3: CRLF injection...
OESA-2026-1185 python-virtualenv security update
Virtualenv is a tool to create isolated Python environments. Since Python 3.3, a subset of it has been integrated into the standard library under the venv module. Note though, that the venv module does not offer all features of this library e.g. cannot create bootstrap scripts, cannot create...
OESA-2026-1187 python-virtualenv security update
Virtualenv is a tool to create isolated Python environments. Since Python 3.3, a subset of it has been integrated into the standard library under the venv module. Note though, that the venv module does not offer all features of this library e.g. cannot create bootstrap scripts, cannot create...
OESA-2026-1188 python-virtualenv security update
Virtualenv is a tool to create isolated Python environments. Since Python 3.3, a subset of it has been integrated into the standard library under the venv module. Note though, that the venv module does not offer all features of this library e.g. cannot create bootstrap scripts, cannot create...
OESA-2026-1186 python-virtualenv security update
Virtualenv is a tool to create isolated Python environments. Since Python 3.3, a subset of it has been integrated into the standard library under the venv module. Note though, that the venv module does not offer all features of this library e.g. cannot create bootstrap scripts, cannot create...
python311-virtualenv-20.36.1-1.1 on GA media (moderate)
python311-virtualenv-20.36.1-1.1 on GA media Announcement ID: openSUSE-SU-2026:10055-1 Rating: moderate Cross-References: CVE-2025-68146 CVE-2026-22702 CVSS scores: CVE-2025-68146 SUSE : 4.7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N CVE-2025-68146 SUSE : 5.7...
OPENSUSE-SU-2026:10055-1 python311-virtualenv-20.36.1-1.1 on GA media
These are all security issues fixed in the python311-virtualenv-20.36.1-1.1 package on the GA media of openSUSE Tumbleweed...
pip-faster (>=1.0.0rc1, <=1.0.0rc6.dev4) potentially affected by CVE-2026-22702 via virtualenv (1.11.6)
virtualenv PYPI version 1.11.6 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - pip-faster =1.0.0rc1, =1.0.0rc6.dev4 Source cves: CVE-2026-22702 Source advisory: OSV:GHSA-597G-3PHW-6986...
dcoscli (>=0.1.1, <=0.1.8) potentially affected by CVE-2026-22702 via virtualenv (12.1.1)
virtualenv PYPI version 12.1.1 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - dcoscli =0.1.1, =0.1.8 Source cves: CVE-2026-22702 Source advisory: OSV:GHSA-597G-3PHW-6986...
uranium (>=0.2.8, <=0.2.22) potentially affected by CVE-2026-22702 via virtualenv (13.1.0)
virtualenv PYPI version 13.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - uranium =0.2.8, =0.2.22 Source cves: CVE-2026-22702 Source advisory: OSV:GHSA-597G-3PHW-6986...
dcoscli (>=0.1.9, <=0.4.6), python-mu (>=1.0.1, <=1.0.3) +1 more potentially affected by CVE-2026-22702 via virtualenv (13.1.2)
virtualenv PYPI version 13.1.2 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - dcoscli =0.1.9, =1.0.1, =0.2.23, =0.2.34 Source cves: CVE-2026-22702 Source advisory: OSV:GHSA-597G-3PHW-6986...
cloudmesh-client (4.2.6) potentially affected by CVE-2026-22702 via virtualenv (15.0.1)
virtualenv PYPI version 15.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - cloudmesh-client 4.2.6 Source cves: CVE-2026-22702 Source advisory: OSV:GHSA-597G-3PHW-6986...
debpackager (>=0.1.0, <=0.2.1), scriptworker (0.2.1) +1 more potentially affected by CVE-2026-22702 via virtualenv (15.0.2)
virtualenv PYPI version 15.0.2 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - debpackager =0.1.0, =0.2.35, =1.1.0 Source cves: CVE-2026-22702 Source advisory: OSV:GHSA-597G-3PHW-6986...
cateye (>=0.3.4, <=0.3.8), edx-completion (>=0.0.1, <=0.1.1) +4 more potentially affected by CVE-2026-22702 via virtualenv (15.1.0)
virtualenv PYPI version 15.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - cateye =0.3.4, =0.0.1, =0.5.7, =1.0.0rc1, =1.2.0, =1.7.1 Source cves: CVE-2026-22702 Source advisory: OSV:GHSA-597G-3PHW-6986...
backlogapi (>=0.1.3, <=0.1.5), dcoscli (>=0.4.10, <=0.6.1) +1 more potentially affected by CVE-2026-22702 via virtualenv (15.2.0)
virtualenv PYPI version 15.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - backlogapi =0.1.3, =0.4.10, =0.6.7, =0.7.1 Source cves: CVE-2026-22702 Source advisory: OSV:GHSA-597G-3PHW-6986...
cabrita (>=2.2.2b1, <=2.2.2b2), kaze-python (>=0.7.8, <=0.8.9) +2 more potentially affected by CVE-2026-22702 via virtualenv (16.0.0)
virtualenv PYPI version 16.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - cabrita =2.2.2b1, =0.7.8, =0.7.2, =1.7.2, =1.11.0 Source cves: CVE-2026-22702 Source advisory: OSV:GHSA-597G-3PHW-6986...