1162 matches found
XPRTestSuite
XProtect Remediator Test Suite A collection of scripts and documents to help future XProtect Remediator XPR research, presented at Black Hat USA 2025 About This Repository This repository contains: The scripts to create harmless minimal files and processes that reproduce the remediation of each...
chipsec
CHIPSEC: Platform Security Assessment Framework CHIPSEC is a framework for analyzing the security of PC platforms including hardware, system firmware BIOS/UEFI, and platform components. It includes a security test suite, tools for accessing various low level interfaces, and forensic capabilities...
lava
LAVA: Large Scale Automated Vulnerability Addition Evaluating and improving bug-finding tools is currently difficult due to a shortage of ground truth corpora i.e., software that has known bugs with triggering inputs. LAVA attempts to solve this problem by automatically injecting bugs into...
http-desync-guardian
Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...
[SECURITY] [DLA 4821-2] libmodule-cpants-analyse-perl regression update
------------------------------------------------------------------------- Debian LTS Advisory DLA-4821-2 [email protected] https://www.debian.org/lts/security/ Arnaud Rebillout October 06, 2026 https://wiki.debian.org/LTS -...
MAL-2026-16267 Malicious code in pyjstat-smooth (PyPI)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector f65efaaf25b41d789624595550d966762b21747205b23f15325db2e05924387d The package advertised as a JSON-stat library ships a test module that, when the test suite is executed, walks the /app and /Users directory trees,...
SEMA-GUARD: Semantic and Graph-Based Vulnerability Detection in Assembly Code
In cases where source code is not available, such as malware analysis, firmware analysis, and embedded systems analysis, vulnerability detection in compiled programs has gained importance. Current methods are heavily reliant on syntactical regularities or higher level representations that are...
Towards Behavior Tree-Guided Vulnerability Detection with Lightweight LLMs
Large Language Models LLMs are increasingly used for software vulnerability detection, but their performance depends on how source code is represented in the input. Most prompting approaches use source code in its original form, while some works propose the use of structured representations...
[SECURITY] [DLA 4764-2] libdbd-csv-perl regression update
Debian LTS Advisory DLA-4764-2 [email protected] https://www.debian.org/lts/security/ Guilhem Moulin August 31, 2026 https://wiki.debian.org/LTS Package : libdbd-csv-perl Version : 0.5800-1+deb11u1 0.6000-1+deb12u1 Debian Bug : 1139509 The security fix for CVE-2026-15392 symlink escape ...
MAL-2026-12024 Malicious code in @keyv/test-suite (npm)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 710c3cc7a3215d4a3bfa506c57bf04ffc7973d33da9dca652060a6bf1d0a4856 @keyv/test-suite is a shared test harness used by keyv storage adapter packages. No install-time lifecycle hooks, remote fetches, credential reads,...
Malicious code in @keyv/test-suite (npm)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 710c3cc7a3215d4a3bfa506c57bf04ffc7973d33da9dca652060a6bf1d0a4856 @keyv/test-suite is a shared test harness used by keyv storage adapter packages. No install-time lifecycle hooks, remote fetches, credential reads,...
Phoronix Test Suite Panel - Detect
Phoronix Test Suite panel was detected. !/usr/bin/env python3 -- coding: utf-8 -- """Phoronix Test Suite panel was detected.""" import re from kittysploit import from lib.protocols.http.httpclient import Httpclient class ModuleScanner, Httpclient: info = 'name': 'Phoronix Test Suite Panel -...
io.micronaut:micronaut-function-client (2.0.1), io.micronaut:micronaut-test-suite-kotlin (2.0.1) +1 more potentially affected by unknown CVE via io.micronaut:micronaut-http-client (2.0.1)
io.micronaut:micronaut-http-client MAVEN version 2.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on io.micronaut:micronaut-http-client and may be impacted: - io.micronaut:micronaut-function-client 2.0.1 - io.micronaut:micronaut-test-suite-kotlin 2.0...
Fedora 44 : leptonica / openqa / os-autoinst (2026-a72f110dcd)
The remote Fedora 44 host has packages installed that are affected by a vulnerability as referenced in the FEDORA-2026-a72f110dcd advisory. This update includes new upstream snapshots of openQA and os-autoinst, with the usual mix of fixes and improvements. See upstream changelogs for details. For...
CVE-2026-53026
This CVE concerns Linux kernel NFSD: in nfsd4_add_rdaccess_to_wrdeleg, an extra nfs4_file access count may be incremented by multiple threads, preventing the corresponding nfsd_file from being freed and triggering a BUG during kmem_cache_destroy() when stopping the nfs-server. Descriptions across...
org.apache.nifi:nifi-system-test-suite (1.16.3) potentially affected by CVE-2026-54665 via org.apache.nifi:nifi-jetty (1.16.3)
org.apache.nifi:nifi-jetty MAVEN version 1.16.3 is affected by a known vulnerability. The following packages have a transitive dependency on org.apache.nifi:nifi-jetty and may be impacted: - org.apache.nifi:nifi-system-test-suite 1.16.3 Source cves: CVE-2026-54665 Source advisory:...
org.apache.nifi:nifi-framework-nar (1.12.1), org.apache.nifi:nifi-system-test-suite (1.12.1) potentially affected by CVE-2026-54665 via org.apache.nifi:nifi-jetty (1.12.1)
org.apache.nifi:nifi-jetty MAVEN version 1.12.1 is affected by a known vulnerability. The following packages have a transitive dependency on org.apache.nifi:nifi-jetty and may be impacted: - org.apache.nifi:nifi-framework-nar 1.12.1 - org.apache.nifi:nifi-system-test-suite 1.12.1 Source cves:...
org.apache.nifi:nifi-framework-nar (1.11.0), org.apache.nifi:nifi-system-test-suite (1.11.0) potentially affected by CVE-2026-54665 via org.apache.nifi:nifi-jetty (1.11.0)
org.apache.nifi:nifi-jetty MAVEN version 1.11.0 is affected by a known vulnerability. The following packages have a transitive dependency on org.apache.nifi:nifi-jetty and may be impacted: - org.apache.nifi:nifi-framework-nar 1.11.0 - org.apache.nifi:nifi-system-test-suite 1.11.0 Source cves:...
org.apache.nifi:nifi-framework-nar (1.11.4), org.apache.nifi:nifi-system-test-suite (1.11.4) potentially affected by CVE-2026-54665 via org.apache.nifi:nifi-jetty (1.11.4)
org.apache.nifi:nifi-jetty MAVEN version 1.11.4 is affected by a known vulnerability. The following packages have a transitive dependency on org.apache.nifi:nifi-jetty and may be impacted: - org.apache.nifi:nifi-framework-nar 1.11.4 - org.apache.nifi:nifi-system-test-suite 1.11.4 Source cves:...
org.apache.nifi:nifi-server-nar (1.13.1), org.apache.nifi:nifi-system-test-suite (1.13.1) potentially affected by CVE-2026-54665 via org.apache.nifi:nifi-jetty (1.13.1)
org.apache.nifi:nifi-jetty MAVEN version 1.13.1 is affected by a known vulnerability. The following packages have a transitive dependency on org.apache.nifi:nifi-jetty and may be impacted: - org.apache.nifi:nifi-server-nar 1.13.1 - org.apache.nifi:nifi-system-test-suite 1.13.1 Source cves:...