Lucene search
+L

3094 matches found

SUSE CVE
SUSE CVE
•added 2023/02/15 5:02 a.m.•15 views

SUSE CVE-2016-4431

Apache Struts 2 2.3.20 through 2.3.28.1 allows remote attackers to bypass intended access restrictions and conduct redirection attacks by leveraging a default method...

7.5CVSS7AI score0.09755EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 5:02 a.m.•19 views

SUSE CVE-2016-4433

Apache Struts 2 2.3.20 through 2.3.28.1 allows remote attackers to bypass intended access restrictions and conduct redirection attacks via a crafted request...

7.5CVSS7AI score0.09755EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 5:02 a.m.•11 views

SUSE CVE-2016-4436

Apache Struts 2 before 2.3.29 and 2.5.x before 2.5.1 allow attackers to have unspecified impact via vectors related to improper action name clean up...

9.8CVSS7.3AI score0.06603EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 5:02 a.m.•17 views

SUSE CVE-2016-4438

The REST plugin in Apache Struts 2 2.3.19 through 2.3.28.1 allows remote attackers to execute arbitrary code via a crafted expression...

9.8CVSS8AI score0.16742EPSS
SaveExploits2References3
SUSE CVE
SUSE CVE
•added 2023/02/15 5:02 a.m.•15 views

SUSE CVE-2016-4465

The URLValidator class in Apache Struts 2 2.3.20 through 2.3.28.1 and 2.5.x before 2.5.1 allows remote attackers to cause a denial of service via a null value for a URL field...

5.3CVSS6.8AI score0.10365EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 4:49 a.m.•21 views

SUSE CVE-2017-5638

The Jakarta Multipart parser in Apache Struts 2 2.3.x before 2.3.32 and 2.5.x before 2.5.10.1 has incorrect exception handling and error-message generation during file-upload attempts, which allows remote attackers to execute arbitrary commands via a crafted Content-Type, Content-Disposition, or...

10CVSS8.4AI score0.99999EPSS
SaveExploits51References7
SUSE CVE
SUSE CVE
•added 2023/02/15 4:47 a.m.•12 views

SUSE CVE-2017-7672

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12...

5.9CVSS9.2AI score0.09835EPSS
SaveExploits0References4
SUSE CVE
SUSE CVE
•added 2023/02/15 4:44 a.m.•11 views

SUSE CVE-2017-9787

When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33...

7.5CVSS7.4AI score0.10554EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 4:44 a.m.•19 views

SUSE CVE-2017-9793

The REST Plugin in Apache Struts 2.1.x, 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload...

7.5CVSS9.4AI score0.08787EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 4:44 a.m.•8 views

SUSE CVE-2017-9804

In Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12, if an application allows entering a URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. NOTE: this...

7.5CVSS9.3AI score0.08237EPSS
SaveExploits24References3
SUSE CVE
SUSE CVE
•added 2023/02/15 4:44 a.m.•19 views

SUSE CVE-2017-9805

The REST Plugin in Apache Struts 2.1.1 through 2.3.x before 2.3.34 and 2.5.x before 2.5.13 uses an XStreamHandler with an instance of XStream for deserialization without any type filtering, which can lead to Remote Code Execution when deserializing XML payloads...

8.1CVSS7.5AI score0.99396EPSS
SaveExploits24References3
SUSE CVE
SUSE CVE
•added 2023/02/15 4:41 a.m.•17 views

SUSE CVE-2017-12611

In Apache Struts 2.0.0 through 2.3.33 and 2.5 through 2.5.10.1, using an unintentional expression in a Freemarker tag instead of string literals can lead to a RCE attack...

9.8CVSS9.5AI score0.87123EPSS
SaveExploits9References3
SUSE CVE
SUSE CVE
•added 2023/02/15 4:34 a.m.•19 views

SUSE CVE-2018-1327

The Apache Struts REST Plugin is using XStream library which is vulnerable and allow perform a DoS attack when using a malicious request with specially crafted XML payload. Upgrade to the Apache Struts version 2.5.16 and switch to an optional Jackson XML handler as described here...

7.5CVSS9.4AI score0.08647EPSS
SaveExploits1References3
SUSE CVE
SUSE CVE
•added 2023/02/15 4:27 a.m.•18 views

SUSE CVE-2018-11776

Apache Struts versions 2.3 to 2.3.34 and 2.5 to 2.5.16 suffer from possible Remote Code Execution when alwaysSelectFullNamespace is true either by user or a plugin like Convention Plugin and then: results are used with no namespace and in same time, its upper package have no or wildcard namespace...

9.3CVSS8AI score0.99996EPSS
SaveExploits44References3
SUSE CVE
SUSE CVE
•added 2023/02/15 4:19 a.m.•17 views

SUSE CVE-2019-0230

Apache Struts 2.0.0 to 2.5.20 forced double OGNL evaluation, when evaluated on raw user input in tag attributes, may lead to remote code execution...

9.8CVSS8.7AI score0.96946EPSS
SaveExploits15References3
SUSE CVE
SUSE CVE
•added 2023/02/15 4:19 a.m.•7 views

SUSE CVE-2019-0233

An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload...

7.5CVSS9.5AI score0.66146EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 3:55 a.m.•17 views

SUSE CVE-2020-17530

Forced OGNL evaluation, when evaluated on raw user input in tag attributes, may lead to remote code execution. Affected software : Apache Struts 2.0.0 - Struts 2.5.25...

9.8CVSS7.8AI score0.96251EPSS
SaveExploits16References3
Tenable Nessus
Tenable Nessus
•added 2023/01/30 12:00 a.m.•55 views

Apache Struts 1.x < 1.2.9 Denial of Service (CVE-2006-1547)

The version of Apache Struts running on the remote host is 1.x prior to 1.2.9. It is, therefore, affected by a denial of service vulnerability in the ActionForm class. Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number. C...

7.8CVSS7.8AI score0.54635EPSS
SaveExploits1References1
IBM Security Bulletins
IBM Security Bulletins
•added 2022/11/18 12:11 p.m.•49 views

Security Bulletin: Vulnerabilities in Apache Struts affect IBM Tivoli Application Dependency Discovery Manager. (CVE-2021-31805)

Summary Vulnerabilities in Apache Struts affect IBM Tivoli Application Dependency Discovery Manager CVE-2021-31805 Vulnerability Details CVEID:CVE-2021-31805 DESCRIPTION: Apache Struts could allow a remote attacker to execute arbitrary code on the system, caused by a double evaluation of tag...

9.8CVSS9.5AI score0.85433EPSS
SaveExploits8Affected Software1
IBM Security Bulletins
IBM Security Bulletins
•added 2022/11/08 4:20 p.m.•81 views

Security Bulletin: IBM Security Guardium is affected by multiple vulnerabilities

Summary IBM Security Guardium has addressed the following vulnerabilities. Vulnerability Details CVEID:CVE-2021-31805 DESCRIPTION: Apache Struts could allow a remote attacker to execute arbitrary code on the system, caused by a double evaluation of tag attributes. By forcing OGNL evaluation of...

9.8CVSS7.2AI score0.85433EPSS
SaveExploits8Affected Software1
Rows per page
Query Builder