3092 matches found
CVE-2023-50164: Files or Directories Accessible to External Parties
An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution. Users are recommended to upgrade to versions Struts 2.5.33 or Struts 6.3.0.2 or greater to fix this...
Apache Struts 2.5.0 < 2.5.33 / 6.0.0 < 6.3.0.2 Remote Code Execution (S2-066)
The version of Apache Struts installed on the remote host is prior to 2.5.33 or 6.3.0.2. It is, therefore, affected by a vulnerability as referenced in the S2-066 advisory. - An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to...
CVE-2023-41835
A flaw was found in struts. When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in 'struts.multipart.saveDir', even if the request has been denied...
org.apache.struts:struts2-apps (>=6.2.0, <=6.3.0), org.apache.struts:struts2-assembly (>=6.2.0, <=6.3.0) +34 more potentially affected by CVE-2023-41835 via org.apache.struts:struts2-core (>=6.2.0, <=6.3.0)
org.apache.struts:struts2-core MAVEN version =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.3.0 and more Source cves: CVE-2023-41835 Source advisory: OSV:GHSA-729Q-FCGP-R5XH...
GHSA-729Q-FCGP-R5XH Apache Struts Improper Control of Dynamically-Managed Code Resources vulnerability
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fi...
org.apache.struts:struts2-apps (>=6.2.0, <=6.3.0), org.apache.struts:struts2-assembly (>=6.2.0, <=6.3.0) +34 more potentially affected by CVE-2023-41835 via org.apache.struts:struts2-core (>=6.2.0, <=6.3.0)
org.apache.struts:struts2-core MAVEN version =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.3.0 and more Source cves: CVE-2023-41835 Source advisory: GHSA-729Q-FCGP-R5XH...
Apache Struts Improper Control of Dynamically-Managed Code Resources vulnerability
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fi...
CVE-2023-41835
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which...
CVE-2023-41835
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which...
Design/Logic Flaw
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which...
CVE-2023-41835 Apache Struts: excessive disk usage
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which...
CVE-2023-41835
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which...
CVE-2023-41835 Apache Struts: excessive disk usage
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which...
com.amazonaws.serverless:aws-serverless-java-container-struts (>=1.9, <=1.9.3), com.jgeppert.struts2.bootstrap:struts2-bootstrap-plugin (>=5.0.0, <=5.0.2) +50 more potentially affected by CVE-2023-41835 via org.apache.struts:struts2-core (>=6.0.0, <=6.1.2.1)
org.apache.struts:struts2-core MAVEN version =6.0.0, =1.9, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =1.4.0, =1.4.1, =1.4.0, =1.4.3 and more Source cves: CVE-2023-41835 Source advisory: MEND:CVE-20...
CVE-2023-41835 Apache Struts: excessive disk usage
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which...
org.apache.struts:struts2-apps (>=6.2.0, <=6.3.0), org.apache.struts:struts2-assembly (>=6.2.0, <=6.3.0) +34 more potentially affected by CVE-2023-41835 via org.apache.struts:struts2-core (>=6.2.0, <=6.3.0)
org.apache.struts:struts2-core MAVEN version =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.2.0, =6.3.0 and more Source cves: CVE-2023-41835 Source advisory: MEND:CVE-2023-41835...
CVE-2023-41835: Incomplete Cleanup
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which...
Apache Struts Security Vulnerabilities
Apache Struts is the United States Apache Apache Foundation of an open source project , is a set of open source MVC framework for creating enterprise-class Java Web applications , mainly provides two versions of the framework product , Struts 1 and Struts 2. Apache Struts has a security...
PT-2023-7502
Name of the Vulnerable Software and Affected Versions Apache Struts versions 2.0.0 through 2.5.32 Apache Struts versions 6.0.0 through 6.3.0.1 Description A critical vulnerability has been identified in Apache Struts, allowing attackers to manipulate file upload parameters and enable path...
ai.databand.azkaban:azkaban-web-server (3.18.0), at.ganzleicht.vaadin:vaadin-maven-plugin (>=9.1.1, <=9.1.3.2) +1031 more potentially affected by CVE-2023-49735 via org.apache.struts:struts-tiles (>=1.3.5, <=1.3.10)
org.apache.struts:struts-tiles MAVEN version =1.3.5, =9.1.1, =0.1, =2.1-beta1, =1.2.1, =1.0.0, =0.0.1.alpha, =0.0.1.alpha, =1.2.28, =1.0.0, =1.0.0, =1.0, =1.0, =1.0.1 and more Source cves: CVE-2023-49735 Source advisory: GHSA-QW4H-3XJJ-84CC...