101559 matches found
PT-2026-116803
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 7.2-rc6 Description A stack information leak exists in the em text dump function. The function allocates a struct tcf em text on the stack without zeroing it. While strscpy writes the algorithm name and a NUL...
PT-2026-116747
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description A kernel stack leak occurs in the error path of the GPIO character device. When the system fails to acquire the GPIO chip guard within the gpio desc to lineinfo function, it returns...
Linux Kernel Security Vulnerabilities
The Linux kernel version 7.1 contains a security vulnerability. This vulnerability arises from fprobefgraphentry, which does not clear uninitialized reserved shadow stack spaces. As a result, fprobereturn misinterprets unused tail sections as previously called headers, potentially causing exit...
Linux Kernel Security Vulnerabilities
The Linux kernel versions from 6.11.7 to 6.12 and version 6.12 contain security vulnerabilities. These vulnerabilities arise when the TPM empty key name does not match, resulting in the chip not being disabled and a success return being given. This allows uninitialized stack values to be used as...
Lode Vandevenne has a buffer error vulnerability
Lode Vandevenne’s lodepng 20261006 and earlier versions have a buffer error vulnerability. This vulnerability stems from the lodepng::getFilterTypesInterlaced function in lodepngutil.cpp, which fails to perform boundary checks on the decompressed IDAT data. As a result, a stack overflow attack is...
Linux Kernel Security Vulnerabilities
The Linux kernel version 6.9 contains security vulnerabilities. These vulnerabilities stem from the gpiodesctolineinfo function, which returns early when attempting to retrieve GPIO chip protection information, and does not clear the info structure. This may lead to the leakage of kernel stack...
Linux Kernel Security Vulnerabilities
The Linux kernel version 6.17 contains security vulnerabilities. These vulnerabilities stem from the fact that emtextdump does not zero the stack when allocating a struct tcfemtext; the strscpy function writes the algorithm name and NUL terminator, but the remaining bytes are not initialized...
Strophe/Libstrophe buffer error vulnerability
Strophe libstrophe versions 0.14.0 and earlier have a buffer overflow vulnerability. This vulnerability stems from SCRAMHi’s handling of SCRAM salts, where a stack buffer overflow occurs when processing SCRAM salts. Malicious XMPP servers can exploit this vulnerability by sending SCRAM salts that...
lwIP Developers: lwIP buffer error vulnerability
lwIP Developers: Versions of lwIP 2.2.1 and earlier contain a buffer overflow vulnerability. This vulnerability stems from the mdnshandleresponse function, which allows stack-based out-of-bounds writes. Attackers can exploit this vulnerability by sending mDNS responses with invalid domain names...
Linux Kernel Security Vulnerabilities
The Linux kernel version 6.18 contains security vulnerabilities. These vulnerabilities stem from the fact that in the function cd321xupdatework, the variable typecpartnerdesc is not initialized to zero. Only the variables usbpd, accessory, and identity are initialized. As a result, fields such as...
Grigory Chudov: A bug related to numerical errors
Grigory Chudov’s libtta versions 2.3 and earlier have a numerical error vulnerability. This vulnerability stems from the ttadecoderinitgetinfo function not verifying header fields properly. Integer overflow leads to a stack buffer overflow in 32-bit builds. Attackers can exploit this vulnerabilit...
Grigory Chudov’s buffer error vulnerability
Grigory Chudov’s libtta versions 2.3 and earlier have a buffer error vulnerability. This vulnerability arises from the lack of header checks that reject zero audio channels. An attacker can create a specially crafted .tta file that declares zero audio channels, causing the application to access...
Linux Kernel Security Vulnerabilities
The Linux kernel version 6.4 contains a security vulnerability. This vulnerability arises from the fact that the stackslotobjgetspi function does not reject non-negative offsets. When the offset is 0, the calculated spi index is the same as the valid stack slot at fp-8. This may lead to...
AbiWord wv buffer error vulnerability
AbiWord versions 1.2.9 and earlier have a buffer error vulnerability. This vulnerability stems from the lack of verification of the FKP run count in functions wvGetPAPXFKP and wvGetCHPXFKP. Attackers can read content that exceeds the 512-byte stack buffer by providing a specially crafted.doc file...
Linux Kernel Security Vulnerabilities
The Linux kernel version 6.12 contains security vulnerabilities. These vulnerabilities stem from insufficient depth restrictions on the ownership relationship between BPF and local kptrs and Goto statements. The self-referencing local kptr types can form arbitrarily deep object chains, and the sa...
SUSE CVE-2026-93164
In the Linux kernel, the following vulnerability has been resolved: uprobes/x86: Move optimized uprobe from nop5 to nop10 Andrii reported an issue with optimized uprobes 1 that can clobber redzone area with call instruction storing return address on stack where user code may keep temporary data...
Exploit for CVE-2026-99999
cve-2026-99999-audit !CVEhttps://img.shields.io/badge/CVE-...
MGASA-2026-0515 Updated curl package fixes security vulnerabilities
curl 8.23.0 has been released. It fixes 24 CVEs since 8.22.0, listed at https://curl.se/docs/security.html Not all of theses CVEs affect Mageia. Of the ones fixed in 8.23.0, these are the ones that do: CVE-2026-86410: redirect to SFTP or SCP bypasses host verification CVE-2026-86412: server-set...
MGASA-2026-0518 Updated nodejs-braces package fixes a security vulnerability
It was discovered that braces through 3.0.3 contains a stack overflow vulnerability in the recursive AST walkers that lack depth guards CVE-2026-93687...
Updated nodejs-braces package fixes a security vulnerability
It was discovered that braces through 3.0.3 contains a stack overflow vulnerability in the recursive AST walkers that lack depth guards CVE-2026-93687...