739 matches found
VulnCheck KEV: CVE-2022-22963
In Spring Cloud Function versions 3.1.6, 3.2.2 and older unsupported versions, when using routing functionality it is possible for a user to provide a specially crafted SpEL as a routing-expression that may result in remote code execution and access to local resources...
Expression Language Injection
Expression Language EL has been defined as part of the Java Server Pages Standard Tag Library JSTL in order to offer developers a simple way to output data from an object model. Starting from the JSP 2.0 specification, Expression Language has been made available within JSP pages, but it is also...
spring-expression: Denial of service via specially crafted SpEL expression
A flaw was found in the Spring Framework. This flaw allows an attacker to craft a special Spring Expression, causing a denial of service...
spring-expression: Denial of service via specially crafted SpEL expression
A flaw was found in the Spring Framework. This flaw allows an attacker to craft a special Spring Expression, causing a denial of service...
Moderate: Red Hat Security Advisory: RHV Manager (ovirt-engine) [ovirt-4.5.1] security, bug fix and update
Updated ovirt-engine packages that fix several bugs and add various enhancements are now available. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available f...
Exploit for Expression Language Injection in Vmware Spring_Data_Mongodb
Springcve-2022-22980 spring data mongodb remote code executio...
spring-expression: Denial of service via specially crafted SpEL expression
A flaw was found in the Spring Framework. This flaw allows an attacker to craft a special Spring Expression, causing a denial of service...
Important: Red Hat Security Advisory: Red Hat Fuse 7.11.0 release and security update
A minor version update from 7.10 to 7.11 is now available for Red Hat Fuse. The purpose of this text-only errata is to inform you about the security issues fixed in this release. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scorin...
GHSA-W24X-87MR-4R23 SpEL Injection in Spring Data MongoDB
A Spring Data MongoDB application is vulnerable to SpEL Injection when using @Query or @Aggregation-annotated query methods with SpEL expressions that contain query parameter placeholders for value binding if the input is not sanitized...
CVE-2022-22980
A Spring Data MongoDB application is vulnerable to SpEL Injection when using @Query or @Aggregation-annotated query methods with SpEL expressions that contain query parameter placeholders for value binding if the input is not sanitized...
Spring Data MongoDB security vulnerabilities
Spring Framework is the U.S. Spring team of a set of open source Java, JavaEE application framework. The framework helps developers build high-quality applications. A security vulnerability exists in Spring Data MongoDB that stems from vulnerability to SpEL injection when using @Query or...
Denial Of Service (DoS)
Spring Expression is vulnerable to denial of service. The vulnerability exists due to the creation of large array in a SpEL and sending meaningless error messages to the user which allows an attacker to send crafted SpEL expressions that leads to an out ouf bound error causing an application cras...
BSA-2022-1768
Security Advisory ID : BSA-2022-1768 Component : Spring Cloud Revision : 1.0 In Spring Cloud Function versions 3.1.6, 3.2.2 and older unsupported versions, when using routing functionality it is possible for a user to provide a specially crafted SpEL as a routing-expression that may result in...
ai.foremast.metrics:foremast-spring-boot-15x-starter (>=0.1.10, <=0.1.12), ai.houyi:dorado (>=0.0.6, <=0.0.8) +1474 more potentially affected by CVE-2022-22950 via org.springframework:spring-expression (4.3.18.release)
org.springframework:spring-expression MAVEN version 4.3.18.release is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-expression and may be impacted: - ai.foremast.metrics:foremast-spring-boot-15x-starter =0.1.10, =0.0.6, =0.0.1...
at.molindo.social:spring-social-config (1.1.0.release), at.molindo.social:spring-social-core (1.1.0.release) +310 more potentially affected by CVE-2022-22950 via org.springframework:spring-expression (4.0.3.release)
org.springframework:spring-expression MAVEN version 4.0.3.release is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-expression and may be impacted: - at.molindo.social:spring-social-config 1.1.0.release -...
at.molindo.social:spring-social-config (1.1.4.release), at.molindo.social:spring-social-core (1.1.4.release) +431 more potentially affected by CVE-2022-22950 via org.springframework:spring-expression (4.1.8.release)
org.springframework:spring-expression MAVEN version 4.1.8.release is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-expression and may be impacted: - at.molindo.social:spring-social-config 1.1.4.release -...
cn.deepbit:deepbit-sdk (8.3.7), cn.deepbit:deepbit-start-mvc (8.3.7) +501 more potentially affected by CVE-2022-22950 via org.springframework:spring-expression (4.3.23.release)
org.springframework:spring-expression MAVEN version 4.3.23.release is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-expression and may be impacted: - cn.deepbit:deepbit-sdk 8.3.7 - cn.deepbit:deepbit-start-mvc 8.3.7 -...
com.bytebybyte:google-geocoding (>=3.0.0, <=3.0.1), com.bytebybyte:mapquest-open-geocoding (1.0.0) +260 more potentially affected by CVE-2022-22950 via org.springframework:spring-expression (4.0.7.release)
org.springframework:spring-expression MAVEN version 4.0.7.release is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-expression and may be impacted: - com.bytebybyte:google-geocoding =3.0.0, =3.0.1 -...
br.ufc.quixada.npi:npi-core-api (0.1.0), ch.ralscha:extdirectspring (1.5.1) +539 more potentially affected by CVE-2022-22950 via org.springframework:spring-expression (4.1.4.release)
org.springframework:spring-expression MAVEN version 4.1.4.release is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-expression and may be impacted: - br.ufc.quixada.npi:npi-core-api 0.1.0 - ch.ralscha:extdirectspring 1.5.1 -...
be.eliwan:ew-profiling-api (>=1.0, <=1.4), be.eliwan:ew-profiling-core (>=1.0, <=1.4) +1251 more potentially affected by CVE-2022-22950 via org.springframework:spring-expression (3.0.5.release)
org.springframework:spring-expression MAVEN version 3.0.5.release is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-expression and may be impacted: - be.eliwan:ew-profiling-api =1.0, =1.0, =2.0-beta1, =1.1.1, =1.0.2, =1.1.2,...