12720 matches found
Arbitrary memory address read vulnerability with Regex search
If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. We recommend to update the Ruby to version 3.3.1 or later. In order to ensure compatibility with older Ruby...
CVE-2024-32039 FreeRDP Integer overflow & OutOfBound Write in clear_decompress_residual_data
FreeRDP is a free implementation of the Remote Desktop Protocol. FreeRDP based clients using a version of FreeRDP prior to 3.5.0 or 2.11.6 are vulnerable to integer overflow and out-of-bounds write. Versions 3.5.0 and 2.11.6 patch the issue. As a workaround, do not use /gfx options e.g. deactivat...
SUSE-SU-2024:1376-1 Security update for polkit
This update for polkit fixes the following issues: - Change permissions for rules folders bsc1209282...
Armeria-saml improperly handles SAML messages
Overview Armeria-saml provided by LY Corporation contains an issue in handling SAML messages CWE-304, CVE-2024-1735. LY Corporation reported this vulnerability to JPCERT/CC to notify users of its solution through JVN. Impact Authentication may be bypassed by receiving a specially crafted SAML...
PT-2024-24604 · Librenms · Librenms
Name of the Vulnerable Software and Affected Versions: LibreNMS versions prior to 24.4.0 Description: The issue is related to a SQL injection vulnerability. The order parameter, obtained from $request, is directly incorporated into an SQL statement after a string check, resulting in the...
DLA-3791-1 thunderbird - security update
Bulletin has no description...
MGASA-2024-0140 Updated putty & filezilla packages fix security vulnerability
The PuTTY client and all related components generate heavily biased ECDSA nonces in the case of NIST P-521. To be more precise, the first 9 bits of each ECDSA nonce are zero. This allows for full secret key recovery in roughly 60 signatures by using state-of-the-art techniques. These signatures c...
BIT-ENVOY-2024-32475 Envoy RELEASE_ASSERT using auto_sni with :authority header > 255 bytes
Envoy is a cloud-native, open source edge and service proxy. When an upstream TLS cluster is used with autosni enabled, a request containing a host/:authority header longer than 255 characters triggers an abnormal termination of Envoy process. Envoy does not gracefully handle an error when settin...
SUSE-SU-2024:1351-1 Security update for graphviz
This update for graphviz fixes the following issues: - CVE-2023-46045: Fixed out-of-bounds read via a crafted config6a file bsc1219491...
DLA-3788-1 tzdata - new timezone database
Bulletin has no description...
Add Custom CSS and JS <= 1.20 - Stored XSS via CSRF
Description The plugin does not have CSRF check in some places, and is missing sanitisation as well as escaping, which could allow attackers to make logged in as author and above add Stored XSS payloads via a CSRF attack PoC Make an author or above role open the following HTML:...
ALSA-2024:1818 Moderate: java-1.8.0-openjdk security update
The java-1.8.0-openjdk packages provide the OpenJDK 8 Java Runtime Environment and the OpenJDK 8 Java Software Development Kit. Security Fixes: OpenJDK: long Exception message leading to crash 8319851 CVE-2024-21011 OpenJDK: integer overflow in C1 compiler address generation 8322122 CVE-2024-2106...
CVE-2024-26894 ACPI: processor_idle: Fix memory leak in acpi_processor_power_exit()
In the Linux kernel, the following vulnerability has been resolved: ACPI: processoridle: Fix memory leak in acpiprocessorpowerexit After unregistering the CPU idle device, the memory associated with it is not freed, leading to a memory leak: unreferenced object 0xffff896282f6c000 size 1024: comm...
GHSA-G7XQ-XV8C-H98C Cross-site Scripting (XSS) possible due to improper sanitisation of `href` attributes on `<a>` tags
Summary There is a potential cross-site scripting XSS vulnerability that can be exploited via maliciously crafted user data. Our filter to detect and prevent the use of the javascript: URL scheme in the href attribute of an tag could be bypassed with tab \t or newline \n characters between the...
Important: emacs
Issue Overview: In Emacs before 29.3, arbitrary Lisp code is evaluated as part of turning on Org mode. This affects Org Mode before 9.6.23. CVE-2024-30202 Affected Packages: emacs Issue Correction: Run dnf update emacs --releasever 2023.4.20240416 to update your system. New Packages: aarch64: ...
PT-2024-3086 · Google +6 · Google Chrome +6
Name of the Vulnerable Software and Affected Versions: Google Chrome versions prior to 124.0.6367.60 Microsoft Edge affected versions not specified Description: The issue is related to an inappropriate implementation in the Autofill feature, allowing an attacker to perform UI spoofing via a craft...
A new tool bar has appearred since Citrix Workspace App for ChromeOS 2402.
A new tool bar has appearred after upgrading to Citrix Workspace App for ChromeOS 2402. Prior to 2402, the old old tool bar was displayed...
DSA-5655-2 cockpit - regression update
Bulletin has no description...
PT-2024-3194 · Mysql Server · Mysql Connectors
Name of the Vulnerable Software and Affected Versions: MySQL Connectors versions 8.3.0 and prior Description: The issue is related to insufficient input validation in the Connector/Python component of MySQL Connectors, allowing an unauthenticated attacker with network access via multiple protocol...
PT-2024-3077 · Google +5 · Google Chrome +5
Name of the Vulnerable Software and Affected Versions: Google Chrome versions prior to 124.0.6367.60 Description: The issue is related to insufficient data validation in the Browser Switcher component, which can be exploited by a remote attacker to inject scripts or HTML into a privileged page vi...