46 matches found
CVE-2015-5531: Improper Limitation of a Pathname to a Restricted Directory
Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls...
PT-2015-6976
Name of the Vulnerable Software and Affected Versions Elasticsearch versions prior to 1.6.1 Description The issue allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls. This affects Elasticsearch, enabling attackers to access files they should not...
FreeBSD : elasticsearch -- directory traversal attack via snapshot API (ae8c09cb-32da-11e5-a4a5-002590263bf5)
Elastic reports : Vulnerability Summary: Elasticsearch versions from 1.0.0 to 1.6.0 are vulnerable to a directory traversal attack. Remediation Summary: Users should upgrade to 1.6.1 or later, or constrain access to the snapshot API to trusted sources. %NASLMINLEVEL 70300 C Tenable Network...
elasticsearch -- directory traversal attack via snapshot API
Elastic reports: Vulnerability Summary: Elasticsearch versions from 1.0.0 to 1.6.0 are vulnerable to a directory traversal attack. Remediation Summary: Users should upgrade to 1.6.1 or later, or constrain access to the snapshot API to trusted sources...
Elasticsearch vulnerability CVE-2015-4165
Summary: Elasticsearch versions 1.0.0 - 1.5.2 are vulnerable to an engineered attack on other applications on the system. The snapshot API may be used indirectly to place snapshot metadata files into locations that are writeable by the user running the Elasticsearch process. It is possible to...