253 matches found
@strapi/upgrade (>=0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, <=0.0.0-next.5613eaed044dde893bdffc7c01a9e38754f363eb), ag-toolkit (0.7.0) +2 more potentially affected by CVE-2026-102829 via @simple-git/argv-parser (2.0.0)
@simple-git/argv-parser NPM version 2.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on @simple-git/argv-parser and may be impacted: - @strapi/upgrade =0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, =4.0.0, =4.0.1 Source cves:...
@strapi/upgrade (>=0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, <=0.0.0-next.5613eaed044dde893bdffc7c01a9e38754f363eb), ag-toolkit (0.7.0) +2 more potentially affected by CVE-2026-102829 via @simple-git/argv-parser (2.0.0)
@simple-git/argv-parser NPM version 2.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on @simple-git/argv-parser and may be impacted: - @strapi/upgrade =0.0.0-experimental.152d909f212548df3933e5c99e8e1500315a6eb3, =4.0.0, =4.0.1 Source cves:...
GHSA-V5RQ-49VH-5V5C simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection
Security control bypass in @simple-git/argv-parser: Git's VISUAL editor fallback is not classified as allowUnsafeEditor Report metadata | Field | Value | | --- | --- | | Package | @simple-git/argv-parser npm, pkg:npm/%40simple-git/argv-parser | | Repository | https://github.com/steveukx/git-js | ...
simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection
Security control bypass in @simple-git/argv-parser: Git's VISUAL editor fallback is not classified as allowUnsafeEditor Report metadata | Field | Value | | --- | --- | | Package | @simple-git/argv-parser npm, pkg:npm/%40simple-git/argv-parser | | Repository | https://github.com/steveukx/git-js | ...
EUVD-2026-89336
simple-git: VISUAL editor environment variable is omitted from unsafe editor detection...
EUVD-2026-89334
simple-git unsafe-operation guard does not block trailer command configuration...
NPM: simple-git unsafe-operation guard does not block trailer command configuration
NPM: simple-git unsafe-operation guard does not block trailer command configuration vulnerability discovered by ? in WordPress Npm simple-git versions = 3.15.0, 4.0.1...
GHSA-X6JW-M9V5-85VH simple-git unsafe-operation guard does not block trailer command configuration
Affected product The default blockUnsafeOperationsPlugin in simple-git when an application permits untrusted values to reach SimpleGitOptions.config or Git inline configuration arguments such as -c =. Summary trailer..cmd is not recognized as unsafe by the default guard. Therefore, a configured...
simple-git unsafe-operation guard does not block trailer command configuration
Affected product The default blockUnsafeOperationsPlugin in simple-git when an application permits untrusted values to reach SimpleGitOptions.config or Git inline configuration arguments such as -c =. Summary trailer..cmd is not recognized as unsafe by the default guard. Therefore, a configured...
2context (>=0.1.0, <=0.2.0), 3extensions (1.0.1) +8463 more potentially affected by CVE-2026-102828 via simple-git (>=3.15.0, <=3.36.0)
simple-git NPM version =3.15.0, =0.1.0, =0.16.0, =0.0.112-rc1, =1.0.0-beta.1, =1.0.0, =0.0.2, =1.0.0, =1.0.0, =1.25.0, =2.0.0, =1.0.3, =1.1.0, =0.1.0, =0.1.0, =0.2.0 and more Source cves: CVE-2026-102828 Source advisory: GHSA-X6JW-M9V5-85VH...
2context (>=0.1.0, <=0.2.0), 3extensions (1.0.1) +8463 more potentially affected by CVE-2026-102828 via simple-git (>=3.15.0, <=3.36.0)
simple-git NPM version =3.15.0, =0.1.0, =0.16.0, =0.0.112-rc1, =1.0.0-beta.1, =1.0.0, =0.0.2, =1.0.0, =1.0.0, =1.25.0, =2.0.0, =1.0.3, =1.1.0, =0.1.0, =0.1.0, =0.2.0 and more Source cves: CVE-2026-102828 Source advisory: OSV:GHSA-X6JW-M9V5-85VH...
2context (>=0.1.0, <=0.2.0), 3extensions (1.0.1) +8570 more potentially affected by CVE-2026-102826 via simple-git (>=3.0.3, <=3.36.0)
simple-git NPM version =3.0.3, =0.1.0, =0.16.0, =0.0.112-rc1, =1.0.0-beta.1, =1.0.0, =0.0.2, =1.0.0, =1.0.0, =1.25.0, =2.0.0, =1.0.3, =1.1.0, =0.1.0, =0.1.0, =0.2.0 and more Source cves: CVE-2026-102826 Source advisory: GHSA-G4WM-2VF7-VFGR...
GHSA-G4WM-2VF7-VFGR simple-git allows command execution through unblocked Git configuration includes
Summary An OS command injection vulnerability in git.clone allows any application that flows attacker-influenced data into customArgs to execute arbitrary code. simple-git 3.36.0 current latest on npm ships without any include.path entry in the blockUnsafeOperationsPlugin denylist. Passing -c...
EUVD-2026-89332
simple-git allows command execution through unblocked Git configuration includes...
simple-git allows command execution through unblocked Git configuration includes
Summary An OS command injection vulnerability in git.clone allows any application that flows attacker-influenced data into customArgs to execute arbitrary code. simple-git 3.36.0 current latest on npm ships without any include.path entry in the blockUnsafeOperationsPlugin denylist. Passing -c...
NPM: simple-git allows command execution through unblocked Git configuration includes
NPM: simple-git allows command execution through unblocked Git configuration includes vulnerability discovered by ? in WordPress Npm simple-git versions = 3.36.0...
NPM: simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291)
NPM: simple-git: unsafe-operations plugin bypass via git long-option abbreviation --receive-p/--exe - command execution residual of CVE-2026-28291 vulnerability discovered by ? in WordPress Npm simple-git versions = 3.36.0...
simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291)
simple-git's blockUnsafeOperationsPlugin blocks dangerous git options --upload-pack/--receive-pack/--exec/... unless the consumer opts in via unsafe:allowUnsafePack:true. Detection @simple-git/argv-parser detectVulnerableFlags matches the parsed flag NAME against literal-spelling patterns:...
GHSA-858H-WHJF-MVG5 simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291)
simple-git's blockUnsafeOperationsPlugin blocks dangerous git options --upload-pack/--receive-pack/--exec/... unless the consumer opts in via unsafe:allowUnsafePack:true. Detection @simple-git/argv-parser detectVulnerableFlags matches the parsed flag NAME against literal-spelling patterns:...
2context (>=0.1.0, <=0.2.0), 3extensions (1.0.1) +8570 more potentially affected by CVE-2026-102827 +1 more via simple-git (>=3.0.3, <=3.36.0)
simple-git NPM version =3.0.3, =0.1.0, =0.16.0, =0.0.112-rc1, =1.0.0-beta.1, =1.0.0, =0.0.2, =1.0.0, =1.0.0, =1.25.0, =2.0.0, =1.0.3, =1.1.0, =0.1.0, =0.1.0, =0.2.0 and more Source cves: CVE-2026-102827, CVE-2026-28291 Source advisory: GHSA-858H-WHJF-MVG5...