2929 matches found
RHEL 8 : python3.11-setuptools (RHSA-2024:5002)
The remote Redhat Enterprise Linux 8 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2024:5002 advisory. Setuptools is a collection of enhancements to the Python 3 distutils that allow you to more easily build and distribute Python 3 packages, especially...
RHEL 8 : python-setuptools (RHSA-2024:5000)
The remote Redhat Enterprise Linux 8 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2024:5000 advisory. The python-setuptools package provides a collection of enhancements to Python distribution utilities allowing convenient building and distribution of...
BIT-SETUPTOOLS-2024-6345 Remote Code Execution in pypa/setuptools
A vulnerability in the packageindex module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code...
OESA-2024-1931 python-setuptools security update
Setuptools is a collection of enhancements to the Python distutils that allow you to more easily build and distribute Python packages, especially ones that have dependencies on other packages. Security Fixes: A vulnerability in the packageindex module of pypa/setuptools versions up to 69.1.1 allo...
CentOS 9 : python-setuptools-53.0.0-13.el9
The remote CentOS Linux 9 host has packages installed that are affected by a vulnerability as referenced in the python- setuptools-53.0.0-13.el9 build changelog. - A vulnerability in the packageindex module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download...
setuptools package_index Command Execution
The vulnerability of the packageindex module in the setuptools packaging library relates to the use of functions that are used to download packages from URLs provided by users or obtained from package index servers. This code can be exploited. Exploiting this vulnerability allows a malicious acto...
ROS-20240729-22
A vulnerability in the packageindex module of the library designed to simplify the packaging of setuptools projects is related to functions used to download packages from URLs, provided by users or obtained from package index servers, are susceptible to code injection. Exploitation of the...
Important Photon OS Security Update - PHSA-2024-5.0-0332
Updates of 'python3-setuptools', 'shim-signed' packages of Photon OS have been released...
Important Photon OS Security Update - PHSA-2024-5.0-91-0332
Updates of 'shim-signed', 'python3-setuptools' packages of Photon OS have been released...
Important Photon OS Security Update - PHSA-2024-4.0-0660
Updates of 'python3-setuptools' packages of Photon OS have been released...
Amazon Linux 2023 : python3.11-setuptools, python3.11-setuptools-wheel (ALAS2023-2024-653)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2024-653 advisory. A Denial of Service DoS vulnerability exists in the jaraco/zipp library, affecting all versions prior to 3.19.1. The vulnerability is triggered when processing a specially crafted zip file that leads to...
SUSE CVE-2024-6345
A vulnerability in the packageindex module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code...
Code Injection
setuptools is vulnerable to Code Injection. The vulnerability is due to the packageindex module's download function, which can execute arbitrary OS commands when exposed to user-controlled inputs such as package URLs...
CVE-2024-6345
A flaw was found in the packageindex module of pypa/setuptools. Affected versions of this package allow remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to co...
aaiopay (>=0.2.1, <=0.2.2), absorb (0.1.2) +146 more potentially affected by CVE-2024-6345 via setuptools (65.5.1)
setuptools PYPI version 65.5.1 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - aaiopay =0.2.1, =0.1.0, =1.8.15, =1.8.17, =0.0.8, =1.8.14, =1.0.6a1, =0.0.1, =3.0.0, =0.1.2, =0.2.0, =0.2.1 and more Source cves:...
backlog (2.0.2), butterfree (>=1.2.0.dev3, <=1.2.1) +21 more potentially affected by CVE-2024-6345 via setuptools (41.6.0)
setuptools PYPI version 41.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - backlog 2.0.2 - butterfree =1.2.0.dev3, =0.1.0, =0.4.1, =0.1.0, =0.1.2, =0.0.2b1, =0.1.8, =0.1.7, =0.1.15 and more Source cves: CVE-2024-63...
bandersnatch (>=3.0.0, <=3.0.1), bert-multitask-client (>=0.1.0, <=0.1.1) +1 more potentially affected by CVE-2024-6345 via setuptools (40.5.0)
setuptools PYPI version 40.5.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - bandersnatch =3.0.0, =0.1.0, =0.1.1 - pygrest 1.0.1 Source cves: CVE-2024-6345 Source advisory: OSV:GHSA-CX63-2MW6-8HW5...
cvexplore (>=0.2.6.0, <=0.2.6.1), meloetta (1.1.0) +4 more potentially affected by CVE-2024-6345 via setuptools (58.0.0)
setuptools PYPI version 58.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - cvexplore =0.2.6.0, =0.0.1, =0.3.1, =1.3.0, =1.6.0 Source cves: CVE-2024-6345 Source advisory: OSV:GHSA-CX63-2MW6-8HW5...
aioimdb (>=1.0.5, <=1.1.2), auto-dl (0.1.1) +11 more potentially affected by CVE-2024-6345 via setuptools (39.0.1)
setuptools PYPI version 39.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - aioimdb =1.0.5, =0.2.0b0, =1.1.0, =0.2.1, =0.0.2, =1.1.0rc0, =0.1.3, =0.2.6.1 Source cves: CVE-2024-6345 Source advisory:...
batcave (37.0.0), batspp (>=2.0.1, <=2.1.2) +25 more potentially affected by CVE-2024-6345 via setuptools (41.2.0)
setuptools PYPI version 41.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - batcave 37.0.0 - batspp =2.0.1, =0.1.5, =0.1.4, =2021.9.1, =0.2.0, =0.0.1, =1.0.8, =1.0.0, =1.0.0, =1.0.2 - gendeblur 0.0.1 - lunas 0.3.7 -...