2953 matches found
SUSE-SU-2025:01704-1 Security update for python-setuptools
This update for python-setuptools fixes the following issues: - CVE-2025-47273: path traversal in PackageIndex.download may lead to an arbitrary file write bsc1243313...
SUSE: Security Advisory (SUSE-SU-2025:01695-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2025 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
SUSE: Security Advisory (SUSE-SU-2025:01693-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2025 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
SUSE SLES12 Security Update : python-setuptools (SUSE-SU-2025:01695-1)
The remote SUSE Linux SLES12 / SLESSAP12 host has packages installed that are affected by a vulnerability as referenced in the SUSE-SU-2025:01695-1 advisory. - CVE-2025-47273: path traversal in PackageIndex.download may lead to an arbitrary file write bsc1243313. Tenable has extracted the precedi...
SUSE SLES12 Security Update : python36-setuptools (SUSE-SU-2025:01693-1)
The remote SUSE Linux SLES12 host has a package installed that is affected by a vulnerability as referenced in the SUSE- SU-2025:01693-1 advisory. - CVE-2025-47273: path traversal in PackageIndex.download may lead to an arbitrary file write bsc1243313. Tenable has extracted the preceding...
SUSE-SU-2025:01695-1 Security update for python-setuptools
This update for python-setuptools fixes the following issues: - CVE-2025-47273: path traversal in PackageIndex.download may lead to an arbitrary file write bsc1243313...
Security update for python36-setuptools
This update for python36-setuptools fixes the following issues: CVE-2025-47273: path traversal in PackageIndex.download may lead to an arbitrary file write bsc1243313. Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST onlineupdate or "zypper...
SUSE-SU-2025:01693-1 Security update for python36-setuptools
This update for python36-setuptools fixes the following issues: - CVE-2025-47273: path traversal in PackageIndex.download may lead to an arbitrary file write bsc1243313...
SUSE CVE-2025-47273
setuptools is a package that allows users to download, build, install, upgrade, and uninstall Python packages. A path traversal vulnerability in PackageIndex is present in setuptools prior to version 78.1.1. An attacker would be allowed to write files to arbitrary locations on the filesystem with...
setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File Write
Summary A path traversal vulnerability in PackageIndex was fixed in setuptools version 78.1.1 Details def downloadurlself, url, tmpdir: Determine download filename name, fragment = egginfoforurlurl if name: while '..' in name: name = name.replace'..', '.'.replace'\', '' else: name = "downloaded"...
an-website (>=22.7.23, <=22.8.3), aws-toolbox (0.0.2) +10 more potentially affected by CVE-2025-47273 via setuptools (63.2.0)
setuptools PYPI version 63.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - an-website =22.7.23, =4.0.0, =1.0.6, =1.0.1, =0.13.0, =0.0.3, =0.0.4 - vpc-img-inst 1.0.0b7 Source cves: CVE-2025-47273 Source advisory:...
GHSA-5RJG-FVGR-3XXF setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File Write
Summary A path traversal vulnerability in PackageIndex was fixed in setuptools version 78.1.1 Details def downloadurlself, url, tmpdir: Determine download filename name, fragment = egginfoforurlurl if name: while '..' in name: name = name.replace'..', '.'.replace'\', '' else: name = "downloaded"...
pex (>=0.8.2, <=0.8.6) potentially affected by CVE-2025-47273 via setuptools (7.0.0)
setuptools PYPI version 7.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - pex =0.8.2, =0.8.6 Source cves: CVE-2025-47273 Source advisory: OSV:GHSA-5RJG-FVGR-3XXF...
pex (>=0.9.0, <=1.1.1), revscoring (>=0.6.4, <=2.0.4) +3 more potentially affected by CVE-2025-47273 via setuptools (15.2.0)
setuptools PYPI version 15.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - pex =0.9.0, =0.6.4, =1.4.1, =0.3.0, =0.3.2 - yt-formula-node 0.0.4 Source cves: CVE-2025-47273 Source advisory: OSV:GHSA-5RJG-FVGR-3XXF...
planadversity (1.0.2), uranium (>=0.2.10, <=0.2.22) potentially affected by CVE-2025-47273 via setuptools (18.0.1)
setuptools PYPI version 18.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - planadversity 1.0.2 - uranium =0.2.10, =0.2.22 Source cves: CVE-2025-47273 Source advisory: OSV:GHSA-5RJG-FVGR-3XXF...
uranium (>=0.2.23, <=0.2.34) potentially affected by CVE-2025-47273 via setuptools (18.2.0)
setuptools PYPI version 18.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - uranium =0.2.23, =0.2.34 Source cves: CVE-2025-47273 Source advisory: OSV:GHSA-5RJG-FVGR-3XXF...
python-mu (>=1.0.1, <=1.0.3) potentially affected by CVE-2025-47273 via setuptools (18.4.0)
setuptools PYPI version 18.4.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - python-mu =1.0.1, =1.0.3 Source cves: CVE-2025-47273 Source advisory: OSV:GHSA-5RJG-FVGR-3XXF...
coala (>=0.3.0.dev20151230202701, <=0.4.1.dev20160217212532), igitt (>=0.1.0.dev20160122122211, <=0.2.0.dev20160125152641) +1 more potentially affected by CVE-2025-47273 via setuptools (19.2.0)
setuptools PYPI version 19.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - coala =0.3.0.dev20151230202701, =0.1.0.dev20160122122211, =0.1.0, =0.1.1 Source cves: CVE-2025-47273 Source advisory: OSV:GHSA-5RJG-FVGR-3X...
coala (>=0.4.2.dev20160317151543, <=0.4.2.dev20160317165437), pex (>=1.1.2, <=1.1.5) +1 more potentially affected by CVE-2025-47273 via setuptools (19.7.0)
setuptools PYPI version 19.7.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - coala =0.4.2.dev20160317151543, =1.1.2, =1.1.5 - pyprint 0.2.2 Source cves: CVE-2025-47273 Source advisory: OSV:GHSA-5RJG-FVGR-3XXF...
ngsqc (0.1.1) potentially affected by CVE-2025-47273 via setuptools (20.2.2)
setuptools PYPI version 20.2.2 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - ngsqc 0.1.1 Source cves: CVE-2025-47273 Source advisory: OSV:GHSA-5RJG-FVGR-3XXF...