1457 matches found
cbs-sentry-dingding (1.0.24), cbs-sentry-qyweixin (1.0.1) +47 more potentially affected by CVE-2024-41656 via sentry (20.8.0)
sentry PYPI version 20.8.0 is affected by a known vulnerability. The following packages have a transitive dependency on sentry and may be impacted: - cbs-sentry-dingding 1.0.24 - cbs-sentry-qyweixin 1.0.1 - csnp =0.0.5, =1.0.0, =0.2.4, =1.0.0, =0.1.0, =0.4.0, =0.1.0, =0.2.0 and more Source cves:...
GHSA-FM88-HC3V-3WWW Sentry vulnerable to stored Cross-Site Scripting (XSS)
Impact An unsanitized payload sent by an Integration platform integration allows the storage of arbitrary HTML tags on the Sentry side. This payload could subsequently be rendered on the Issues page, creating a Stored Cross-Site Scripting XSS vulnerability. This vulnerability might lead to the...
Sentry vulnerable to stored Cross-Site Scripting (XSS)
Impact An unsanitized payload sent by an Integration platform integration allows the storage of arbitrary HTML tags on the Sentry side. This payload could subsequently be rendered on the Issues page, creating a Stored Cross-Site Scripting XSS vulnerability. This vulnerability might lead to the...
OPENSUSE-SU-2024:0214-1 Security update for python-sentry-sdk
This update for python-sentry-sdk fixes the following issues: - CVE-2024-40647: Do not leak environment variables to child processes. bsc1228128...
CVE-2024-41656: Improper Neutralization of Input During Web Page Generation
Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 24.7.1, an unsanitized payload sent by an Integration platform integration allows storing arbitrary HTML tags on the Sentry side with the subsequent rendering them on the Issues page...
Sentry security vulnerabilities
Sentry is Sentry's open source bug tracking and performance monitoring platform for developers. A security vulnerability exists in Sentry prior to version 24.7.1, which stems from a payload that can store arbitrary HTML tags on the Sentry side and can be displayed on the issue page...
Security update for python-sentry-sdk (moderate)
openSUSE Security Update: Security update for python-sentry-sdk Announcement ID: openSUSE-SU-2024:0214-1 Rating: moderate References: 1228128 Cross-References: CVE-2024-40647 Affected Products: openSUSE Backports SLE-15-SP5 An update that fixes one vulnerability is now available. Description: Thi...
Information Leakage
Sentry-sdk is vulnerable to Information Leakage. The vulnerability is due to subprocess calls leaking environment variables when the Stdlib integration is enabled, which could allow an attacker to gain access to sensitive environment variables by exploiting the unintended passing of these variabl...
SUSE CVE-2024-40647
sentry-sdk is the official Python SDK for Sentry.io. A bug in Sentry's Python SDK 2.8.0 allows the environment variables to be passed to subprocesses despite the env= setting. In Python's subprocess calls, all environment variables are passed to subprocesses by default. However, if you specifical...
OPENSUSE-SU-2024:14209-1 python310-sentry-sdk-2.10.0-1.1 on GA media
These are all security issues fixed in the python310-sentry-sdk-2.10.0-1.1 package on the GA media of openSUSE Tumbleweed...
alectio-sdk (>=0.6.2, <=0.6.14), alectiolite (0.0.1) +4 more potentially affected by CVE-2024-40647 via sentry-sdk (0.15.1)
sentry-sdk PYPI version 0.15.1 is affected by a known vulnerability. The following packages have a transitive dependency on sentry-sdk and may be impacted: - alectio-sdk =0.6.2, =0.4.3, =0.5.0a5 Source cves: CVE-2024-40647 Source advisory: OSV:GHSA-G92J-QHMH-64V2...
portfolio-website (>=1.1.2, <=1.1.6) potentially affected by CVE-2024-40647 via sentry-sdk (0.10.0)
sentry-sdk PYPI version 0.10.0 is affected by a known vulnerability. The following packages have a transitive dependency on sentry-sdk and may be impacted: - portfolio-website =1.1.2, =1.1.6 Source cves: CVE-2024-40647 Source advisory: OSV:GHSA-G92J-QHMH-64V2...
aioshadowsocks (>=0.1.1, <=0.1.6), cellprofiler (>=4.0.7, <=4.2.8.1) +5 more potentially affected by CVE-2024-40647 via sentry-sdk (0.18.0)
sentry-sdk PYPI version 0.18.0 is affected by a known vulnerability. The following packages have a transitive dependency on sentry-sdk and may be impacted: - aioshadowsocks =0.1.1, =4.0.7, =0.5.29, =0.13.0, =1.4.0, =0.2.9, =0.2.10 Source cves: CVE-2024-40647 Source advisory: OSV:GHSA-G92J-QHMH-64...
eqmaster (>=0.0.15, <=0.0.36), etestificatus (>=0.0.5, <=0.0.7) +7 more potentially affected by CVE-2024-40647 via sentry-sdk (0.14.1)
sentry-sdk PYPI version 0.14.1 is affected by a known vulnerability. The following packages have a transitive dependency on sentry-sdk and may be impacted: - eqmaster =0.0.15, =0.0.5, =0.7.0, =0.1.1.dev6, =3.5.0, =0.0.1, =0.0.37, =0.0.39 Source cves: CVE-2024-40647 Source advisory:...
richie (>=1.0.0b2, <=1.0.0b3), robotoff (>=1.0.6, <=1.0.12) potentially affected by CVE-2024-40647 via sentry-sdk (0.7.6)
sentry-sdk PYPI version 0.7.6 is affected by a known vulnerability. The following packages have a transitive dependency on sentry-sdk and may be impacted: - richie =1.0.0b2, =1.0.6, =1.0.12 Source cves: CVE-2024-40647 Source advisory: OSV:GHSA-G92J-QHMH-64V2...
ev3sim (2.2.3) potentially affected by CVE-2024-40647 via sentry-sdk (0.20.0)
sentry-sdk PYPI version 0.20.0 is affected by a known vulnerability. The following packages have a transitive dependency on sentry-sdk and may be impacted: - ev3sim 2.2.3 Source cves: CVE-2024-40647 Source advisory: OSV:GHSA-G92J-QHMH-64V2...
aicloud-deploy (0.0.1), apis-bibsonomy (0.2.3) +33 more potentially affected by CVE-2024-40647 via sentry-sdk (0.19.5)
sentry-sdk PYPI version 0.19.5 is affected by a known vulnerability. The following packages have a transitive dependency on sentry-sdk and may be impacted: - aicloud-deploy 0.0.1 - apis-bibsonomy 0.2.3 - apis-core =0.14.3, =0.8.8, =0.0.3, =1.0.43, =2.28.1, =0.1.102, =0.2.10, =11.0.0rc1, =0.1.0,...
big-graph-dataset (>=0.0.1, <=0.0.8.post4), bugsink (0.1.12) +28 more potentially affected by CVE-2024-40647 via sentry-sdk (>=2.0.0rc4, <=2.7.1)
sentry-sdk PYPI version =2.0.0rc4, =0.0.1, =1.7.0, =2.2.47, =2.2.47, =0.50.0, =1.8.0, =0.20.0, =2024.7.0b2, =0.5.27, =0.1.10, =2.2.2, =2.2.0.post1, =2024.6.0, =2024.6.1 and more Source cves: CVE-2024-40647 Source advisory: GHSA-G92J-QHMH-64V2...
big-graph-dataset (>=0.0.1, <=0.0.8.post4), bugsink (0.1.12) +28 more potentially affected by CVE-2024-40647 via sentry-sdk (>=2.0.0rc4, <=2.7.1)
sentry-sdk PYPI version =2.0.0rc4, =0.0.1, =1.7.0, =2.2.47, =2.2.47, =0.50.0, =1.8.0, =0.20.0, =2024.7.0b2, =0.5.27, =0.1.10, =2.2.2, =2.2.0.post1, =2024.6.0, =2024.6.1 and more Source cves: CVE-2024-40647 Source advisory: OSV:GHSA-G92J-QHMH-64V2...
aioshadowsocks (0.1.8), airbyte-cdk (>=0.1.45, <=0.1.60) +180 more potentially affected by CVE-2024-40647 via sentry-sdk (>=1.0.0, <=1.45.0)
sentry-sdk PYPI version =1.0.0, =0.1.45, =0.0.2, =0.0.1, =0.1.0, =0.0.1, =1.1.0, =1.1.0, =0.0.3, =202209.1088.0, =0.1.2, =3.0.1, =1.0.1, =3.0.0 and more Source cves: CVE-2024-40647 Source advisory: GHSA-G92J-QHMH-64V2...