Lucene search
+L

461 matches found

OSV
OSV
•added 2026/07/01 9:51 p.m.•25 views

GHSA-P9JG-FCR6-3MHF OnGres SCRAM silent channel-binding authentication downgrade via unsupported certificate algorithms

Summary A flaw in com.ongres.scram:scram-client allows an attacker capable of performing a TLS man-in-the-middle MITM attack to silently downgrade a connection from SCRAM-SHA-256-PLUS with channel binding to standard SCRAM-SHA-256 without channel binding, bypassing strict client-side enforcement...

8.2CVSS5.8AI score0.0026EPSS
SaveExploits0References2
Github Security Blog
Github Security Blog
•added 2026/07/01 9:51 p.m.•32 views

OnGres SCRAM silent channel-binding authentication downgrade via unsupported certificate algorithms

Summary A flaw in com.ongres.scram:scram-client allows an attacker capable of performing a TLS man-in-the-middle MITM attack to silently downgrade a connection from SCRAM-SHA-256-PLUS with channel binding to standard SCRAM-SHA-256 without channel binding, bypassing strict client-side enforcement...

8.2CVSS5.9AI score0.0026EPSS
SaveExploits0References2Affected Software2
Snyk
Snyk
•added 2026/07/01 9:51 p.m.•18 views

Not Failing Securely ('Failing Open')

Overview Affected versions of this package are vulnerable to Not Failing Securely 'Failing Open' in the TlsServerEndpoint process when a server presents an X.509 certificate using a modern signature algorithm lacking traditional naming structures. An attacker can bypass strict client-side...

8.2CVSS6AI score0.0026EPSS
SaveExploits0References2
Positive Technologies
Positive Technologies
•added 2026/07/01 12:00 a.m.•27 views

PT-2026-55221

Name of the Vulnerable Software and Affected Versions com.ongres.scram:scram-client versions prior to 3.3 com.ongres.scram:scram-common versions prior to 3.3 Description A flaw in com.ongres.scram:scram-client and com.ongres.scram:scram-common allows an attacker performing a TLS man-in-the-middle...

8.2CVSS5.3AI score0.0026EPSS
SaveExploits0References4
Tenable Nessus
Tenable Nessus
•added 2026/07/01 12:00 a.m.•13 views

Alibaba Cloud Linux 3 : 0171: postgresql:13 (ALINUX3-SA-2026:0171)

The remote Alibaba Cloud Linux 3 host has packages installed that are affected by a vulnerability as referenced in the ALINUX3-SA-2026:0171 advisory. Package updates are available for Alibaba Cloud Linux 3 that fix the following vulnerabilities: CVE-2026-6478: Covert timing channel in comparison ...

8.2CVSS6.6AI score0.00558EPSS
SaveExploits0References2
RedHat Linux
RedHat Linux
•added 2026/06/30 7:02 p.m.•20 views

ruby/net-imap: ruby: Net::IMAP: Denial of Service via large iteration count in SCRAM authentication

A flaw was found in Net::IMAP, a Ruby library for Internet Message Access Protocol IMAP client functionality. A hostile server can exploit this vulnerability during SCRAM-SHA1 or SCRAM-SHA256 Salted Challenge Response Authentication Mechanism - Secure Hash Algorithm 1 or 256 authentication by...

6.5CVSS5.8AI score0.00519EPSS
SaveExploits0References11
RedHat Linux
RedHat Linux
•added 2026/06/30 2:25 p.m.•27 views

ruby/net-imap: ruby: Net::IMAP: Denial of Service via large iteration count in SCRAM authentication

A flaw was found in Net::IMAP, a Ruby library for Internet Message Access Protocol IMAP client functionality. A hostile server can exploit this vulnerability during SCRAM-SHA1 or SCRAM-SHA256 Salted Challenge Response Authentication Mechanism - Secure Hash Algorithm 1 or 256 authentication by...

6.5CVSS5.8AI score0.00519EPSS
SaveExploits0References11
RedHat Linux
RedHat Linux
•added 2026/06/30 2:25 p.m.•11 views

ruby/net-imap: ruby: Net::IMAP: Denial of Service via large iteration count in SCRAM authentication

A flaw was found in Net::IMAP, a Ruby library for Internet Message Access Protocol IMAP client functionality. A hostile server can exploit this vulnerability during SCRAM-SHA1 or SCRAM-SHA256 Salted Challenge Response Authentication Mechanism - Secure Hash Algorithm 1 or 256 authentication by...

6.5CVSS5.8AI score0.00519EPSS
SaveExploits0References11
Ubuntu
Ubuntu
•added 2026/06/29 10:42 a.m.•23 views

USN-8478-1: Ruby vulnerabilities

It was discovered that Ruby's Net::IMAP library did not properly verify that TLS encryption was started after issuing a STARTTLS command. A remote attacker could use this to perform a machine-in-the-middle attack and silently bypass TLS encryption. CVE-2026-42246 It was discovered that Ruby's...

9.8CVSS7.5AI score0.00519EPSS
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2026/06/25 12:00 a.m.•20 views

Oracle Linux 9 : postgresql-jdbc (ELSA-2026-22304)

The remote Oracle Linux 9 host has a package installed that is affected by a vulnerability as referenced in the ELSA-2026-22304 advisory. - Add tests for CVE-2026-42198 - Fix CVE-2026-42198: limit SCRAM PBKDF2 iterations to prevent DoS Tenable has extracted the preceding description block directl...

7.5CVSS7.1AI score0.04117EPSS
SaveExploits0References2
Oracle linux
Oracle linux
•added 2026/06/23 12:00 a.m.•17 views

postgresql-jdbc security update

42.2.28-2.2 - Add tests for CVE-2026-42198 42.2.28-2.1 - Fix CVE-2026-42198: limit SCRAM PBKDF2 iterations to prevent DoS - Resolves: RHEL-173489...

7.5CVSS7.2AI score0.04117EPSS
SaveExploits0
Fedora
Fedora
•added 2026/06/20 12:51 a.m.•25 views

[SECURITY] Fedora 44 Update: ongres-scram-3.3-1.fc44

This is a Java implementation of SCRAM Salted Challenge Response Authentication Mechanism which is part of the family of Simple Authentication and Security Layer SASL, RFC 4422 authentication mechanisms. It is described as part of RFC 5802 and RFC7677...

5.8AI score
SaveExploits0
Fedora
Fedora
•added 2026/06/19 1:10 a.m.•28 views

[SECURITY] Fedora 43 Update: ongres-scram-3.3-1.fc43

This is a Java implementation of SCRAM Salted Challenge Response Authentication Mechanism which is part of the family of Simple Authentication and Security Layer SASL, RFC 4422 authentication mechanisms. It is described as part of RFC 5802 and RFC7677...

5.4AI score
SaveExploits0
IBM Security Bulletins
IBM Security Bulletins
•added 2026/06/17 3:24 p.m.•19 views

Security Bulletin: IBM Watson Discovery Cartridge affected by vulnerability in postgresql-42.6.1.jar

Summary IBM Watson Discovery Cartridge affected by vulnerability in postgresql-42.6.1.jar Vulnerability Details CVEID:CVE-2026-42198 DESCRIPTION: pgjdbc is an open source postgresql JDBC Driver. From version 42.2.0 to before version 42.7.11, pgjdbc is vulnerable to a client-side denial of service...

7.5CVSS7AI score0.04117EPSS
SaveExploits0Affected Software1
Tenable Nessus
Tenable Nessus
•added 2026/06/16 12:00 a.m.•20 views

Alibaba Cloud Linux 3 : 0155: postgresql-jdbc (ALINUX3-SA-2026:0155)

The remote Alibaba Cloud Linux 3 host has packages installed that are affected by a vulnerability as referenced in the ALINUX3-SA-2026:0155 advisory. Package updates are available for Alibaba Cloud Linux 3 that fix the following vulnerabilities: CVE-2026-42198: pgjdbc is an open source postgresql...

7.5CVSS7AI score0.04117EPSS
SaveExploits0References2
Tenable Nessus
Tenable Nessus
•added 2026/06/15 12:00 a.m.•17 views

Linux Distros Unpatched Vulnerability : CVE-2026-10143

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - kafka-python prior to 2.3.2 contains a denial-of-service vulnerability in SCRAM authentication handling that allows a malicious or machine-in-the-middle broker ...

8.7CVSS5.9AI score0.00517EPSS
SaveExploits0References3
OSV
OSV
•added 2026/06/12 12:00 p.m.•44 views

RUSTSEC-2026-0179 Unbounded SCRAM iteration count allows a malicious server to cause CPU-exhaustion denial of service

A malicious, compromised, or man-in-the-middle server can supply an arbitrarily large SCRAM-SHA-256 PBKDF2 iteration count during authentication. The client runs it inline with no upper bound, pinning a tokio worker thread for minutes per connection, possibly stalling the whole async runtime...

8.7CVSS5.5AI score
SaveExploits0References4
RustSec
RustSec
•added 2026/06/12 12:00 p.m.•32 views

Unbounded SCRAM iteration count allows a malicious server to cause CPU-exhaustion denial of service

A malicious, compromised, or man-in-the-middle server can supply an arbitrarily large SCRAM-SHA-256 PBKDF2 iteration count during authentication. The client runs it inline with no upper bound, pinning a tokio worker thread for minutes per connection, possibly stalling the whole async runtime...

5.4AI score
SaveExploits0Affected Software1
SUSE CVE
SUSE CVE
•added 2026/06/12 2:32 a.m.•27 views

SUSE CVE-2026-10143

kafka-python prior to 2.3.2 contains a denial-of-service vulnerability in SCRAM authentication handling that allows a malicious or machine-in-the-middle broker to freeze the client event loop by supplying an excessively large iteration count. In scram.py, ScramClient.processserverfirstmessage...

8.7CVSS5.9AI score0.00517EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2026/06/12 12:00 a.m.•27 views

MiracleLinux 8 : postgresql-jdbc-42.2.14-4.el8_10 (AXSA:2026-782:01)

The remote MiracleLinux 8 host has packages installed that are affected by a vulnerability as referenced in the AXSA:2026-782:01 advisory. jdbc.postgresql.org: pgjdbc: Client-side Denial of Service via malicious SCRAM-SHA-256 authentication CVE-2026-42198 Tenable has extracted the preceding...

7.5CVSS7.2AI score0.04117EPSS
SaveExploits0References2
Rows per page
Query Builder