6746 matches found
EulerOS Virtualization 2.13.1 : sqlite (EulerOS-SA-2025-2564)
According to the versions of the sqlite package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns...
Security Bulletin:Vulnerability in SQLite affects IBM Netezza Appliance
Summary The SQLite package is used by IBM Netezza Appliance . IBM Netezza Appliance has addressed the applicable CVEs CVE-2019-19244, CVE-2019-9936, CVE-2019-9937, CVE-2024-0232 Vulnerability Details CVEID:CVE-2019-19244 DESCRIPTION: sqlite3Select in select.c in SQLite 3.30.1 allows a crash if a...
Exploit for SQL Injection in Fortinet Fortiweb
CVE-2025-25257 - Environnement d'Expérimentation Architecture...
CVE-2025-34179: Improper Neutralization of Special Elements used in an SQL Command
NetSupport Manager 14.12.0001 contains an unauthenticated SQL injection vulnerability in its Connectivity Server/Gateway HTTPS request handling. The server evaluates request URIs using an unsanitized SQLite query against the FileLinks table in gateway.db. By injecting SQL through the LinkName/URI...
Nutanix AHV : Multiple Vulnerabilities (NXSA-AHV-11.0)
The version of AHV installed on the remote host is prior to 11.0. It is, therefore, affected by multiple vulnerabilities as referenced in the NXSA-AHV-11.0 advisory. - libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a use-after-free in xmlSchemaIDCFillNodeTables and xmlSchemaBubbleIDCNodeTabl...
SQL Injection
LangGraph SQLite Checkpoint is vulnerable to SQL injection. The vulnerability is due to unsafe construction of SQL queries using unvalidated metadata filter keys, where attacker-controlled keys are interpolated directly into SQL f-strings in the checkpoint search logic, allowing manipulation of...
SQL Injection
langgraph-checkpoint-sqlite is vulnerable to SQL Injection. The vulnerability is due to use of direct string concatenation without proper parameterization in database queries, which allows an attacker to inject arbitrary SQL and bypass access controls...
CVE-2025-67644
LangGraph SQLite Checkpoint is an implementation of LangGraph CheckpointSaver that uses SQLite DB both sync and async, via aiosqlite. Versions 3.0.0 and below are vulnerable to SQL injection through the checkpoint implementation. Checkpoint allows attackers to manipulate SQL queries through...
CVE-2025-67644
LangGraph SQLite Checkpoint is an implementation of LangGraph CheckpointSaver that uses SQLite DB both sync and async, via aiosqlite. Versions 3.0.0 and below are vulnerable to SQL injection through the checkpoint implementation. Checkpoint allows attackers to manipulate SQL queries through...
CVE-2025-67644: Improper Neutralization of Special Elements used in an SQL Command
LangGraph SQLite Checkpoint is an implementation of LangGraph CheckpointSaver that uses SQLite DB both sync and async, via aiosqlite. Versions 3.0.0 and below are vulnerable to SQL injection through the checkpoint implementation. Checkpoint allows attackers to manipulate SQL queries through...
SQL Injection
Overview langgraph-checkpoint-sqlite is a Library with a SQLite implementation of LangGraph checkpoint saver. Affected versions of this package are vulnerable to SQL Injection via the metadatapredicate function. An attacker can execute arbitrary SQL commands by supplying crafted metadata filter...
langgraph-agent-toolkit (>=0.8.0, <=0.8.15), tabsdata-agent (>=1.5.0, <=1.5.1) potentially affected by CVE-2025-67644 via langgraph-checkpoint-sqlite (3.0.0)
langgraph-checkpoint-sqlite PYPI version 3.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on langgraph-checkpoint-sqlite and may be impacted: - langgraph-agent-toolkit =0.8.0, =1.5.0, =1.5.1 Source cves: CVE-2025-67644 Source advisory:...
CVE-2025-67644
LangGraph SQLite Checkpoint (langgraph-checkpoint-sqlite) is vulnerable to SQL injection in the _metadata_predicate() path, where unvalidated metadata filter keys are interpolated into SQL. Affected versions are 3.0.0 and earlier; fixed in 3.0.1. The issue allows attackers controlling filter keys...
CVE-2025-67644 LangGraph SQLite Checkpoint is vulnerable to SQL Injection via metadata filter key in checkpointer list method
LangGraph SQLite Checkpoint is an implementation of LangGraph CheckpointSaver that uses SQLite DB both sync and async, via aiosqlite. Versions 3.0.0 and below are vulnerable to SQL injection through the checkpoint implementation. Checkpoint allows attackers to manipulate SQL queries through...
agentfoundry (1.2.9.1), agentic-graph-composer (0.1.0) +21 more potentially affected by CVE-2025-67644 via langgraph-checkpoint-sqlite (>=1.0.4, <=3.0.0)
langgraph-checkpoint-sqlite PYPI version =1.0.4, =0.0.45, =0.1.0a2, =0.1.0a1, =0.9.9, =0.0.2, =0.0.1, =0.1.0, =0.1.0, =0.1.4 - my-agent 0.1.0 - novachain 0.1.0 and more Source cves: CVE-2025-67644 Source advisory: MEND:CVE-2025-67644...
CVE-2025-67644 LangGraph SQLite Checkpoint is vulnerable to SQL Injection via metadata filter key in checkpointer list method
LangGraph SQLite Checkpoint is an implementation of LangGraph CheckpointSaver that uses SQLite DB both sync and async, via aiosqlite. Versions 3.0.0 and below are vulnerable to SQL injection through the checkpoint implementation. Checkpoint allows attackers to manipulate SQL queries through...
br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin (>=0.1.0, <=0.3.5), org.jenkins-ci.main:jenkins-test-harness (1.625.2) +6 more potentially affected by CVE-2025-67639 via org.jenkins-ci.main:jenkins-core (1.625.2)
org.jenkins-ci.main:jenkins-core MAVEN version 1.625.2 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin =0.1.0, =1.0.1, =1.0.2 Source cves:...
br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin (>=0.1.0, <=0.3.5), org.jenkins-ci.main:jenkins-test-harness (1.625.2) +6 more potentially affected by CVE-2025-67636 via org.jenkins-ci.main:jenkins-core (1.625.2)
org.jenkins-ci.main:jenkins-core MAVEN version 1.625.2 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin =0.1.0, =1.0.1, =1.0.2 Source cves:...
br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin (>=0.1.0, <=0.3.5), org.jenkins-ci.main:jenkins-test-harness (1.625.2) +6 more potentially affected by CVE-2025-67638 via org.jenkins-ci.main:jenkins-core (1.625.2)
org.jenkins-ci.main:jenkins-core MAVEN version 1.625.2 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin =0.1.0, =1.0.1, =1.0.2 Source cves:...
br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin (>=0.1.0, <=0.3.5), org.jenkins-ci.main:jenkins-test-harness (1.625.2) +6 more potentially affected by CVE-2025-67635 via org.jenkins-ci.main:jenkins-core (1.625.2)
org.jenkins-ci.main:jenkins-core MAVEN version 1.625.2 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin =0.1.0, =1.0.1, =1.0.2 Source cves:...