Lucene search
+L

819 matches found

RedhatCVE
RedhatCVE
•added 2025/05/11 12:15 a.m.•39 views

CVE-2025-47736

dialect/mod.rs in the libsql-sqlite3-parser crate through 0.13.0 before 14f422a for Rust can crash if the input is not valid UTF-8...

2.9CVSS5.9AI score0.00257EPSS
SaveExploits0References1
Github Security Blog
Github Security Blog
•added 2025/05/09 6:32 a.m.•31 views

libsql-sqlite3-parser crash due to invalid UTF-8 input

dialect/mod.rs in the libsql-sqlite3-parser crate through 0.13.0 before 14f422a for Rust can crash if the input is not valid UTF-8...

2.9CVSS5.8AI score0.00257EPSS
SaveExploits0References6Affected Software1
osv_ghsa
osv_ghsa
•added 2025/05/09 6:32 a.m.•41 views

GHSA-8M95-FFFC-H4C5 libsql-sqlite3-parser crash due to invalid UTF-8 input

dialect/mod.rs in the libsql-sqlite3-parser crate through 0.13.0 before 14f422a for Rust can crash if the input is not valid UTF-8...

2.9CVSS5.8AI score0.00257EPSS
SaveExploits0References5
NVD
NVD
•added 2025/05/09 5:15 a.m.•35 views

CVE-2025-47736

dialect/mod.rs in the libsql-sqlite3-parser crate through 0.13.0 before 14f422a for Rust can crash if the input is not valid UTF-8...

2.9CVSS0.00257EPSS
SaveExploits0References4
Cvelist
Cvelist
•added 2025/05/09 12:00 a.m.•44 views

CVE-2025-47736

dialect/mod.rs in the libsql-sqlite3-parser crate through 0.13.0 before 14f422a for Rust can crash if the input is not valid UTF-8...

2.9CVSS0.00257EPSS
SaveExploits0References4
osv_cve
osv_cve
•added 2025/05/09 12:00 a.m.•22 views

CVE-2025-47736

dialect/mod.rs in the libsql-sqlite3-parser crate through 0.13.0 before 14f422a for Rust can crash if the input is not valid UTF-8...

2.9CVSS5.8AI score0.00257EPSS
SaveExploits0References6
Mend
Mend
•added 2025/05/09 12:00 a.m.•13 views

CVE-2025-47736

dialect/mod.rs in the libsql-sqlite3-parser crate through 0.13.0 before 14f422a for Rust can crash if the input is not valid UTF-8...

2.9CVSS5.8AI score0.00257EPSS
SaveExploits0References6
CVE
CVE
•added 2025/05/09 12:00 a.m.•94 views

CVE-2025-47736

The CVE-2025-47736 issue affects the libsql-sqlite3-parser crate (Rust). Specifically, the dialect/mod.rs component can crash when given input that is not valid UTF-8, affecting versions up to 0.13.0 and before the commit 14f422a. The vulnerability arises from handling non-UTF-8 input during pars...

2.9CVSS5.8AI score0.00257EPSS
SaveExploits0References4
Positive Technologies
Positive Technologies
•added 2025/05/09 12:00 a.m.•33 views

PT-2025-20471 · Unknown · Libsql-Sqlite3-Parser

Name of the Vulnerable Software and Affected Versions: libsql-sqlite3-parser versions 0.13.0 and earlier Description: The issue is related to the dialect/mod.rs file in the libsql-sqlite3-parser crate for Rust, which can crash if the input is not valid UTF-8. Recommendations: For versions 0.13.0...

2.9CVSS5.8AI score0.00257EPSS
SaveExploits0References10
Tenable Nessus
Tenable Nessus
•added 2025/05/09 12:00 a.m.•19 views

SUSE SLED15: libsqlite3-0 / libsqlite3-0-32bit / sqlite3 / sqlite3-devel / etc (SUSE-SU-2025:1456-1)

The remote SUSE Linux SLED15 / SLEDSAP15 / SLES15 / SLESSAP15 / openSUSE 15 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2025:1456-1 advisory. - CVE-2025-29087,CVE-2025-3277: Fixed integer overflow in sqlite concat function bsc1241020 -...

9.8CVSS7AI score0.01252EPSS
SaveExploits0References10
Tenable Nessus
Tenable Nessus
•added 2025/05/09 12:00 a.m.•19 views

SUSE SLES12: libsqlite3-0 / libsqlite3-0-32bit / sqlite3 / sqlite3-devel / etc (SUSE-SU-2025:1455-1)

The remote SUSE Linux SLES12 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2025:1455-1 advisory. - CVE-2025-3277,CVE-2025-29087: Fixed integer overflow in sqlite concat function bsc1241020 - CVE-2025-29088: Fixed integer overflow through th...

9.8CVSS7AI score0.01252EPSS
SaveExploits0References10
osv_suse
osv_suse
•added 2025/05/07 3:13 p.m.•14 views

SUSE-SU-2025:1455-1 Security update for sqlite3

This update for sqlite3 fixes the following issues: - CVE-2025-3277,CVE-2025-29087: Fixed integer overflow in sqlite concat function bsc1241020 - CVE-2025-29088: Fixed integer overflow through the SQLITEDBCONFIGLOOKASIDE component bsc1241078 Other fixes: - Updated to version 3.49.1 from Factory...

9.8CVSS6.7AI score0.01252EPSS
SaveExploits0References7
osv_suse
osv_suse
•added 2025/05/07 3:13 p.m.•7 views

SUSE-SU-2025:1456-1 Security update for sqlite3

This update for sqlite3 fixes the following issues: - CVE-2025-29087,CVE-2025-3277: Fixed integer overflow in sqlite concat function bsc1241020 - CVE-2025-29088: Fixed integer overflow through the SQLITEDBCONFIGLOOKASIDE component bsc1241078 Other fixes: - Updated to version 3.49.1 from Factory...

9.8CVSS6.7AI score0.01252EPSS
SaveExploits0References7
SUSE Linux
SUSE Linux
•added 2025/05/05 10:52 a.m.•11 views

Security update for sqlite3

This update for sqlite3 fixes the following issues: CVE-2025-29087: Fixed integer overflow in sqlite concat function bsc1241020 CVE-2025-29088: Fixed integer overflow through the SQLITEDBCONFIGLOOKASIDE component bsc1241078 Other fixes: Updated to version 3.49.1 from Factory jscSLE-16032 Patch...

6.8CVSS6.7AI score0.00523EPSS
SaveExploits0References10
SUSE Linux
SUSE Linux
•added 2025/05/05 10:51 a.m.•11 views

Security update for sqlite3

This update for sqlite3 fixes the following issues: CVE-2025-29087: Fixed integer overflow in sqlite concat function bsc1241020 CVE-2025-29088: Fixed integer overflow through the SQLITEDBCONFIGLOOKASIDE component bsc1241078 Other fixes: Updated to version 3.49.1 from Factory jscSLE-16032 Patch...

6.8CVSS6.7AI score0.00523EPSS
SaveExploits0References10
Snyk
Snyk
•added 2025/04/14 5:41 p.m.•13 views

Integer Overflow or Wraparound

Overview Affected versions of this package are vulnerable to Integer Overflow or Wraparound in the concat function. An attacker can trigger an integer overflow by supplying input with an excessive number of separators and arguments. Note: This vulnerability has also been published as CVE-2025-327...

9.8CVSS6.5AI score0.01252EPSS
SaveExploits0References2
SUSE CVE
SUSE CVE
•added 2025/04/12 3:29 a.m.•10 views

SUSE CVE-2025-29088

In SQLite 3.49.0 before 3.49.1, certain argument values to sqlite3dbconfig in the C-language API can cause a denial of service application crash. An sznBig multiplication is not cast to a 64-bit integer, and consequently some memory allocations may be incorrect...

5.5CVSS6.6AI score0.00217EPSS
SaveExploits0References12
Snyk
Snyk
•added 2025/04/07 8:42 p.m.•10 views

Integer Overflow or Wraparound

Overview Affected versions of this package are vulnerable to Integer Overflow or Wraparound in the concat function. An attacker can trigger an integer overflow by supplying input with an excessive number of separators and arguments. Note: This vulnerability has also been published as CVE-2025-327...

9.8CVSS6.5AI score0.01252EPSS
SaveExploits0References2
Tenable Nessus
Tenable Nessus
•added 2025/03/04 12:00 a.m.•16 views

Linux Distros Unpatched Vulnerability : CVE-2019-8457

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - SQLite3 from 3.6.0 to and including 3.27.2 is vulnerable to heap out-of-bound read in the rtreenode function when handling invalid rtree tables. CVE-2019-8457...

9.8CVSS7.6AI score0.45426EPSS
SaveExploits0References3
UbuntuCve
UbuntuCve
•added 2025/02/21 12:00 p.m.•25 views

CVE-2025-26794

Exim 4.98 before 4.98.1, when SQLite hints and ETRN serialization are used, allows remote SQL injection. Resolving SQL injection requires an update to 4.99.1 in certain non-default rate-limit configurations...

9.8CVSS7.7AI score0.77486EPSS
SaveExploits6References1
Rows per page
Query Builder