12751 matches found
new packages: rust-toolset
An update is available for rust-toolset. This update affects Rocky Linux 9. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list For detailed information on changes in this release, see the Rocky Linux...
new packages: rust-coreos-installer
An update is available for rust-coreos-installer. This update affects Rocky Linux 9. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list For detailed information on changes in this release, see the...
rust-toolset:ol8 security, bug fix, and enhancement update
rust 1.58.1-1 - Update to 1.58.1. 1.58.0-1 - Update to 1.58.0. 1.57.0-1 - Update to 1.57.0. 1.56.1-2 - Add rust-std-static-wasm32-wasi Resolves: rhbz1980080 1.56.0-1 - Update to 1.56.1. 1.55.0-1 - Update to 1.55.0. - Backport support for LLVM 13. 1.54.0-2 - Make std-static-wasm arch-specific to...
AlmaLinux 8 : rust-toolset:rhel8 (ALSA-2022:1894)
The remote AlmaLinux 8 host has packages installed that are affected by a vulnerability as referenced in the ALSA-2022:1894 advisory. rust: Race condition in removedirall leading to removal of files outside of the directory being removed CVE-2022-21658 Tenable has extracted the preceding...
wee_alloc is Unmaintained
Two of the maintainers have indicated that the crate may not be maintained. The crate has open issues including memory leaks and may not be suitable for production use. It may be best to switch to the default Rust standard allocator on wasm32 targets. Last release seems to have been three years...
RUSTSEC-2022-0054 wee_alloc is Unmaintained
Two of the maintainers have indicated that the crate may not be maintained. The crate has open issues including memory leaks and may not be suitable for production use. It may be best to switch to the default Rust standard allocator on wasm32 targets. Last release seems to have been three years...
RHEL 8 : rust-toolset:rhel8 (RHSA-2022:1894)
The remote Redhat Enterprise Linux 8 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2022:1894 advisory. Rust Toolset provides the Rust programming language compiler rustc, the cargo build tool and dependency manager, and required libraries. The followin...
Moderate: Red Hat Security Advisory: rust-toolset:rhel8 security, bug fix, and enhancement update
An update for the rust-toolset:rhel8 module is now available for Red Hat Enterprise Linux 8. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each...
abi_stable (>=0.4.0, <=0.8.4), aeron-rs (>=0.1.2, <=0.1.3) +388 more potentially affected by unknown CVE via crossbeam-channel (>=0.1.3, <=0.3.9)
crossbeam-channel CARGO version =0.1.3, =0.4.0, =0.1.2, =0.7.5, =0.2.5, =0.4.0, =0.5.0, =0.1.0, =0.6.0, =0.5.0, =0.4.0, =0.5.0, =0.6.0 - amethystderive 0.3.0 and more Source cves: unknown CVE Source advisory: OSV:RUSTSEC-2022-0019...
abc (>=0.1.0, <=0.2.3), aerospike (>=0.0.1, <=1.3.0) +413 more potentially affected by unknown CVE via crossbeam (>=0.1.6, <=0.6.0)
crossbeam CARGO version =0.1.6, =0.1.0, =0.0.1, =0.2.0, =0.1.0, =0.1.0, =0.1.0, =0.5.0, =0.1.0, =0.2.0, =0.6.0, =0.7.0, =0.2.0, =0.2.0, =0.1.0, =0.2.0 and more Source cves: unknown CVE Source advisory: OSV:RUSTSEC-2022-0020...
malicious crate `rustdecimal`
The Rust Security Response WG and the crates.io team were notified1 on 2022-05-02 of the existence of the malicious crate rustdecimal, which contained malware. The crate name was intentionally similar to the name of the popular rustdecimal2 crate, hoping that potential victims would misspell its...
Moderate: rust-toolset:rhel8 security, bug fix, and enhancement update
Rust Toolset provides the Rust programming language compiler rustc, the cargo build tool and dependency manager, and required libraries. The following packages have been upgraded to a later upstream version: rust 1.58.0. BZ2002883 Security Fixes: rust: Race condition in removedirall leading to...
ALSA-2022:1894 Moderate: rust-toolset:rhel8 security, bug fix, and enhancement update
Rust Toolset provides the Rust programming language compiler rustc, the cargo build tool and dependency manager, and required libraries. The following packages have been upgraded to a later upstream version: rust 1.58.0. BZ2002883 Security Fixes: rust: Race condition in removedirall leading to...
rust-toolset:rhel8 security, bug fix, and enhancement update
An update is available for rust-toolset, rust. This update affects Rocky Linux 8. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list Rust Toolset provides the Rust programming language compiler rustc...
RLSA-2022:1894 Moderate: rust-toolset:rhel8 security, bug fix, and enhancement update
Rust Toolset provides the Rust programming language compiler rustc, the cargo build tool and dependency manager, and required libraries. The following packages have been upgraded to a later upstream version: rust 1.58.0. BZ2002883 Security Fixes: rust: Race condition in removedirall leading to...
CentOS 8 : rust-toolset:rhel8 (CESA-2022:1894)
The remote CentOS Linux 8 host has packages installed that are affected by a vulnerability as referenced in the CESA-2022:1894 advisory. - rust: Race condition in removedirall leading to removal of files outside of the directory being removed CVE-2022-21658 Note that Nessus has not tested for thi...
FBI Warns of BlackCat Ransomware That Breached Over 60 Organisations Worldwide
The U.S. Federal Bureau of Investigation FBI is sounding the alarm on the BlackCat ransomware-as-a-service RaaS, which it said victimized at least 60 entities worldwide between as of March 2022 since its emergence last November. Also called ALPHV and Noberus, the malware is notable for being the...
afire_compress (>=0.1.0, <=0.1.1-alpha) potentially affected by unknown CVE via afire (0.3.0)
afire CARGO version 0.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on afire and may be impacted: - afirecompress =0.1.0, =0.1.1-alpha Source cves: unknown CVE Source advisory: OSV:GHSA-3227-R97M-8J95...
Denial Of Service (DoS)
crossbeam-utils is vulnerable to firefox:devel. It provides atomics, synchronization primitives, scoped threads, and other utilities for concurrent programming in Rust. crossbeam-utils incorrectly assumed that the alignment of i,u64 was always the same as AtomicI,U64. However, the alignment of...
SWHKD has unspecified vulnerabilities (CNVD-2022-36045)
SWHKD is a display protocol-independent hotkey daemon made in Rust. SWHKD has a security vulnerability that stems from keyboard events using an unintended user, which can be exploited by an attacker to cause information disclosure, but is usually a denial of functionality...