Lucene search
+L

12406 matches found

Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2024/12/20 12:00 a.m.•4 views

CVE-2024-56335: Improper Privilege Management

vaultwarden is an unofficial Bitwarden compatible server written in Rust, formerly known as bitwardenrs. In affected versions an attacker is capable of updating or deleting groups from an organization given a few conditions: 1. The attacker has a user account in the server. 2. The attacker's...

7.6CVSS5.9AI score0.00338EPSS
SaveExploits0References1
CBLMariner
CBLMariner
•added 2024/12/19 11:06 p.m.•26 views

CVE-2024-43806 affecting package rust for versions less than 1.72.0-9

CVE-2024-43806 affecting package rust for versions less than 1.72.0-9. A patched version of the package is available...

6.5CVSS5.8AI score0.0048EPSS
SaveExploits0
osv_cve
osv_cve
•added 2024/12/19 10:24 p.m.•22 views

CVE-2024-56327 Malicious plugin names, recipients, or identities can cause arbitrary binary execution in pyrage

pyrage is a set of Python bindings for the rage file encryption library age in Rust. pyrage uses the Rust age crate for its underlying operations, and age is vulnerable to GHSA-4fg7-vxc8-qx5w. All details of GHSA-4fg7-vxc8-qx5w are relevant to pyrage for the versions specified in this advisory. S...

7.7CVSS6.6AI score
SaveExploits0References5
Github Security Blog
Github Security Blog
•added 2024/12/19 3:14 p.m.•38 views

pyrage vulnerable to malicious plugin names, recipients, or identities causing arbitrary binary execution

pyrage uses the Rust age crate for its underlying operations, and age is vulnerable to GHSA-4fg7-vxc8-qx5w. All details of GHSA-4fg7-vxc8-qx5w are relevant to pyrage for the versions specified in this advisory. See GHSA-4fg7-vxc8-qx5w for full details. Versions of pyrage before 1.2.0 lack plugin...

9.8CVSS5.7AI score0.00499EPSS
SaveExploits0References6Affected Software1
osv_ghsa
osv_ghsa
•added 2024/12/19 3:14 p.m.•63 views

GHSA-47H8-JMP3-9F28 pyrage vulnerable to malicious plugin names, recipients, or identities causing arbitrary binary execution

pyrage uses the Rust age crate for its underlying operations, and age is vulnerable to GHSA-4fg7-vxc8-qx5w. All details of GHSA-4fg7-vxc8-qx5w are relevant to pyrage for the versions specified in this advisory. See GHSA-4fg7-vxc8-qx5w for full details. Versions of pyrage before 1.2.0 lack plugin...

9.8CVSS5.7AI score0.00499EPSS
SaveExploits0References6
vulnersOsv
vulnersOsv
•added 2024/12/19 12:00 p.m.•6 views

butterfly-fuzz (>=0.1.0, <=0.2.2), libafl_frida (>=0.1.0, <=0.3.2) +4 more potentially affected by unknown CVE via libafl (>=0.1.0, <=0.10.1)

libafl CARGO version =0.1.0, =0.1.0, =0.1.0, =0.6.0, =0.6.0, =0.3.1, =0.1.0, =0.10.1 Source cves: unknown CVE Source advisory: OSV:RUSTSEC-2024-0424...

5.8AI score
SaveExploits0
CNNVD
CNNVD
•added 2024/12/19 12:00 a.m.•23 views

Pyrage code injection vulnerability

pyrage is a Python binding for rage by the individual developer William Woodruff. A code injection vulnerability exists in pyrage versions 1.2.0, 1.2.1, and 1.2.2, which stems from a vulnerability in the Rust age crate on which it depends...

9.8CVSS5.8AI score0.00499EPSS
SaveExploits0References3
osv_rustsec
osv_rustsec
•added 2024/12/12 12:00 p.m.•21 views

RUSTSEC-2024-0437 Crash due to uncontrolled recursion in protobuf crate

Affected version of this crate did not properly parse unknown fields when parsing a user-supplied input. This allows an attacker to cause a stack overflow when parsing the mssage on untrusted data...

5.9CVSS6.1AI score0.00473EPSS
SaveExploits0References3
Positive Technologies
Positive Technologies
•added 2024/12/12 12:00 a.m.•20 views

PT-2025-28031

Name of the Vulnerable Software and Affected Versions: protobuf crate for Rust versions prior to 3.7.2 Description: The issue allows uncontrolled recursion in the protobuf::coded input stream::CodedInputStream::skip group function when parsing unknown fields in untrusted input. This can occur due...

8.7CVSS6AI score0.00473EPSS
SaveExploits0References32
vulnersOsv
vulnersOsv
•added 2024/12/11 9:47 p.m.•17 views

pqcrypto (>=0.12.2, <=0.16.1), pqcrypto-compat (0.1.0) potentially affected by unknown CVE via pqcrypto-hqc (>=0.0.4, <=0.1.6)

pqcrypto-hqc CARGO version =0.0.4, =0.12.2, =0.16.1 - pqcrypto-compat 0.1.0 Source cves: unknown CVE Source advisory: OSV:GHSA-753P-WRJ5-G8FJ...

5.8AI score
SaveExploits0
OpenVAS
OpenVAS
•added 2024/12/11 12:00 a.m.•9 views

Fedora: Security Advisory (FEDORA-2024-5a5f401785)

The remote host is missing an update for the SPDX-FileCopyrightText: 2024 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...

7.5AI score
SaveExploits0References3
vulnersOsv
vulnersOsv
•added 2024/12/10 4:55 p.m.•13 views

cosmwasm-check (>=1.1.0-rc.1, <=1.3.4), cw-check-contract (1.0.1) +2 more potentially affected by unknown CVE via cosmwasm-vm (>=1.2.8, <=1.3.4)

cosmwasm-vm CARGO version =1.2.8, =1.1.0-rc.1, =1.3.4 - cw-check-contract 1.0.1 - cw-desmos-dummy-tokenomics 0.0.3 - cw-desmos-filter-posts 0.1.4 Source cves: unknown CVE Source advisory: OSV:GHSA-VMQH-5232-V43R...

5.8AI score
SaveExploits0
Fedora
Fedora
•added 2024/12/10 1:24 a.m.•20 views

[SECURITY] Fedora 41 Update: rust-rbspy-0.24.0-3.fc41

Sampling CPU profiler for Ruby...

7.4AI score
SaveExploits0
Fedora
Fedora
•added 2024/12/10 1:24 a.m.•23 views

[SECURITY] Fedora 41 Update: rust-rustls-0.23.19-1.fc41

Rustls is a modern TLS library written in Rust...

7.3AI score
SaveExploits0
Fedora
Fedora
•added 2024/12/10 1:19 a.m.•22 views

[SECURITY] Fedora 40 Update: rust-rbspy-0.24.0-3.fc40

Sampling CPU profiler for Ruby...

7.4AI score
SaveExploits0
Fedora
Fedora
•added 2024/12/10 1:19 a.m.•22 views

[SECURITY] Fedora 40 Update: rust-rustls-0.23.19-1.fc40

Rustls is a modern TLS library written in Rust...

7.3AI score
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2024/12/10 12:00 a.m.•8 views

Fedora 40 : rust-rustls (2024-5a5f401785)

The remote Fedora 40 host has a package installed that is affected by a vulnerability as referenced in the FEDORA-2024-5a5f401785 advisory. Update to version 0.23.19. This version includes fix for RUSTSEC-2024-0399. Tenable has extracted the preceding description block directly from the Fedora...

5.6AI score
SaveExploits0References1
Tenable Nessus
Tenable Nessus
•added 2024/12/10 12:00 a.m.•7 views

Fedora 41 : rust-rustls (2024-0d14d0d2f9)

The remote Fedora 41 host has a package installed that is affected by a vulnerability as referenced in the FEDORA-2024-0d14d0d2f9 advisory. Update to version 0.23.19. This version includes fix for RUSTSEC-2024-0399. Tenable has extracted the preceding description block directly from the Fedora...

5.6AI score
SaveExploits0References1
vulnersOsv
vulnersOsv
•added 2024/12/09 12:00 p.m.•8 views

gtk-layer-shell (>=0.1.0, <=0.8.2), hyprdock (>=0.3.0, <=0.4.1) +1 more potentially affected by unknown CVE via gtk-layer-shell-sys (>=0.0.1, <=0.7.0)

gtk-layer-shell-sys CARGO version =0.0.1, =0.1.0, =0.3.0, =0.1.0, =0.1.1 Source cves: unknown CVE Source advisory: OSV:RUSTSEC-2024-0423...

5.8AI score
SaveExploits0
vulnersOsv
vulnersOsv
•added 2024/12/05 7:05 p.m.•5 views

acir (>=0.44.0, <=0.46.0), age (>=0.7.0, <=0.9.3) +114 more potentially affected by unknown CVE via pprof (>=0.3.23, <=0.13.0)

pprof CARGO version =0.3.23, =0.44.0, =0.7.0, =1.0.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =1.0.0, =1.0.1, =0.1.0, =1.0.8, =1.0.8, =1.1.0 and more Source cves: unknown CVE Source advisory: OSV:GHSA-GW5W-5J7F-JMJJ...

5.8AI score
SaveExploits0
Rows per page
Query Builder