108 matches found
CVE-2025-31877
Technical details for CVE-2025-31877 (affected software, version range, root cause, impact, and remediation) are not provided in the supplied documents. Monitor for updates from official advisories to obtain concrete information.
WordPress plugin RestroPress has a security vulnerability
WordPress and WordPress plugin are both products of the WordPress Foundation.WordPress is a blogging platform developed using the PHP language. The platform supports setting up personal blog sites on servers with PHP and MySQL.WordPress plugin is an application plugin. A security vulnerability...
PT-2025-14253
Name of the Vulnerable Software and Affected Versions Magnigenie RestroPress versions 3.1.8.4 and earlier Description The issue is related to a Missing Authorization vulnerability, which allows exploiting incorrectly configured access control security levels. Recommendations For versions 3.1.8.4...
CVE-2025-31877: Missing Authorization
Missing Authorization vulnerability in Magnigenie RestroPress restropress allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects RestroPress: from n/a through = 3.2.8...
RestroPress – Online Food Ordering System < 3.1.2.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
Description The RestroPress – Online Food Ordering System plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 3.1.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticate...
CVE-2024-35719
Improper Neutralization of Input During Web Page Generation XSS or 'Cross-site Scripting' vulnerability in MagniGenie RestroPress allows Stored XSS.This issue affects RestroPress: from n/a through 3.1.2.1...
CVE-2024-35719
Improper Neutralization of Input During Web Page Generation XSS or 'Cross-site Scripting' vulnerability in MagniGenie RestroPress allows Stored XSS.This issue affects RestroPress: from n/a through 3.1.2.1...
CVE-2024-35719 WordPress RestroPress plugin <= 3.1.2.1 - Cross Site Scripting (XSS) vulnerability
Improper Neutralization of Input During Web Page Generation XSS or 'Cross-site Scripting' vulnerability in MagniGenie RestroPress allows Stored XSS.This issue affects RestroPress: from n/a through 3.1.2.1...
CVE-2024-35719
CVE-2024-35719 is a stored XSS in RestroPress (WordPress) affecting versions up to 3.1.2.1. The vulnerability arises from improper neutralization of input during web page generation, enabling stored cross-site scripting when an authenticated user (Contributor+) submits crafted content. Publicly a...
CVE-2024-35719 WordPress RestroPress plugin <= 3.1.2.1 - Cross Site Scripting (XSS) vulnerability
Improper Neutralization of Input During Web Page Generation XSS or 'Cross-site Scripting' vulnerability in MagniGenie RestroPress allows Stored XSS.This issue affects RestroPress: from n/a through 3.1.2.1...
WordPress plugin RestroPress cross-site scripting vulnerability
WordPress and WordPress plugin are both products of the WordPress Foundation.WordPress is a blogging platform developed using the PHP language. The platform supports setting up personal blog sites on servers with PHP and MySQL.WordPress plugin is an application plug-in. A cross-site scripting...
PT-2024-26669 · Unknown · Magnigenie Restropress
Name of the Vulnerable Software and Affected Versions: MagniGenie RestroPress versions through 3.1.2.1 Description: The issue is related to Improper Neutralization of Input During Web Page Generation, also known as Cross-site Scripting XSS, which allows Stored XSS. This means that an attacker can...
CVE-2024-35719: Improper Neutralization of Input During Web Page Generation
Improper Neutralization of Input During Web Page Generation XSS or 'Cross-site Scripting' vulnerability in MagniGenie RestroPress allows Stored XSS.This issue affects RestroPress: from n/a through 3.1.2.1...
WordPress RestroPress plugin <= 3.1.2.1 - Cross Site Scripting (XSS) vulnerability
Cross Site Scripting XSS vulnerability discovered by LVT-tholv2k Patchstack Alliance in WordPress Plugin RestroPress versions = 3.1.2.1...
WordPress RestroPress Plugin <= 3.1.2.1 is vulnerable to Cross Site Scripting (XSS)
Software RestroPress Type Plugin Vulnerable versions = 3.1.2.1 Fixed in 3.1.2.2 OWASP Top 10 A3: Injection Classification Cross Site Scripting XSS CVE CVE-2024-35719 Patch priority Low CVSS severity Low 6.5 Developer Claim ownership PSID 4f811f4d1bd1 Credits LVT-tholv2k Required privilege...
RestroPress < 3.1.2.1 - Cross-Site Request Forgery via rpress_orders_list_table_process_bulk_actions
Description The RestroPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.1.2. This is due to missing or incorrect nonce validation on the rpressorderslisttableprocessbulkactions function. This makes it possible for unauthenticated attackers ...
CVE-2024-32449
Cross-Site Request Forgery CSRF vulnerability in MagniGenie RestroPress.This issue affects RestroPress: from n/a through 3.1.2...
CVE-2024-32449 WordPress RestroPress plugin <= 3.1.2 - Cross Site Request Forgery (CSRF) vulnerability
Cross-Site Request Forgery CSRF vulnerability in MagniGenie RestroPress.This issue affects RestroPress: from n/a through 3.1.2...
CVE-2024-32449
Technical details about CVE-2024-32449 are not publicly provided in the supplied documents. No affected versions, exploit info, or remediation details are stated here. Monitor for updates from vendors and security advisories.
CVE-2024-32449 WordPress RestroPress plugin <= 3.1.2 - Cross Site Request Forgery (CSRF) vulnerability
Cross-Site Request Forgery CSRF vulnerability in MagniGenie RestroPress.This issue affects RestroPress: from n/a through 3.1.2...