401 matches found
PT-2021-15726
Name of the Vulnerable Software and Affected Versions: Related Posts for WordPress versions prior to 2.0.4 Description: The issue arises from unvalidated input and a lack of output encoding within the plugin, leading to a Reflected Cross-Site Scripting XSS vulnerability. This vulnerability is...
WordPress cross-site scripting vulnerabilities
WordPress is a blogging platform developed by the WordPress Wordpress Foundation using the PHP language. The platform supports personal blog sites on PHP and MySQL servers.Related Posts is a plugin for adding related content to WordPress. A security vulnerability exists in the WordPress Related...
PT-2021-15756 · WordPress · Wordpress Related Posts
Name of the Vulnerable Software and Affected Versions: WordPress Related Posts plugin versions 3.6.4 and earlier Description: The issue concerns an authenticated stored XSS vulnerability in the title field on the settings page. This allows an attacker to execute JavaScript code in the user's...
CVE-2021-24211: Improper Neutralization of Input During Web Page Generation
The WordPress Related Posts plugin through 3.6.4 contains an authenticated admin+ stored XSS vulnerability in the title field on the settings page. By exploiting that an attacker will be able to execute JavaScript code in the user's browser...
CVE-2021-24180: Improper Neutralization of Input During Web Page Generation
Unvalidated input and lack of output encoding within the Related Posts for WordPress plugin before 2.0.4 lead to a Reflected Cross-Site Scripting XSS vulnerability within the 'lang' GET parameter while editing a post, triggered when users with the capability of editing posts access a malicious UR...
WordPress Related Posts <= 3.6.4 - Authenticated Stored Cross-Site Scripting (XSS)
The plugin contains an authenticated admin+ stored XSS vulnerability in the title field on the settings page. By exploiting that an attacker will be able to execute JavaScript code in the user's browser. Put the following payload in the "Related Posts Title" settings of the plugin...
WordPress Related Posts plugin <= 3.6.4 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability
Authenticated Stored Cross-Site Scripting XSS vulnerability discovered by Ganesh Bagaria in WordPress Related Posts plugin versions = 3.6.4. Solution Plugin closed. No patched version is available. Deactivate and delete...
WordPress Related Posts <= 3.6.4 - Authenticated Stored Cross-Site Scripting (XSS)
The plugin contains an authenticated admin+ stored XSS vulnerability in the title field on the settings page. By exploiting that an attacker will be able to execute JavaScript code in the user's browser. PoC Put the following payload in the "Related Posts Title" settings of the plugin...
Contextual Related Posts < 2.9.4 - CSRF Nonce Validation Bypass
The plugin does not properly check for the CSRF nonce in the export and import features, which could allow attackers to make authenticated logged in administrators perform those actions via a CSRF attack. To bypass the nonce validation, just don't send the crpexportsettingsnonce or...
Contextual Related Posts < 2.9.4 - CSRF Nonce Validation Bypass
The plugin does not properly check for the CSRF nonce in the export and import features, which could allow attackers to make authenticated logged in administrators perform those actions via a CSRF attack. PoC To bypass the nonce validation, just don't send the crpexportsettingsnonce or...
WordPress Contextual Related Posts plugin <= 2.9.3 - Cross-Site Request Forgery (CSRF) Nonce Validation Bypass vulnerability
Cross-Site Request Forgery CSRF Nonce Validation Bypass vulnerability found by Lenon Leite in WordPress Contextual Related Posts plugin versions = 2.9.3. Solution Update the WordPress Contextual Related Posts plugin to the latest available version at least 2.9.3...
WordPress Related Posts Plugin Cross-Site Scripting Vulnerability
WordPress is a blogging platform developed by the WordPress Foundation using the PHP language. The platform supports personal blog sites on PHP and MySQL servers.Related Posts is a plugin for adding related content. WordPress Related Posts plugin version 1.8.2 before the cross-site scripting...
CVE-2015-9361
The Related Posts plugin before 1.8.2 for WordPress has XSS via addqueryarg and removequeryarg...
CVE-2015-9361
The CVE-2015-9361 entry concerns the WordPress Related Posts plugin (before 1.8.2). The vulnerability is a cross-site scripting (XSS) flaw triggered via add_query_arg() and remove_query_arg(), allowing injected client-side scripts. Affected component: Related Posts plugin for WordPress; root caus...
CVE-2015-9361
The Related Posts plugin before 1.8.2 for WordPress has XSS via addqueryarg and removequeryarg...
PT-2019-7320
Name of the Vulnerable Software and Affected Versions Related Posts plugin versions prior to 1.8.2 Description The issue concerns a problem with the add query arg and remove query arg functions, which can lead to XSS. Recommendations For versions prior to 1.8.2, update to version 1.8.2 or later t...
CVE-2015-9361: Improper Neutralization of Input During Web Page Generation
The Related Posts plugin before 1.8.2 for WordPress has XSS via addqueryarg and removequeryarg...
WordPress Yuzo Related Posts Plugin Cross-Site Scripting
A Cross-Site Scripting vulnerability exists in WordPress Yuzo Related Posts plugin. Successful exploitation of this vulnerability would allow remote attackers to inject an arbitrary web script into the affected system...
Design/Logic Flaw
The Yuzo Related Posts plugin 5.12.94 for WordPress has XSS because it mistakenly expects that isadmin verifies that the request comes from an admin user it actually only verifies that the request is for an admin page. An unauthenticated attacker can inject a payload into the plugin settings, suc...
CVE-2019-11869
The Yuzo Related Posts plugin 5.12.94 for WordPress has XSS because it mistakenly expects that isadmin verifies that the request comes from an admin user it actually only verifies that the request is for an admin page. An unauthenticated attacker can inject a payload into the plugin settings, suc...