9033 matches found
SUSE SLES12 Security Update : squid (SUSE-SU-2024:0296-1)
The remote SUSE Linux SLES12 / SLESSAP12 host has a package installed that is affected by multiple vulnerabilities as referenced in the SUSE-SU-2024:0296-1 advisory. - CVE-2023-50269: fixed X-Forwarded-For Stack Overflow. bsc1217654 - CVE-2024-23638: fixed Denial of Service attack against Cache...
Debian dla-3726 : bind9 - security update
The remote Debian 10 host has packages installed that are affected by a vulnerability as referenced in the dla-3726 advisory. - ------------------------------------------------------------------------- Debian LTS Advisory DLA-3726-1 [email protected] https://www.debian.org/lts/security/...
oniguruma: Stack exhaustion in regcomp.c because of recursion in regparse.c
Oniguruma before 6.9.3 allows Stack Exhaustion in regcomp.c because of recursion in regparse.c...
PT-2024-3475
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description The issue is related to a function pfn valid in the Linux kernel's memory management subsystem, which can cause an infinite recursion. This could allow an attacker to cause a denial of...
squid: denial of service in HTTP request parsing
A flaw was found in Squid, which is susceptible to a Denial of Service DoS due to an Uncontrolled Recursion bug, specifically targeting HTTP Request parsing. Exploiting this issue involves a remote client initiating a DoS attack by sending an oversized X-Forwarded-For header when the...
RUSTSEC-2024-0012 Stack overflow during recursive JSON parsing
When parsing untrusted, deeply nested JSON, the stack may overflow, possibly enabling a Denial of Service attack. This was fixed by adding a check for recursion depth...
Stack overflow during recursive JSON parsing
When parsing untrusted, deeply nested JSON, the stack may overflow, possibly enabling a Denial of Service attack. This was fixed by adding a check for recursion depth...
Ubuntu 20.04 LTS / 22.04 LTS / 23.04 / 23.10 : Squid vulnerabilities (USN-6594-1)
The remote Ubuntu 20.04 LTS / 22.04 LTS / 23.04 / 23.10 host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-6594-1 advisory. Joshua Rogers discovered that Squid incorrectly handled HTTP message processing. A remote attacker could possibly use this...
Uncontrolled Recursion in SurrealQL Parsing
In some specific instances, the SurrealQL parser will attempt to recursively parse nested statements or idioms i.e. nested IF and RELATE statements, nested basic idioms and nested access to attributes without checking if the depth limit established by default or in the SURREALMAXCOMPUTATIONDEPTH...
jflex:JflexFuzzer: Security exception in jflex.core.NFA.insertNFA
Project: https://github.com/jflex-de/jflex.git Detailed Report: https://oss-fuzz.com/testcase?key=6079359265865728 Project: jflex Fuzzing Engine: libFuzzer Fuzz Target: JflexFuzzer Job Type: libfuzzerasanjflex Platform Id: linux Crash Type: Security exception Crash Address: Crash State:...
PT-2026-60950
Name of the Vulnerable Software and Affected Versions SurrealDB versions prior to 1.1.0 Description The software fails to enforce recursion depth limits when parsing nested SurrealQL statements, specifically involving IF, RELATE, and attribute access idioms. Authorized attackers can submit querie...
EulerOS 2.0 SP9 : bind (EulerOS-SA-2023-3291)
According to the versions of the bind packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : - The code that processes control channel messages sent to named calls certain functions recursively during packet parsing. Recursion depth is only...
EulerOS 2.0 SP10 : bind (EulerOS-SA-2023-3199)
According to the versions of the bind packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : - The code that processes control channel messages sent to named calls certain functions recursively during packet parsing. Recursion depth is only...
Denial Of Service
squid:buster is vulnerable to Denial Of Service. The vulnerability due to an Uncontrolled Recursion bug configured by sending a large X-Forwarded-For header when the followxforwardedfor feature. It allows a remote attacker to perform Denial of Service attack...
Uncontrolled Recursion (Denial Of Service)
Zigbee TLV in Wireshark 4.2.0 is vulnerable to Uncontrolled Recursion. The vulnerability is due to packet injection or crafted capture file resulting in denial of service...
Uncontrolled Recursion (Denial Of Service)
DOCSIS in Wireshark 4.2.0 is vulnerable to Uncontrolled Recursion. The vulnerability is due to packet injection or crafted capture file resulting in denial of service...
Uncontrolled Recursion (Denial Of Service)
GVCP in Wireshark 4.2.0 is vulnerable to Uncontrolled Recursion. The vulnerability is due to packet injection or crafted capture file resulting in denial of service...
Uncontrolled Recursion (Denial Of Service)
GVCP in Wireshark 4.2.0, 4.0.0 to 4.0.11, and 3.6.0 to 3.6.19 is vulnerable to Uncontrolled Recursion. The vulnerability is due to packet injection or crafted capture file resulting in denial of service...
CLSA-2024-1705077885 Fix of 8 CVEs
SECURITY UPDATE: use-after-free in winclose - debian/patches/CVE-2023-48231.patch: check window is valid, before accessing it - CVE-2023-48231 SECURITY UPDATE: overflow with count for :s command - debian/patches/CVE-2023-48233.patch: abort the :s command if the count is too large - CVE-2023-48233...
Ubuntu 16.04 ESM / 18.04 ESM / 20.04 LTS / 22.04 LTS : Go vulnerabilities (USN-6038-2)
The remote Ubuntu 16.04 ESM / 18.04 ESM / 20.04 LTS / 22.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-6038-2 advisory. USN-6038-1 fixed several vulnerabilities in Go 1.18. This update provides the corresponding updates for Go 1.13 and G...