39381 matches found
CVE-2019-16449
Adobe Acrobat and Reader versions , 2019.021.20056 and earlier, 2017.011.30152 and earlier, 2017.011.30155 and earlier version, 2017.011.30152 and earlier, and 2015.006.30505 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure...
CVE-2011-3691
Untrusted search path vulnerability in Foxit Reader before 5.0.2.0718 allows local users to gain privileges via a Trojan horse dwmapi.dll, dwrite.dll, or msdrm.dll in the current working directory...
CVE-2018-20312
Foxit Reader before 9.5, and PhantomPDF before 8.3.10 and 9.x before 9.5, has a proxyDoAction race condition that can cause a stack-based buffer overflow or an out-of-bounds read, a different issue than CVE-2018-20310 because of a different opcode...
CVE-2018-20310
Foxit Reader before 9.5, and PhantomPDF before 8.3.10 and 9.x before 9.5, has a proxyDoAction race condition that can cause a stack-based buffer overflow or an out-of-bounds read...
CVE-2011-4220
Investintech.com SlimPDF Reader does not properly restrict the arguments to unspecified function calls, which allows remote attackers to cause a denial of service application crash or possibly execute arbitrary code via a crafted PDF document...
CVE-2012-4759
Untrusted search path vulnerability in facebookplugin.fpi in the Facebook plug-in in Foxit Reader 5.3.1.0606 allows local users to gain privileges via a Trojan horse dwmapi.dll file in the current working directory, as demonstrated by a directory that contains a .pdf file. NOTE: some of these...
CVE-2012-4337
Foxit Reader before 5.3 on Windows XP and Windows 7 allows remote attackers to execute arbitrary code via a PDF document with a crafted attachment that triggers calculation of a negative number during processing of cross references...
CVE-2012-4162
Adobe Reader and Acrobat 9.x before 9.5.2 and 10.x before 10.1.4 on Mac OS X allow attackers to execute arbitrary code or cause a denial of service memory corruption via unspecified vectors, a different vulnerability than CVE-2012-4161...
CVE-2015-8843
The Foxit Cloud Update Service FoxitCloudUpdateService in Foxit Reader 6.1 through 6.2.x and 7.x before 7.2.2, when an update to the Cloud plugin is available, allows local users to gain privileges by writing crafted data to a shared memory region, which triggers memory corruption...
CVE-2009-0691
The Foxit JPEG2000/JBIG2 Decoder add-on before 2.0.2009.616 for Foxit Reader 3.0 before Build 1817 does not properly handle a fatal error during decoding of a JPEG2000 aka JPX header, which allows remote attackers to cause a denial of service memory corruption and application crash or possibly...
CVE-2009-0690
The Foxit JPEG2000/JBIG2 Decoder add-on before 2.0.2009.616 for Foxit Reader 3.0 before Build 1817 does not properly handle a negative value for the stream offset in a JPEG2000 aka JPX stream, which allows remote attackers to cause a denial of service memory corruption and application crash or...
PT-2025-34315
Name of the Vulnerable Software and Affected Versions: Foxit PDF Reader affected versions not specified Description: Foxit PDF Reader contains a flaw in the parsing of JP2 files due to insufficient validation of user-supplied data. This can lead to a read past the end of an allocated object,...
file-reader-utility (>=0.3.0, <=0.5.0) potentially affected by CVE-2025-47273 via setuptools (60.1.0)
setuptools PYPI version 60.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - file-reader-utility =0.3.0, =0.5.0 Source cves: CVE-2025-47273 Source advisory: OSV:GHSA-5RJG-FVGR-3XXF...
file-reader-utility (>=0.3.0, <=0.5.0) potentially affected by CVE-2025-47273 via setuptools (60.1.0)
setuptools PYPI version 60.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - file-reader-utility =0.3.0, =0.5.0 Source cves: CVE-2025-47273 Source advisory: OSV:PYSEC-2025-49...
Alibaba Cloud Linux 3 : 0120: libxml2 (ALINUX3-SA-2024:0120)
The remote Alibaba Cloud Linux 3 host has packages installed that are affected by a vulnerability as referenced in the ALINUX3-SA-2024:0120 advisory. Package updates are available for Alibaba Cloud Linux 3 that fix the following vulnerabilities: CVE-2024-25062: An issue was discovered in libxml2...
PDF Memory Use Code Execution
The vulnerability of PDF viewing and editing programs such as Acrobat DC, Acrobat Reader DC, Acrobat 2017, and Acrobat Reader 2017 is related to the use of memory after it is freed. Exploiting this vulnerability can allow a remote attacker to execute arbitrary code...
PDF Reader Buffer Overflow
The vulnerabilities of PDF viewing and editing programs such as Adobe Acrobat Document Cloud, Adobe Acrobat Reader Document Cloud, Adobe Acrobat 2020, and Adobe Acrobat Reader 2020 are related to reading data beyond the buffer memory. Exploiting these vulnerabilities can allow attackers to gain...
PDF Reader Buffer Overflow
The vulnerabilities of PDF viewing and editing programs such as Adobe Acrobat Document Cloud, Adobe Acrobat Reader Document Cloud, Adobe Acrobat 2020, and Adobe Acrobat Reader 2020 are related to reading data beyond the buffer memory. Exploiting these vulnerabilities can allow attackers to gain...