182302 matches found
CVE-2026-109269: Out-of-bounds Read
ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 contains an information disclosure vulnerability in the JPEG decoder, which performs a read that exposes uninitialized memory when handling crafted input. Attackers can supply a crafted JPEG file for processing to disclose uninitialized memory...
CVE-2026-77366: Authorization Bypass Through User-Controlled Key
obsidian-tc is a governed, agent-ready Model Context Protocol server for Obsidian vaults. Prior to 1.3.1, tool dispatch does not compare the caller-controlled input.vault value with the vault bound to the caller, the JSON Web Token JWT has no vault claim, and the folder access-control list is...
Important: perl-Net-IDN-Encode
Issue Overview: Net::IDN::Punycode versions before 2.590 for Perl allow an out-of-bounds read via integer overflow of the delta accumulator in encodepunycode. The XS backend keeps the punycode delta, and the digit index derived from it, in a signed int. The accumulation delta += m-n h+1 has no...
CVE-2026-109281: Out-of-bounds Read
ImageMagick 7.1.0-21 before 7.1.2-32 contains a heap buffer over-read in its handling of the -fx option, where a certain -fx operation reads beyond the bounds of an allocated heap buffer in specific situations. Attackers who can get a crafted -fx expression processed can read out-of-bounds heap...
Amazon Linux 2 : libsoup (ALAS-2026-3970)
The version of libsoup installed on the remote host is prior to 2.56.0-6. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2-2026-3970 advisory. OOB Read via Integer Overflow on libsoup through libsoup/websocket/soup-websocket-connection.c via processframe leads to...
Medium: libsoup
Issue Overview: OOB Read via Integer Overflow on libsoup through libsoup/websocket/soup-websocket-connection.c via processframe leads to Undefined Behavior CVE-2026-0716 The fix for CVE-2026-0716 commit 6ff7ef0, libsoup 3.6.6 placed the integer overflow guard inside the if masked block, leaving...
TencentOS Server 3: glib2 (TSSA-2026:1148)
The version of Tencent Linux installed on the remote TencentOS Server 3 host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the TSSA-2026:1148 advisory. Package updates are available for TencentOS Server 3 that fix the following vulnerabilities...
EulerOS 2.0 SP11 : perl-XML-LibXML (EulerOS-SA-2026-4273)
According to the versions of the perl-XML-LibXML package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : XML::LibXML versions through 2.0210 for Perl read out-of-bounds heap memory when parsing XML node names containing truncated UTF-8 byte...
EulerOS 2.0 SP11 : sssd (EulerOS-SA-2026-4382)
According to the versions of the sssd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : A flaw was found in SSSD's LDAP sudo provider. When the ldapsudosearchbase option is not explicitly configured, SSSD searches the entire LDAP...
Important: pcre2 security update
The pcre2 package contains a new generation of the Perl Compatible Regular Expression libraries for implementing regular expression pattern matching using the same syntax and semantics as Perl. Security Fixes: pcre2: PCRE2: Out-of-bounds write allows arbitrary code execution via crafted regular...
Important: kernel
Issue Overview: An issue in the Linux kernel's virtio-net/TAP networking path could allow an actor with privileged access inside a guest virtual machine to send specially crafted network packets that corrupt host kernel memory on KVM-based hypervisors running unpatched Linux kernel versions 4.4...
EulerOS 2.0 SP13 : libssh2 (EulerOS-SA-2026-4156)
According to the versions of the libssh2 packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : libssh2 through 1.11.1 grows its publickey list with SSH2REALLOC but does not zero-initialize new entries before parsing populates them, so a par...
EulerOS 2.0 SP11 : nmap (EulerOS-SA-2026-4259)
According to the versions of the nmap packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : Nmap through 7.99 does not keep the IPv6 extension-header walk within the captured packet in ipv6getdataprimitive libnetutil/netutil.cc, so the...
EulerOS 2.0 SP11 : nmap (EulerOS-SA-2026-4349)
According to the versions of the nmap packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : Nmap through 7.99 does not keep the IPv6 extension-header walk within the captured packet in ipv6getdataprimitive libnetutil/netutil.cc, so the...
EulerOS 2.0 SP13 : libssh2 (EulerOS-SA-2026-4065)
According to the versions of the libssh2 packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : libssh2 through 1.11.1 grows its publickey list with SSH2REALLOC but does not zero-initialize new entries before parsing populates them, so a par...
EulerOS 2.0 SP11 : libssh2 (EulerOS-SA-2026-4250)
According to the versions of the libssh2 packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : libssh2 through 1.11.1, fixed in commit 5e47761, contains a double-free vulnerability in the sftpopen function in src/sftp.c that allows a...
EulerOS 2.0 SP11 : expat (EulerOS-SA-2026-4316)
According to the versions of the expat packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : Expat through 2.8.3 contains an out-of-bounds read vulnerability that allows attackers to trigger memory corruption by processing XML with external...
EulerOS 2.0 SP13 : expat (EulerOS-SA-2026-4044)
According to the versions of the expat packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : libexpat before 2.8.2 has an integer overflow in getAttributeId.CVE-2026-56405 Expat through 2.8.3 contains an out-of-bounds read vulnerability tha...
EulerOS 2.0 SP13 : expat (EulerOS-SA-2026-4135)
According to the versions of the expat packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : libexpat before 2.8.2 has an integer overflow in getAttributeId.CVE-2026-56405 Expat through 2.8.3 contains an out-of-bounds read vulnerability tha...
andriller
Andriller CE Edición Comunitaria Andriller es una utilidad de software con una colección de herramientas forenses para teléfonos inteligentes. Realiza adquisición de solo lectura, forensicamente sólida y no destructiva desde dispositivos Android. Tiene características como potente descifrado de...