Lucene search
+L

56 matches found

osv_cve
osv_cve
•added 2026/11/08 1:38 a.m.•8 views

CVE-2026-123591 Hickory DNS 0.26.0-beta.1 before 0.26.2 DNSSEC Validation Bypass via Missing RFC 6840 Checks

Hickory DNS hickory-net 0.26.0-beta.1 before 0.26.2 and hickory-proto through 0.26.0-alpha.1 fail to verify, per RFC 6840 §4.4, that an NSEC or NSEC3 record denying a DS RRset also proves the delegation's NS record exists. Attackers can reuse child-side NSEC or NSEC3 records to fake an insecure...

8.2CVSS6AI score
SaveExploits0References4
CVE
CVE
•added 2026/11/08 1:38 a.m.•11 views

CVE-2026-123591

The Hickory DNS software is vulnerable to a DNSSEC Validation Bypass in hickory-net versions 0.26.0-beta.1 before 0.26.2 and hickory-proto versions through 0.26.0-alpha.1 . The root cause is a failure to comply with RFC 6840 §4.4 , where the software fails to verify that an NSEC or NSEC3 record d...

8.2CVSS5.9AI score0.00134EPSS
SaveExploits0References2
Cvelist
Cvelist
•added 2026/11/08 1:38 a.m.•32 views

CVE-2026-123591 Hickory DNS 0.26.0-beta.1 before 0.26.2 DNSSEC Validation Bypass via Missing RFC 6840 Checks

Hickory DNS hickory-net 0.26.0-beta.1 before 0.26.2 and hickory-proto through 0.26.0-alpha.1 fail to verify, per RFC 6840 §4.4, that an NSEC or NSEC3 record denying a DS RRset also proves the delegation's NS record exists. Attackers can reuse child-side NSEC or NSEC3 records to fake an insecure...

8.2CVSS0.00134EPSS
SaveExploits0References2
Tenable Nessus
Tenable Nessus
•added 2024/09/24 12:00 a.m.•59 views

EulerOS 2.0 SP8 : dnsmasq (EulerOS-SA-2024-2461)

According to the versions of the dnsmasq packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CP...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/09/24 12:00 a.m.•66 views

EulerOS 2.0 SP8 : bind (EulerOS-SA-2024-2456)

According to the versions of the bind packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/09/03 12:00 a.m.•43 views

EulerOS Virtualization 2.12.0 : systemd (EulerOS-SA-2024-2338)

According to the versions of the systemd packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cau...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/09/03 12:00 a.m.•43 views

EulerOS Virtualization 2.12.1 : systemd (EulerOS-SA-2024-2318)

According to the versions of the systemd packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cau...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/08/20 12:00 a.m.•50 views

EulerOS 2.0 SP12 : systemd (EulerOS-SA-2024-2252)

According to the versions of the systemd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/08/20 12:00 a.m.•43 views

EulerOS 2.0 SP12 : systemd (EulerOS-SA-2024-2228)

According to the versions of the systemd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/08/20 12:00 a.m.•44 views

EulerOS Virtualization 2.11.0 : systemd (EulerOS-SA-2024-2187)

According to the versions of the systemd packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denia...

7.5CVSS7.1AI score0.9999EPSS
SaveExploits0References2
Tenable Nessus
Tenable Nessus
•added 2024/08/19 12:00 a.m.•45 views

EulerOS Virtualization 2.10.1 : systemd (EulerOS-SA-2024-2150)

According to the versions of the systemd packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denia...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/08/19 12:00 a.m.•39 views

EulerOS Virtualization 2.10.0 : systemd (EulerOS-SA-2024-2130)

According to the versions of the systemd packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denia...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/08/08 12:00 a.m.•41 views

EulerOS 2.0 SP11 : systemd (EulerOS-SA-2024-2095)

According to the versions of the systemd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CP...

7.5CVSS7.1AI score0.9999EPSS
SaveExploits0References2
Tenable Nessus
Tenable Nessus
•added 2024/07/22 12:00 a.m.•39 views

EulerOS 2.0 SP8 : bind (EulerOS-SA-2024-2018)

According to the versions of the bind packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/07/22 12:00 a.m.•54 views

EulerOS 2.0 SP8 : dnsmasq (EulerOS-SA-2024-2023)

According to the versions of the dnsmasq packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CP...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/07/18 12:00 a.m.•40 views

EulerOS Virtualization 2.10.1 : dnsmasq (EulerOS-SA-2024-1999)

According to the versions of the dnsmasq package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to caus...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/07/16 12:00 a.m.•42 views

EulerOS 2.0 SP9 : systemd (EulerOS-SA-2024-1947)

According to the versions of the systemd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/07/16 12:00 a.m.•54 views

EulerOS 2.0 SP9 : dnsmasq (EulerOS-SA-2024-1954)

According to the versions of the dnsmasq package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/07/16 12:00 a.m.•48 views

EulerOS 2.0 SP9 : systemd (EulerOS-SA-2024-1974)

According to the versions of the systemd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/07/16 12:00 a.m.•57 views

EulerOS 2.0 SP9 : dnsmasq (EulerOS-SA-2024-1927)

According to the versions of the dnsmasq package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS7.2AI score0.9999EPSS
SaveExploits1References3
Rows per page
Query Builder