5814 matches found
PT-2026-34567
Name of the Vulnerable Software and Affected Versions pypdf versions prior to 6.10.2 Description A flaw in the pypdf library allows an attacker to craft a PDF file that causes RAM exhaustion, leading to a denial of service. This occurs when accessing an image using the /FlateDecode filter with...
smart-pdf (2023.9.11.1) potentially affected by CVE-2026-41168 via pypdf (3.16.0)
pypdf PYPI version 3.16.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - smart-pdf 2023.9.11.1 Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...
aiagents4pharma (>=0.0.0, <=1.49.1), aiagents4pharma-ansh (0.0.0) +67 more potentially affected by CVE-2026-41168 via pypdf (>=6.0.0, <=6.10.0)
pypdf PYPI version =6.0.0, =0.0.0, =1.1.0, =1.0.0a3, =0.2.0, =3.1.0, =0.2.0, =0.2.0, =0.0.3, =0.4.1, =6.2.61, =1.0.20, =1.0.31 and more Source cves: CVE-2026-41168 Source advisory: GHSA-JJ6C-8H6C-HPPX...
calibreweb (0.6.25), cewler (>=1.3.0, <=1.3.1) +8 more potentially affected by CVE-2026-41168 via pypdf (5.4.0)
pypdf PYPI version 5.4.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - calibreweb 0.6.25 - cewler =1.3.0, =1.1.2, =1.1.0, =1.2.0, =2025.3.0, =0.2.2, =28.3.2, =29.1.2 - ten8t 0.0.22 Source cves: CVE-2026-41168 Source...
Improper Validation of Specified Quantity in Input
Overview pypdf is an A pure-python PDF library capable of splitting, merging, cropping, and transforming PDF files Affected versions of this package are vulnerable to Improper Validation of Specified Quantity in Input through the PdfReader object stream and xref stream parsers in pypdf/reader.py...
GHSA-JJ6C-8H6C-HPPX pypdf has long runtimes for wrong size values in cross-reference and object streams
Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with wrong large /Size values or object streams with wrong large /N values. Patches This has been fixed in pypdf==6.10.1. Workarounds If you cannot upgrade yet,...
mimir-ai (0.0.3), rara-digitizer (>=1.0.0, <=1.5.8) potentially affected by CVE-2026-41168 via pypdf (5.0.0)
pypdf PYPI version 5.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - mimir-ai 0.0.3 - rara-digitizer =1.0.0, =1.5.8 Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...
chellow (>=1688456919.0.0, <=1692616986.0.0), cybrex (>=1.0.1, <=1.0.7) potentially affected by CVE-2026-41168 via pypdf (3.12.0)
pypdf PYPI version 3.12.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - chellow =1688456919.0.0, =1.0.1, =1.0.7 Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...
aiagents4pharma (>=0.0.0, <=1.49.1), aiagents4pharma-ansh (0.0.0) +67 more potentially affected by CVE-2026-41168 via pypdf (>=6.0.0, <=6.10.0)
pypdf PYPI version =6.0.0, =0.0.0, =1.1.0, =1.0.0a3, =0.2.0, =3.1.0, =0.2.0, =0.2.0, =0.0.3, =0.4.1, =6.2.61, =1.0.20, =1.0.31 and more Source cves: CVE-2026-41168 Source advisory: SNYK:PYTHON-PYPDF-16081092...
krummstab (>=0.2.0, <=1.2.1) potentially affected by CVE-2026-41168 via pypdf (3.1.0)
pypdf PYPI version 3.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - krummstab =0.2.0, =1.2.1 Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...
ai-enterprise-agent (>=0.0.4, <=0.0.9), almax-common (>=1.0.5.dev20240601224039, <=1.0.7.dev20240801212517) +25 more potentially affected by CVE-2026-41168 via pypdf (4.2.0)
pypdf PYPI version 4.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - ai-enterprise-agent =0.0.4, =1.0.5.dev20240601224039, =2024.7.4, =0.6.22, =0.2.1, =0.2.0, =0.0.5, =0.2.1, =3.3.2, =0.1.0, =0.0.1, =4.7.1, =0.1.0, =0.1...
aiagents4pharma (>=0.0.0, <=1.49.1), aiagents4pharma-ansh (0.0.0) +67 more potentially affected by CVE-2026-41168 via pypdf (>=6.0.0, <=6.10.0)
pypdf PYPI version =6.0.0, =0.0.0, =1.1.0, =1.0.0a3, =0.2.0, =3.1.0, =0.2.0, =0.2.0, =0.0.3, =0.4.1, =6.2.61, =1.0.20, =1.0.31 and more Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...
chellow (>=1692799408.0.0, <=1698672999.0.0), pspdfutils (>=3.1.2, <=3.2.0) potentially affected by CVE-2026-41168 via pypdf (3.15.2)
pypdf PYPI version 3.15.2 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - chellow =1692799408.0.0, =3.1.2, =3.2.0 Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...
chellow (>=1679494175.0.0, <=1688376223.0.0), pretix (>=4.18.0, <=4.18.2.post1) potentially affected by CVE-2026-41168 via pypdf (3.6.0)
pypdf PYPI version 3.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - chellow =1679494175.0.0, =4.18.0, =4.18.2.post1 Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...
agatta (>=0.9.1, <=0.9.4), automate3 (2023.11.7) +5 more potentially affected by CVE-2026-41168 via pypdf (3.17.0)
pypdf PYPI version 3.17.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - agatta =0.9.1, =1698926697.0.0, =9.2.3, =9.2.6 - uniflow 0.0.7 Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...
pspdfutils (>=3.0.5, <=3.0.7) potentially affected by CVE-2026-41168 via pypdf (3.10.0)
pypdf PYPI version 3.10.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - pspdfutils =3.0.5, =3.0.7 Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...
docvec-cli (0.1.0), ingenious (>=0.1.0, <=0.1.3) +3 more potentially affected by CVE-2026-41168 via pypdf (5.5.0)
pypdf PYPI version 5.5.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docvec-cli 0.1.0 - ingenious =0.1.0, =0.1.3b1, =0.2.6, =29.1.3, =30.0.4 Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...
centricube-langchain (>=1.2.3, <=1.3.0), centricube-pyautogen (>=0.3.2, <=0.3.3) +5 more potentially affected by CVE-2026-41168 via pypdf (5.6.1)
pypdf PYPI version 5.6.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - centricube-langchain =1.2.3, =0.3.2, =0.3.0, =0.1.0, =0.0.11, =0.0.3, =0.0.5 Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...
chat-with-mlx (>=0.1.0, <=0.1.11), crewai-files (>=1.9.0, <=1.10.1a1) +9 more potentially affected by CVE-2026-41168 via pypdf (4.0.2)
pypdf PYPI version 4.0.2 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - chat-with-mlx =0.1.0, =1.9.0, =3.2.0, =1.2.1, =1.0.9, =0.0.0, =0.1.2, =0.73.0, =0.94.0 Source cves: CVE-2026-41168 Source advisory:...
iiiflow (>=0.1.0, <=1.3.2), mayan-edms (>=4.5.0, <=4.5.8) potentially affected by CVE-2026-41168 via pypdf (3.14.0)
pypdf PYPI version 3.14.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - iiiflow =0.1.0, =4.5.0, =4.5.8 Source cves: CVE-2026-41168 Source advisory: OSV:GHSA-JJ6C-8H6C-HPPX...