6446 matches found
centricube-langchain (>=1.2.3, <=1.3.0), centricube-pyautogen (>=0.3.2, <=0.3.3) +5 more potentially affected by CVE-2026-27025 via pypdf (5.6.1)
pypdf PYPI version 5.6.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - centricube-langchain =1.2.3, =0.3.2, =0.3.0, =0.1.0, =0.0.11, =0.0.3, =0.0.5 Source cves: CVE-2026-27025 Source advisory: OSV:PYSEC-2026-3024...
nerxiv (>=0.0.1, <=1.1.0), osfexport (>=0.1.4, <=1.0.1) +3 more potentially affected by CVE-2026-27024 via pypdf (5.7.0)
pypdf PYPI version 5.7.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - nerxiv =0.0.1, =0.1.4, =0.0.1, =0.3.3, =30.0.8, =30.0.9 Source cves: CVE-2026-27024 Source advisory: OSV:PYSEC-2026-3013...
nerxiv (>=0.0.1, <=1.1.0), osfexport (>=0.1.4, <=1.0.1) +3 more potentially affected by CVE-2026-27026 via pypdf (5.7.0)
pypdf PYPI version 5.7.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - nerxiv =0.0.1, =0.1.4, =0.0.1, =0.3.3, =30.0.8, =30.0.9 Source cves: CVE-2026-27026 Source advisory: OSV:PYSEC-2026-3015...
nerxiv (>=0.0.1, <=1.1.0), osfexport (>=0.1.4, <=1.0.1) +3 more potentially affected by CVE-2026-27025 via pypdf (5.7.0)
pypdf PYPI version 5.7.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - nerxiv =0.0.1, =0.1.4, =0.0.1, =0.3.3, =30.0.8, =30.0.9 Source cves: CVE-2026-27025 Source advisory: OSV:PYSEC-2026-3024...
label-sorter (>=0.2.0, <=0.3.0), sereto (0.3.5) potentially affected by CVE-2026-27024 via pypdf (5.8.0)
pypdf PYPI version 5.8.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - label-sorter =0.2.0, =0.3.0 - sereto 0.3.5 Source cves: CVE-2026-27024 Source advisory: OSV:PYSEC-2026-3013...
label-sorter (>=0.2.0, <=0.3.0), sereto (0.3.5) potentially affected by CVE-2026-27026 via pypdf (5.8.0)
pypdf PYPI version 5.8.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - label-sorter =0.2.0, =0.3.0 - sereto 0.3.5 Source cves: CVE-2026-27026 Source advisory: OSV:PYSEC-2026-3015...
label-sorter (>=0.2.0, <=0.3.0), sereto (0.3.5) potentially affected by CVE-2026-27025 via pypdf (5.8.0)
pypdf PYPI version 5.8.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - label-sorter =0.2.0, =0.3.0 - sereto 0.3.5 Source cves: CVE-2026-27025 Source advisory: OSV:PYSEC-2026-3024...
agentc-llamaindex (0.2.5a2), agentia (>=0.0.2, <=0.0.10) +246 more potentially affected by CVE-2026-27024 via pypdf (5.9.0)
pypdf PYPI version 5.9.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - agentc-llamaindex 0.2.5a2 - agentia =0.0.2, =0.0.1, =0.1.4, =0.1.0a0.dev0, =0.2.0a0, =0.11.2, =1.1.0a20250429, =3.1.8, =1.0.5, =1.0.0, =0.1.0, =1.1.1,...
agentc-llamaindex (0.2.5a2), agentia (>=0.0.2, <=0.0.10) +246 more potentially affected by CVE-2026-27026 via pypdf (5.9.0)
pypdf PYPI version 5.9.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - agentc-llamaindex 0.2.5a2 - agentia =0.0.2, =0.0.1, =0.1.4, =0.1.0a0.dev0, =0.2.0a0, =0.11.2, =1.1.0a20250429, =3.1.8, =1.0.5, =1.0.0, =0.1.0, =1.1.1,...
agentc-llamaindex (0.2.5a2), agentia (>=0.0.2, <=0.0.10) +246 more potentially affected by CVE-2026-27025 via pypdf (5.9.0)
pypdf PYPI version 5.9.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - agentc-llamaindex 0.2.5a2 - agentia =0.0.2, =0.0.1, =0.1.4, =0.1.0a0.dev0, =0.2.0a0, =0.11.2, =1.1.0a20250429, =3.1.8, =1.0.5, =1.0.0, =0.1.0, =1.1.1,...
aiagents4pharma (>=0.0.0, <=1.49.1), aiagents4pharma-ansh (0.0.0) +51 more potentially affected by CVE-2026-27024 via pypdf (>=6.0.0, <=6.7.0)
pypdf PYPI version =6.0.0, =0.0.0, =0.2.0, =0.2.0, =6.2.61, =1.0.20, =0.12.0, =2.4.23, =1.4.0, =1.4.1 and more Source cves: CVE-2026-27024 Source advisory: OSV:PYSEC-2026-3013...
aiagents4pharma (>=0.0.0, <=1.49.1), aiagents4pharma-ansh (0.0.0) +51 more potentially affected by CVE-2026-27026 via pypdf (>=6.0.0, <=6.7.0)
pypdf PYPI version =6.0.0, =0.0.0, =0.2.0, =0.2.0, =6.2.61, =1.0.20, =0.12.0, =2.4.23, =1.4.0, =1.4.1 and more Source cves: CVE-2026-27026 Source advisory: OSV:PYSEC-2026-3015...
aiagents4pharma (>=0.0.0, <=1.49.1), aiagents4pharma-ansh (0.0.0) +51 more potentially affected by CVE-2026-27025 via pypdf (>=6.0.0, <=6.7.0)
pypdf PYPI version =6.0.0, =0.0.0, =0.2.0, =0.2.0, =6.2.61, =1.0.20, =0.12.0, =2.4.23, =1.4.0, =1.4.1 and more Source cves: CVE-2026-27025 Source advisory: OSV:PYSEC-2026-3024...
PYSEC-2026-3024 pypdf has possible long runtimes/large memory usage for large /ToUnicode streams
Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes and large memory consumption. This requires parsing the /ToUnicode entry of a font with unusually large values, for example during text extraction. Patches This has been fixed in pypdf==6.7.1. Workarounds ...
docat (1.0.0) potentially affected by CVE-2026-27024 via pypdf (4.0.0)
pypdf PYPI version 4.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docat 1.0.0 Source cves: CVE-2026-27024 Source advisory: OSV:PYSEC-2026-3013...
docat (1.0.0) potentially affected by CVE-2026-27025 via pypdf (4.0.0)
pypdf PYPI version 4.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docat 1.0.0 Source cves: CVE-2026-27025 Source advisory: OSV:PYSEC-2026-3024...
pypdf has a possible infinite loop when processing TreeObject
ImpactAn attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires accessing the children of a TreeObject, for example as part of outlines. PatchesThis has been fixed in pypdf==6.7.1. WorkaroundsIf you cannot upgrade yet, consider applying the changes fro...
smart-pdf (2023.9.11.1) potentially affected by CVE-2026-27024 via pypdf (3.16.0)
pypdf PYPI version 3.16.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - smart-pdf 2023.9.11.1 Source cves: CVE-2026-27024 Source advisory: OSV:PYSEC-2026-3013...
pypdf has possible long runtimes/large memory usage for large /ToUnicode streams
ImpactAn attacker who uses this vulnerability can craft a PDF which leads to long runtimes and large memory consumption. This requires parsing the /ToUnicode entry of a font with unusually large values, for example during text extraction. PatchesThis has been fixed in pypdf==6.7.1. WorkaroundsIf...
pypdf possibly has long runtimes for malformed FlateDecode streams
ImpactAn attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires a malformed /FlateDecode stream, where the byte-by-byte decompression is used. PatchesThis has been fixed in pypdf==6.7.1. WorkaroundsIf you cannot upgrade yet, consider applying the changes...