6458 matches found
centricube-langchain (>=1.2.3, <=1.3.0), centricube-pyautogen (>=0.3.2, <=0.3.3) +5 more potentially affected by CVE-2026-27628 via pypdf (5.6.1)
pypdf PYPI version 5.6.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - centricube-langchain =1.2.3, =0.3.2, =0.3.0, =0.1.0, =0.0.11, =0.0.3, =0.0.5 Source cves: CVE-2026-27628 Source advisory: OSV:PYSEC-2026-3005...
fair-llm (>=0.2.0, <=0.6.2), geo-importer (>=0.0.1b1, <=0.0.1b914) +4 more potentially affected by CVE-2026-27628 via pypdf (5.6.0)
pypdf PYPI version 5.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - fair-llm =0.2.0, =0.0.1b1, =30.0.5, =30.0.7 - textspitter 0.4.0b0 Source cves: CVE-2026-27628 Source advisory: OSV:PYSEC-2026-3005...
docvec-cli (0.1.0), ingenious (>=0.1.0, <=0.1.3) +3 more potentially affected by CVE-2026-27628 via pypdf (5.5.0)
pypdf PYPI version 5.5.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docvec-cli 0.1.0 - ingenious =0.1.0, =0.1.3b1, =0.2.6, =29.1.3, =30.0.4 Source cves: CVE-2026-27628 Source advisory: OSV:PYSEC-2026-3005...
sereto (0.2.1), ten8t (>=0.0.14, <=0.0.21) potentially affected by CVE-2026-27628 via pypdf (5.3.1)
pypdf PYPI version 5.3.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - sereto 0.2.1 - ten8t =0.0.14, =0.0.21 Source cves: CVE-2026-27628 Source advisory: OSV:PYSEC-2026-3005...
chellow (>=1679494175.0.0, <=1688376223.0.0), pretix (>=4.18.0, <=4.18.2.post1) potentially affected by CVE-2026-27628 via pypdf (3.6.0)
pypdf PYPI version 3.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - chellow =1679494175.0.0, =4.18.0, =4.18.2.post1 Source cves: CVE-2026-27628 Source advisory: OSV:PYSEC-2026-3005...
pretix (>=4.17.0, <=4.17.1), providentia (2.4.0) potentially affected by CVE-2026-27628 via pypdf (3.4.1)
pypdf PYPI version 3.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - pretix =4.17.0, =4.17.1 - providentia 2.4.0 Source cves: CVE-2026-27628 Source advisory: OSV:PYSEC-2026-3005...
krummstab (>=0.2.0, <=1.2.1) potentially affected by CVE-2026-27628 via pypdf (3.1.0)
pypdf PYPI version 3.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - krummstab =0.2.0, =1.2.1 Source cves: CVE-2026-27628 Source advisory: OSV:PYSEC-2026-3005...
calibreweb (0.6.20) potentially affected by CVE-2026-27628 via pypdf (3.5.2)
pypdf PYPI version 3.5.2 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - calibreweb 0.6.20 Source cves: CVE-2026-27628 Source advisory: OSV:PYSEC-2026-3005...
criscostack (1.0.0), neumai (>=0.0.9, <=0.0.36) +2 more potentially affected by CVE-2026-27628 via pypdf (3.9.1)
pypdf PYPI version 3.9.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - criscostack 1.0.0 - neumai =0.0.9, =0.0.17, =2023.6.0, =2024.4.0 Source cves: CVE-2026-27628 Source advisory: OSV:PYSEC-2026-3005...
pypdf has a possible infinite loop when loading circular /Prev entries in cross-reference streams
ImpactAn attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires reading the file. PatchesThis has been fixed in pypdf==6.7.2. WorkaroundsIf users cannot upgrade yet, consider applying the changes from PR 3655...
aiagents4pharma (>=0.0.0, <=1.49.1), aiagents4pharma-ansh (0.0.0) +52 more potentially affected by CVE-2026-27628 via pypdf (>=6.0.0, <=6.7.1)
pypdf PYPI version =6.0.0, =0.0.0, =0.2.0, =0.2.0, =0.0.3, =6.2.61, =1.0.20, =0.12.0, =2.4.23, =1.4.0, =1.4.1 and more Source cves: CVE-2026-27628 Source advisory: OSV:PYSEC-2026-3005...
agentc-llamaindex (0.2.5a2), agentia (>=0.0.2, <=0.0.10) +246 more potentially affected by CVE-2026-27628 via pypdf (5.9.0)
pypdf PYPI version 5.9.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - agentc-llamaindex 0.2.5a2 - agentia =0.0.2, =0.0.1, =0.1.4, =0.1.0a0.dev0, =0.2.0a0, =0.11.2, =1.1.0a20250429, =3.1.8, =1.0.5, =1.0.0, =0.1.0, =1.1.1,...
genai-4-dps-helper (0.2.31), news-scraper-pdf (1.1.6) +5 more potentially affected by CVE-2026-27628 via pypdf (5.3.0)
pypdf PYPI version 5.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - genai-4-dps-helper 0.2.31 - news-scraper-pdf 1.1.6 - polytext =0.1.0, =0.1.0, =0.1.10 - python-pdf-toolkit 0.1.1 - synforge 0.1.0 - textspitter 0.3.7r...
aiexec-base (0.6.4), ano-code (>=0.1.6, <=0.1.11) +39 more potentially affected by CVE-2026-27628 via pypdf (5.1.0)
pypdf PYPI version 5.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - aiexec-base 0.6.4 - ano-code =0.1.6, =0.0.1, =1.0.0, =0.6.0, =0.0.3, =0.1.0, =0.3.1, =3.3.6, =1.0.16, =0.2.37, =1.0.0, =0.1.11, =0.1.24 and more Sourc...
docat (1.0.0) potentially affected by CVE-2026-27628 via pypdf (4.0.0)
pypdf PYPI version 4.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docat 1.0.0 Source cves: CVE-2026-27628 Source advisory: OSV:PYSEC-2026-3005...
PYSEC-2026-3005 pypdf has a possible infinite loop when loading circular /Prev entries in cross-reference streams
Impact An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires reading the file. Patches This has been fixed in pypdf==6.7.2. Workarounds If users cannot upgrade yet, consider applying the changes from PR 3655...
PYSEC-2026-3015 pypdf possibly has long runtimes for malformed FlateDecode streams
Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires a malformed /FlateDecode stream, where the byte-by-byte decompression is used. Patches This has been fixed in pypdf==6.7.1. Workarounds If you cannot upgrade yet, consider applying the chang...
pypdf possibly has long runtimes for malformed FlateDecode streams
ImpactAn attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires a malformed /FlateDecode stream, where the byte-by-byte decompression is used. PatchesThis has been fixed in pypdf==6.7.1. WorkaroundsIf you cannot upgrade yet, consider applying the changes...
krummstab (>=0.2.0, <=1.2.1) potentially affected by CVE-2026-27024 via pypdf (3.1.0)
pypdf PYPI version 3.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - krummstab =0.2.0, =1.2.1 Source cves: CVE-2026-27024 Source advisory: OSV:PYSEC-2026-3013...
krummstab (>=0.2.0, <=1.2.1) potentially affected by CVE-2026-27026 via pypdf (3.1.0)
pypdf PYPI version 3.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - krummstab =0.2.0, =1.2.1 Source cves: CVE-2026-27026 Source advisory: OSV:PYSEC-2026-3015...