6493 matches found
aiexec-base (0.6.4), ano-code (>=0.1.6, <=0.1.11) +39 more potentially affected by CVE-2026-28804 via pypdf (5.1.0)
pypdf PYPI version 5.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - aiexec-base 0.6.4 - ano-code =0.1.6, =0.0.1, =1.0.0, =0.6.0, =0.0.3, =0.1.0, =0.3.1, =3.3.6, =1.0.16, =0.2.37, =1.0.0, =0.1.11, =0.1.24 and more Sourc...
aiagents4pharma (>=1.15.0, <=1.44.0), pypdftotext (>=0.0.6, <=0.0.9) +3 more potentially affected by CVE-2026-28804 via pypdf (5.2.0)
pypdf PYPI version 5.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - aiagents4pharma =1.15.0, =0.0.6, =1.0.1, =1.0.1, =1.0.5 Source cves: CVE-2026-28804 Source advisory: OSV:PYSEC-2026-3014...
genai-4-dps-helper (0.2.31), news-scraper-pdf (1.1.6) +5 more potentially affected by CVE-2026-28804 via pypdf (5.3.0)
pypdf PYPI version 5.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - genai-4-dps-helper 0.2.31 - news-scraper-pdf 1.1.6 - polytext =0.1.0, =0.1.0, =0.1.10 - python-pdf-toolkit 0.1.1 - synforge 0.1.0 - textspitter 0.3.7r...
sereto (0.2.1), ten8t (>=0.0.14, <=0.0.21) potentially affected by CVE-2026-28804 via pypdf (5.3.1)
pypdf PYPI version 5.3.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - sereto 0.2.1 - ten8t =0.0.14, =0.0.21 Source cves: CVE-2026-28804 Source advisory: OSV:PYSEC-2026-3014...
docvec-cli (0.1.0), ingenious (>=0.1.0, <=0.1.3) +3 more potentially affected by CVE-2026-28804 via pypdf (5.5.0)
pypdf PYPI version 5.5.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docvec-cli 0.1.0 - ingenious =0.1.0, =0.1.3b1, =0.2.6, =29.1.3, =30.0.4 Source cves: CVE-2026-28804 Source advisory: OSV:PYSEC-2026-3014...
fair-llm (>=0.2.0, <=0.6.2), geo-importer (>=0.0.1b1, <=0.0.1b914) +4 more potentially affected by CVE-2026-28804 via pypdf (5.6.0)
pypdf PYPI version 5.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - fair-llm =0.2.0, =0.0.1b1, =30.0.5, =30.0.7 - textspitter 0.4.0b0 Source cves: CVE-2026-28804 Source advisory: OSV:PYSEC-2026-3014...
centricube-langchain (>=1.2.3, <=1.3.0), centricube-pyautogen (>=0.3.2, <=0.3.3) +5 more potentially affected by CVE-2026-28804 via pypdf (5.6.1)
pypdf PYPI version 5.6.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - centricube-langchain =1.2.3, =0.3.2, =0.3.0, =0.1.0, =0.0.11, =0.0.3, =0.0.5 Source cves: CVE-2026-28804 Source advisory: OSV:PYSEC-2026-3014...
nerxiv (>=0.0.1, <=1.1.0), osfexport (>=0.1.4, <=1.0.1) +3 more potentially affected by CVE-2026-28804 via pypdf (5.7.0)
pypdf PYPI version 5.7.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - nerxiv =0.0.1, =0.1.4, =0.0.1, =0.3.3, =30.0.8, =30.0.9 Source cves: CVE-2026-28804 Source advisory: OSV:PYSEC-2026-3014...
label-sorter (>=0.2.0, <=0.3.0), sereto (0.3.5) potentially affected by CVE-2026-28804 via pypdf (5.8.0)
pypdf PYPI version 5.8.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - label-sorter =0.2.0, =0.3.0 - sereto 0.3.5 Source cves: CVE-2026-28804 Source advisory: OSV:PYSEC-2026-3014...
agentc-llamaindex (0.2.5a2), agentia (>=0.0.2, <=0.0.10) +246 more potentially affected by CVE-2026-28804 via pypdf (5.9.0)
pypdf PYPI version 5.9.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - agentc-llamaindex 0.2.5a2 - agentia =0.0.2, =0.0.1, =0.1.4, =0.1.0a0.dev0, =0.2.0a0, =0.11.2, =1.1.0a20250429, =3.1.8, =1.0.5, =1.0.0, =0.1.0, =1.1.1,...
aiagents4pharma (>=0.0.0, <=1.49.1), aiagents4pharma-ansh (0.0.0) +52 more potentially affected by CVE-2026-28804 via pypdf (>=6.0.0, <=6.7.4)
pypdf PYPI version =6.0.0, =0.0.0, =1.0.0a3, =0.2.0, =0.2.0, =0.0.3, =6.2.61, =1.0.20, =0.12.0, =2.4.23, =1.4.0, =1.4.1 and more Source cves: CVE-2026-28804 Source advisory: OSV:PYSEC-2026-3014...
PYSEC-2026-3014 pypdf vulnerable to inefficient decoding of ASCIIHexDecode streams
Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /ASCIIHexDecode filter. Patches This has been fixed in pypdf==6.7.5. Workarounds If you cannot upgrade yet, consider applying the changes from PR 3666...
pypdf vulnerable to inefficient decoding of ASCIIHexDecode streams
ImpactAn attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /ASCIIHexDecode filter. PatchesThis has been fixed in pypdf==6.7.5. WorkaroundsIf you cannot upgrade yet, consider applying the changes from PR 3666...
docat (1.0.0) potentially affected by CVE-2026-28804 via pypdf (4.0.0)
pypdf PYPI version 4.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docat 1.0.0 Source cves: CVE-2026-28804 Source advisory: OSV:PYSEC-2026-3014...
calibreweb (0.6.21), sysnet-pdffiller (>=1.1.0, <=1.2.1) potentially affected by CVE-2026-28351 via pypdf (3.15.5)
pypdf PYPI version 3.15.5 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - calibreweb 0.6.21 - sysnet-pdffiller =1.1.0, =1.2.1 Source cves: CVE-2026-28351 Source advisory: OSV:PYSEC-2026-3017...
render50 (9.2.2) potentially affected by CVE-2026-28351 via pypdf (3.15.3)
pypdf PYPI version 3.15.3 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - render50 9.2.2 Source cves: CVE-2026-28351 Source advisory: OSV:PYSEC-2026-3017...
chellow (>=1692799408.0.0, <=1698672999.0.0), pspdfutils (>=3.1.2, <=3.2.0) potentially affected by CVE-2026-28351 via pypdf (3.15.2)
pypdf PYPI version 3.15.2 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - chellow =1692799408.0.0, =3.1.2, =3.2.0 Source cves: CVE-2026-28351 Source advisory: OSV:PYSEC-2026-3017...
bondai (>=0.1.0, <=0.3.0b2) potentially affected by CVE-2026-28351 via pypdf (3.15.1)
pypdf PYPI version 3.15.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - bondai =0.1.0, =0.3.0b2 Source cves: CVE-2026-28351 Source advisory: OSV:PYSEC-2026-3017...
docrx (>=0.0.1, <=0.0.10), paperreview (0.1.0) +1 more potentially affected by CVE-2026-28351 via pypdf (3.15.0)
pypdf PYPI version 3.15.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docrx =0.0.1, =1.1.11, =1.1.13 Source cves: CVE-2026-28351 Source advisory: OSV:PYSEC-2026-3017...
iiiflow (>=0.1.0, <=1.3.2), mayan-edms (>=4.5.0, <=4.5.8) potentially affected by CVE-2026-28351 via pypdf (3.14.0)
pypdf PYPI version 3.14.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - iiiflow =0.1.0, =4.5.0, =4.5.8 Source cves: CVE-2026-28351 Source advisory: OSV:PYSEC-2026-3017...