Lucene search
+L

10202 matches found

Positive Technologies
Positive Technologies
•added 2026/06/10 12:00 a.m.•6 views

PT-2026-75985

An application using spring-security-saml2-service-provider and the REDIRECT binding for SAML 2.0 Login or Logout may be vulnerable to a denial of service by way of an unbounded writer that inflates the compressed SAML payload into memory. Affected versions: Spring Security 5.7.0 through 5.7.23;...

7.5CVSS5.7AI score0.0046EPSS
SaveExploits0References6
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/06/10 12:00 a.m.•6 views

CVE-2026-40988: Uncontrolled Resource Consumption

An application using spring-security-saml2-service-provider and the REDIRECT binding for SAML 2.0 Login or Logout may be vulnerable to a denial of service by way of an unbounded writer that inflates the compressed SAML payload into memory. Affected versions: Spring Security 5.7.0 through 5.7.23;...

7.5CVSS5.7AI score0.0046EPSS
SaveExploits0References3
OSV
OSV
•added 2026/06/09 11:47 p.m.•13 views

CVE-2026-41694 SAML Payloads Decrypted Without Valid Signature

Since Spring Security SAML decrypts SAML Responses as well as elements of SAML LogoutRequests and LogoutResponses without requiring a valid signature, attackers may be able to craft these SAML payloads and use the Service Provider as a decryption oracle. Affected versions: Spring Security 5.7.0...

3.7CVSS5.9AI score
SaveExploits0References3
CVE
CVE
•added 2026/06/09 11:46 p.m.•183 views

CVE-2026-40988

CVE-2026-40988 refers to an issue in the use of the REDIRECT binding for SAML 2.0 Login/Logout with the Spring Security SAML2 Service Provider, where an unbounded writer can inflate the compressed SAML payload in memory, causing a denial of service. The vulnerability affects Spring Security versi...

7.5CVSS5.7AI score0.0046EPSS
SaveExploits0References1Affected Software1
Vulnrichment
Vulnrichment
•added 2026/06/09 11:46 p.m.•20 views

CVE-2026-40988 Unbounded DEFLATE Inflation in SAML 2.0 Service Provider

An application using spring-security-saml2-service-provider and the REDIRECT binding for SAML 2.0 Login or Logout may be vulnerable to a denial of service by way of an unbounded writer that inflates the compressed SAML payload into memory. Affected versions: Spring Security 5.7.0 through 5.7.23;...

7.5CVSS5.7AI score0.0046EPSS
SaveExploits0References1
OSV
OSV
•added 2026/06/09 11:46 p.m.•18 views

CVE-2026-40988 Unbounded DEFLATE Inflation in SAML 2.0 Service Provider

An application using spring-security-saml2-service-provider and the REDIRECT binding for SAML 2.0 Login or Logout may be vulnerable to a denial of service by way of an unbounded writer that inflates the compressed SAML payload into memory. Affected versions: Spring Security 5.7.0 through 5.7.23;...

7.5CVSS5.9AI score
SaveExploits0References3
EUVD
EUVD
•added 2026/06/09 6:30 p.m.•29 views

EUVD-2026-35449

Mem0 versions through 0.2.8, fixed in commit ae7f406, contain a missing authorization vulnerability in the self-hosted server component where the POST /configure endpoint modifies global LLM provider and embedder configuration but only verifies authentication via JWT or X-API-Key without validati...

8.6CVSS5.8AI score0.00525EPSS
SaveExploits0References6
OSV
OSV
•added 2026/06/09 5:17 p.m.•18 views

AZL-89790 CVE-2026-9076 affecting package openssl-fips-provider 3.1.2-2

Issue summary: When CMS password-based decryption RFC 3211 / PWRI key unwrap processes attacker-supplied CMS data, an attacker-chosen stream-mode KEK cipher can trigger a heap out-of-bounds read in kekunwrapkey. Impact summary: A heap buffer over-read may trigger a crash which leads to Denial of...

7.5CVSS6.8AI score0.00707EPSS
SaveExploits0References1
OSV
OSV
•added 2026/06/09 5:17 p.m.•20 views

AZL-89799 CVE-2026-7383 affecting package openssl-fips-provider 3.1.2-2

Issue summary: A signed integer overflow when sizing the destination buffer for Unicode output in ASN1mbstringncopy can lead to a heap buffer overflow. Impact summary: A heap buffer overflow may lead to a crash or possibly attacker controlled code execution or other undefined behaviour. In...

8.1CVSS7.8AI score0.00804EPSS
SaveExploits0References1
OSV
OSV
•added 2026/06/09 5:17 p.m.•41 views

AZL-89808 CVE-2026-45446 affecting package openssl-fips-provider 3.1.2-2

Issue summary: The implementations of AES-SIV RFC 5297 and AES-GCM-SIV RFC 8452 mishandle the authentication of AAD Additional Authenticated Data with an empty ciphertext allowing a forgery of such messages. Impact summary: An attacker can forge empty messages with arbitrary AAD to the victim's...

4.8CVSS6.8AI score0.00236EPSS
SaveExploits0References1
OSV
OSV
•added 2026/06/09 5:17 p.m.•15 views

AZL-89793 CVE-2026-45445 affecting package openssl-fips-provider 3.1.2-2

Issue summary: When an application drives an AES-OCB context through the public EVPCipher one-shot interface, the application-supplied initialisation vector IV is silently discarded. Impact summary: Every message encrypted under the same key uses the same effective nonce regardless of the IV...

7.5CVSS6.8AI score0.00704EPSS
SaveExploits0References1
OSV
OSV
•added 2026/06/09 5:17 p.m.•13 views

AZL-89787 CVE-2026-42767 affecting package openssl-fips-provider 3.1.2-2

Issue summary: An attacker-controlled CMP Certificate Management Protocol server could trigger a NULL pointer dereference in a CMP client application. Impact summary: A NULL pointer dereference causes a crash of the application and a Denial of Service. An attacker controlling a CMP server or acti...

5.9CVSS6.3AI score0.00557EPSS
SaveExploits0References1
OSV
OSV
•added 2026/06/09 5:17 p.m.•36 views

AZL-89805 CVE-2026-42766 affecting package openssl-fips-provider 3.1.2-2

Issue summary: A specially crafted password-encrypted CMS message can trigger a NULL pointer dereference during CMS decryption. Impact summary: This NULL pointer dereference leads to an application crash and a Denial of Service. The CMS PasswordRecipientInfo.keyDerivationAlgorithm field is define...

5.9CVSS6.3AI score0.0106EPSS
SaveExploits0References1
OSV
OSV
•added 2026/06/09 5:17 p.m.•17 views

AZL-89796 CVE-2026-34180 affecting package openssl-fips-provider 3.1.2-2

Issue summary: Parsing a crafted DER-encoded ASN.1 structure with a primitive element whose content exceeds 2 gigabytes in length may cause a heap buffer over-read on 64-bit Unix and Unix-like platforms. Impact summary: The heap buffer over-read may crash the application Denial of Service or to...

7.5CVSS6.9AI score0.01025EPSS
SaveExploits0References1
OSV
OSV
•added 2026/06/09 5:17 p.m.•22 views

AZL-89802 CVE-2026-34182 affecting package openssl-fips-provider 3.1.2-2

Issue Summary: Cryptographic Message Services CMS processing fails to perform sufficient input validation on the cipher and tag length fields of AuthEnvelopedData containers, leading to various potential compromises. Impact Summary: Attackers making use of these vulnerabilities may achieve...

9.1CVSS6.6AI score0.01057EPSS
SaveExploits0References1
Vulnrichment
Vulnrichment
•added 2026/06/09 4:03 p.m.•30 views

CVE-2026-45446 Incorrect Tag Processing for Empty Messages in AES-GCM-SIV and AES-SIV modes

Issue summary: The implementations of AES-SIV RFC 5297 and AES-GCM-SIV RFC 8452 mishandle the authentication of AAD Additional Authenticated Data with an empty ciphertext allowing a forgery of such messages. Impact summary: An attacker can forge empty messages with arbitrary AAD to the victim's...

6.8AI score0.00236EPSS
SaveExploits0References6
Github Security Blog
Github Security Blog
•added 2026/06/09 9:32 a.m.•20 views

Apache Airflow has a Path Traversal issue

The Apache Airflow Samba provider's GCSToSambaOperator joined GCS object names to the SMB destination path without a containment check, so an object named with ../ segments resolved a write path outside the configured destinationpath. An attacker able to write objects into the source GCS bucket —...

6.5CVSS6.1AI score0.0097EPSS
SaveExploits0References7Affected Software1
PyPA
PyPA
•added 2026/06/09 9:16 a.m.•27 views

PYSEC-2026-208

The Apache Airflow Samba provider's GCSToSambaOperator joined GCS object names to the SMB destination path without a containment check, so an object named with ../ segments resolved a write path outside the configured destinationpath. An attacker able to write objects into the source GCS bucket —...

6.5CVSS6.1AI score0.0097EPSS
SaveExploits0References4Affected Software1
NVD
NVD
•added 2026/06/09 9:16 a.m.•30 views

CVE-2026-49818

The Apache Airflow Samba provider's GCSToSambaOperator joined GCS object names to the SMB destination path without a containment check, so an object named with ../ segments resolved a write path outside the configured destinationpath. An attacker able to write objects into the source GCS bucket —...

6.5CVSS0.0097EPSS
SaveExploits0References3
OSV
OSV
•added 2026/06/09 9:16 a.m.•21 views

PYSEC-2026-208

The Apache Airflow Samba provider's GCSToSambaOperator joined GCS object names to the SMB destination path without a containment check, so an object named with ../ segments resolved a write path outside the configured destinationpath. An attacker able to write objects into the source GCS bucket —...

6.5CVSS6.1AI score0.0097EPSS
SaveExploits0References4
Rows per page
Query Builder