53 matches found
PT-2018-5986
Name of the Vulnerable Software and Affected Versions: Apache Sling XSS Protection API versions 1.0.4 through 1.0.18 Apache Sling XSS Protection API Compat version 1.1.0 Apache Sling XSS Protection API version 2.0.0 Description: A flaw in the way URLs are escaped and encoded in the...
CVE-2017-15717: Improper Neutralization of Input During Web Page Generation
A flaw in the way URLs are escaped and encoded in the org.apache.sling.xss.impl.XSSAPIImplgetValidHref and org.apache.sling.xss.impl.XSSFilterImplisValidHref allows special crafted URLs to pass as valid, although they carry XSS payloads. The affected versions are Apache Sling XSS Protection API...
Cross site request forgery (csrf)
In the XSS Protection API module before 1.0.12 in Apache Sling, the method XSS.getValidXML uses an insecure SAX parser to validate the input string, which allows for XXE attacks in all scripts which use this method to validate user input, potentially allowing an attacker to read sensitive data on...
CVE-2016-6798
In the XSS Protection API module before 1.0.12 in Apache Sling, the method XSS.getValidXML uses an insecure SAX parser to validate the input string, which allows for XXE attacks in all scripts which use this method to validate user input, potentially allowing an attacker to read sensitive data on...
CVE-2016-6798
In Apache Sling, the XSS Protection API module is affected: versions before 1.0.12 use an insecure SAX parser in XSS.getValidXML(), enabling XML External Entity (XXE) attacks. This can allow attackers to read filesystem data, enable SSRF, perform port scanning behind a firewall, or cause DoS. Pub...
CVE-2016-5394
In the XSS Protection API module before 1.0.12 in Apache Sling, the encoding done by the XSSAPI.encodeForJSString method is not restrictive enough and for some input patterns allows script tags to pass through unencoded, leading to potential XSS vulnerabilities...
CVE-2016-6798
In the XSS Protection API module before 1.0.12 in Apache Sling, the method XSS.getValidXML uses an insecure SAX parser to validate the input string, which allows for XXE attacks in all scripts which use this method to validate user input, potentially allowing an attacker to read sensitive data on...
CVE-2016-6798: Improper Restriction of XML External Entity Reference
In the XSS Protection API module before 1.0.12 in Apache Sling, the method XSS.getValidXML uses an insecure SAX parser to validate the input string, which allows for XXE attacks in all scripts which use this method to validate user input, potentially allowing an attacker to read sensitive data on...
CVE-2016-5394: Improper Neutralization of Input During Web Page Generation
In the XSS Protection API module before 1.0.12 in Apache Sling, the encoding done by the XSSAPI.encodeForJSString method is not restrictive enough and for some input patterns allows script tags to pass through unencoded, leading to potential XSS vulnerabilities...
PT-2017-9015
Name of the Vulnerable Software and Affected Versions Apache Sling versions prior to 1.0.12 Description The issue concerns the XSS Protection API module in Apache Sling, where the method XSS.getValidXML uses an insecure SAX parser to validate input strings. This allows for XXE attacks in scripts...
PT-2017-8715
Name of the Vulnerable Software and Affected Versions Apache Sling versions prior to 1.0.12 Description The issue arises from the XSS Protection API module, where the encoding performed by the XSSAPI.encodeForJSString method is not restrictive enough. This allows script tags to pass through...
iOS 9.3.4 Patches Critical Code Execution Flaw
Apple last week patched a critical iOS memory corruption vulnerability that could allow attackers to execute code on compromised devices. The flaw was found by Team Pangu, a Chinese hacker group that specializes in building iOS jailbreak tools. The vulnerability is fixed in iOS 9.3.4. “An...
Multiple vulnerabilities in TYPO3 Core
It has been discovered that TYPO3 Core is vulnerable to Arbitrary Code Execution, Path Traversal, Cross-Site Scripting XSS, SQL injection and Information Disclosure. Component Type: TYPO3 Core Affected Versions: 4.2.15 and below, 4.3.8 and below, 4.4.4 and below Vulnerability Types: Arbitrary Cod...