17731 matches found
CVE-2026-2003: Improper Validation of Specified Type of Input
Improper validation of type "oidvector" in PostgreSQL allows a database user to disclose a few bytes of server memory. We have not ruled out viability of attacks that arrange for presence of confidential information in disclosed bytes, but they seem unlikely. Versions before PostgreSQL 18.2, 17.8...
KLA90883 PE vulnerability in PostgreSQL
Heap buffer overflow vulnerability was found in PostgreSQL. Malicious users can exploit this vulnerability to cause denial of service, gain privileges. Original advisories PostgreSQL pgtrgm heap buffer overflow writes pattern onto server memory Exploitation Related products PostgreSQL CVE list...
OPENSUSE-SU-2026:10190-1 postgresql14-14.21-1.1 on GA media
These are all security issues fixed in the postgresql14-14.21-1.1 package on the GA media of openSUSE Tumbleweed...
OPENSUSE-SU-2026:10193-1 postgresql17-17.8-1.1 on GA media
These are all security issues fixed in the postgresql17-17.8-1.1 package on the GA media of openSUSE Tumbleweed...
PostgreSQL security vulnerabilities
PostgreSQL is a set of free object-relational database management systems developed by the PostgreSQL organization. This system supports most SQL standards and offers many other features, such as foreign keys, triggers, views, etc. Security vulnerabilities existed in versions prior to PostgreSQL...
OPENSUSE-SU-2026:10192-1 postgresql16-16.12-1.1 on GA media
These are all security issues fixed in the postgresql16-16.12-1.1 package on the GA media of openSUSE Tumbleweed...
DSA-6132-1 postgresql-15 - security update
Bulletin has no description...
DSA-6133-1 postgresql-17 - security update
Bulletin has no description...
OPENSUSE-SU-2026:10191-1 postgresql15-15.16-1.1 on GA media
These are all security issues fixed in the postgresql15-15.16-1.1 package on the GA media of openSUSE Tumbleweed...
Vulnerability in contrib module (CVE-2026-2007)
PostgreSQL pgtrgm heap buffer overflow writes pattern onto server memory Heap buffer overflow in PostgreSQL pgtrgm allows a database user to achieve unknown impacts via a crafted input string. The attacker has limited control over the byte patterns to be written, but we have not ruled out the...
Vulnerability in contrib module (CVE-2026-2005)
PostgreSQL pgcrypto heap buffer overflow executes arbitrary code Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected...
Vulnerability in contrib module (CVE-2026-2004)
PostgreSQL intarray missing validation of type of input to selectivity estimator executes arbitrary code Missing validation of type of input in PostgreSQL intarray extension selectivity estimator function allows an object creator to execute arbitrary code as the operating system user running the...
Vulnerability in core server (CVE-2026-2003)
PostgreSQL oidvector discloses a few bytes of memory Improper validation of type "oidvector" in PostgreSQL allows a database user to disclose a few bytes of server memory. We have not ruled out viability of attacks that arrange for presence of confidential information in disclosed bytes, but they...
Vulnerability in core server (CVE-2026-2006)
PostgreSQL missing validation of multibyte character length executes arbitrary code Missing validation of multibyte character length in PostgreSQL text manipulation allows a database user to issue crafted queries that achieve a buffer overrun. That suffices to execute arbitrary code as the...
PostgreSQL security vulnerabilities
PostgreSQL is a set of free object-relational database management systems developed by the PostgreSQL organization. This system supports most SQL standards and offers many other features, such as foreign keys, triggers, views, etc. Security vulnerabilities existed in versions prior to PostgreSQL...
CVE-2026-2361
PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a temporary view based on a function containing malicious code. When the anon.gettablesampleratio function is then called, the malicious code is executed with superuser privileges. This...
UBUNTU-CVE-2026-2361
PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a temporary view based on a function containing malicious code. When the anon.gettablesampleratio function is then called, the malicious code is executed with superuser privileges. This...
CVE-2026-2361 Improper search_path protection in PostgreSQL Anonymizer 2.5 allows any user with create privilege to gain superuser privileges
PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a temporary view based on a function containing malicious code. When the anon.gettablesampleratio function is then called, the malicious code is executed with superuser privileges. This...
CVE-2026-2361 Improper search_path protection in PostgreSQL Anonymizer 2.5 allows any user with create privilege to gain superuser privileges
PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a temporary view based on a function containing malicious code. When the anon.gettablesampleratio function is then called, the malicious code is executed with superuser privileges. This...
CVE-2026-2361
PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a temporary view based on a function containing malicious code. When the anon.gettablesampleratio function is then called, the malicious code is executed with superuser privileges. This...