17813 matches found
CVE-2026-2003
PostgreSQL vulnerability CVE-2026-2003 involves improper validation of the oidvector type, causing disclosure of a few bytes of server memory. Affected versions are before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21. The issue is a memory disclosure risk with network exposure, requiring low pr...
CVE-2026-2007: Heap-based Buffer Overflow
Heap buffer overflow in PostgreSQL pgtrgm allows a database user to achieve unknown impacts via a crafted input string. The attacker has limited control over the byte patterns to be written, but we have not ruled out the viability of attacks that lead to privilege escalation. PostgreSQL 18.1 and...
CVE-2026-2003: Improper Validation of Specified Type of Input
Improper validation of type "oidvector" in PostgreSQL allows a database user to disclose a few bytes of server memory. We have not ruled out viability of attacks that arrange for presence of confidential information in disclosed bytes, but they seem unlikely. Versions before PostgreSQL 18.2, 17.8...
Linux Distros Unpatched Vulnerability : CVE-2026-2361
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a temporary view based on a function containing...
OPENSUSE-SU-2026:10191-1 postgresql15-15.16-1.1 on GA media
These are all security issues fixed in the postgresql15-15.16-1.1 package on the GA media of openSUSE Tumbleweed...
DSA-6132-1 postgresql-15 - security update
Bulletin has no description...
CVE-2026-2005: Heap-based Buffer Overflow
Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected...
PostgreSQL security vulnerabilities
PostgreSQL is a set of free object-relational database management systems developed by the PostgreSQL organization. This system supports most SQL standards and offers many other features, such as foreign keys, triggers, views, etc. Security vulnerabilities existed in versions prior to PostgreSQL...
OPENSUSE-SU-2026:10192-1 postgresql16-16.12-1.1 on GA media
These are all security issues fixed in the postgresql16-16.12-1.1 package on the GA media of openSUSE Tumbleweed...
Linux Distros Unpatched Vulnerability : CVE-2026-2004
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Missing validation of type of input in PostgreSQL intarray extension selectivity estimator function allows an object creator to execute arbitrary code as the...
KLA90883 PE vulnerability in PostgreSQL
Heap buffer overflow vulnerability was found in PostgreSQL. Malicious users can exploit this vulnerability to cause denial of service, gain privileges. Original advisories PostgreSQL pgtrgm heap buffer overflow writes pattern onto server memory Exploitation Related products PostgreSQL CVE list...
Vulnerability in contrib module (CVE-2026-2005)
PostgreSQL pgcrypto heap buffer overflow executes arbitrary code Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected...
KLA90882 Multiple vulnerabilities in PostgreSQL
Multiple vulnerabilities were found in PostgreSQL. Malicious users can exploit these vulnerabilities to obtain sensitive information, execute arbitrary code, cause denial of service. Below is a complete list of vulnerabilities: 1. Improper validation vulnerability in PostgreSQL can be used to...
Vulnerability in contrib module (CVE-2026-2007)
PostgreSQL pgtrgm heap buffer overflow writes pattern onto server memory Heap buffer overflow in PostgreSQL pgtrgm allows a database user to achieve unknown impacts via a crafted input string. The attacker has limited control over the byte patterns to be written, but we have not ruled out the...
CVE-2026-2004: Improper Validation of Specified Type of Input
Missing validation of type of input in PostgreSQL intarray extension selectivity estimator function allows an object creator to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected...
PostgreSQL security vulnerabilities
PostgreSQL is a set of free object-relational database management systems developed by the PostgreSQL organization. This system supports most SQL standards and offers many other features, such as foreign keys, triggers, views, etc. Versions 18.1 and 18.0 of PostgreSQL have security vulnerabilitie...
DSA-6133-1 postgresql-17 - security update
Bulletin has no description...
PostgreSQL security vulnerabilities
PostgreSQL is a set of free object-relational database management systems developed by the PostgreSQL organization. This system supports most SQL standards and offers many other features, such as foreign keys, triggers, views, etc. Vulnerabilities existed in versions prior to PostgreSQL 18.2, 17....
OPENSUSE-SU-2026:10193-1 postgresql17-17.8-1.1 on GA media
These are all security issues fixed in the postgresql17-17.8-1.1 package on the GA media of openSUSE Tumbleweed...
openSUSE 16 Security Update : orthanc, gdcm, orthanc-authorization, orthanc-dicomweb, orthanc-gdcm, orthanc-indexer, orthanc-mysql, orthanc-neuro, orthanc-postgresql, orthanc-python, orthanc-stl, orthanc-tcia, orthanc-wsi, python-pyorthanc (openSUSE-SU-2026:20193-1)
The remote openSUSE 16 host has packages installed that are affected by multiple vulnerabilities as referenced in the openSUSE-SU-2026:20193-1 advisory. Changes in orthanc: - dcmtk 370 breaks TW build - switch to lua 5.4 - patch out boost component system from framework - version 1.12.10 ' long...